14abr
34

Alojamiento Wordpress con Soporte

Algo ha cambiado en la estructura de permisos en WordPress 2.5 que está dando quebraderos de cabeza a usuarios y sus servidores de alojamiento. No ocurre en todas las ocasiones pero cuando le sucede a uno es bastante molesto.

De lo que tratamos hoy es de un problema que provoca que al tratar de subir una imagen desde el panel de escritura de WordPress 2.5 nos muestra este mensaje:

ERROR HTTP

Ha habido un error en la subida. Por favor, inténtalo mas tarde

No es un error exclusivo de la versión 2.5, pues podía suceder en versiones anteriores, pero parece que está siendo mas habitual de lo deseado en esta versión.

La solución pasa por editar el fichero .htaccess, localizado en la carpeta raiz de la instalación de tu WordPress, e incluir las siguientes líneas:

SecFilterEngine Off
SecFilterScanPOST Off

Si por algún motivo no tuvieras permisos para modificar el fichero .htaccess hay un par de trucos que puedes utilizar:

  1. Descargar el fichero existente a tu ordenador, editarlo y volver a subirlo.
  2. Crear un fichero de texto plano en tu ordenador y llamarlo htaccess.txt. Lo subes a tu servidor y lo renombras a .htaccess
  3. Crear un fichero de texto plano en tu ordenador y llamarlo htaccess.txt. Lo subes a tu carpeta “wp-admin” y lo renombras a .htaccess

Y si nada de esto funcionara, he comprobado que con el plugin No Flash Uploader se evita este error en muchos casos. Lo que hace es inhabilitar la carga múltiple de ficheros modificando el cargador de imágenes. Pierdes esta nueva funcionalidad pero consigues subir imágenes al menos de una en una

.

Gracias | MOPE en los foros  Mas información | El Cuaderno Virtual


Valora este artículo para mejorar la calidad del blog ...

MaloPobreNo está malMe gustaExcelente (sin valoración aún)
Loading...Loading...
95d09c7fe0eb9255bfa8002aa9647cbd
Share

Anúnciese aquí »


  • EERR

    Desgraciadamente este es uno de los dolores de cabeza de la versión 2.5, ojala en breve saquen los parches o correcciones por que en esta versión si he tenido algunos problemas.

  • lalaale

    Espero que se apuren con la 2.6 por que si bien no he tenido otro problema mas que este, he detectado algunos detalles que no son muy de mi agrado. Ya hablaré de ellos…

  • http://revista-digital.verdadera-seduccion.com Jack The Ripper

    Yo tuve ese problema al prcipio y tuve que mirar por los foros en inglés. Además tenía un problema que ca vez que entraba en el permalinks me borraba esas 2 líneas.

    Hasta que tuve que hablar con mi hosting para que reconfiguraran eso.

    Un Abrazo

  • mercedes

    Mi problema no es subirlas… Suben bien mi problema es que no se ve ningun tipo de imagen, ni siquiera en la galería. Solo cuadros en blanco… En el post solo sale de vez en cuando un pequeño marcador y al clicar en el si que logro ver la imagen pero en pagina aparte… Me parece que es un problema del Thumbnail… Aunque tampoco las veo si pongo full size… Alguein tiene una solución??? Por cierto que subí un pdf a la galeria y este si qu ese ve perfectamente… No es problema de la plantilla he probado con varias…

    • http://www.tu-video-curriculum.com julieta

      Me pasa esactamente igual que a mercedes!! como lo solucionó ella??

  • http://fernandotellado.com/ Fernando Tellado

    Parece un problema de memoria mas que de WP, pero pásate por el foro y lo vemos mas en detalle ;)

  • Bernardo

    Hola

    Quizá soy un negado para esto pero mi problema es que no logro ver el famoso fichero .htaccesss ni en la raiz del servidor ni en la carpeta donde alojo wordpress (httpdocs).

    Si creo un fichero nuevo tal como dices ¿Basta con que incluya las dos líneas que citas?

  • http://fernandotellado.com/ Fernando Tellado

    Bernardo, puede ser por dos cosas, a saber:

    1. Realmente no hay un fichero htaccess y no se crea porque tu servidor no te deja (permisos de escritura)

    2. Si está pero tu cliente ftp o navegador no te muestra los ficheros ocultos o que empiezan por punto “.” (mira en las opciones)

    Y si, puedes crear un .htaccess nuevo con solo esas dos líneas

  • Oscar

    excelente ayuda.

    Gracias por el tips.

  • Mr.Yin

    Gracias compadre!!!!!!!!!

    hice la modificacion en el htaccess y todo comenzo a funcionar bien!!!!!

  • http://www.oscarmartin.info oscar

    A mi modificando el htaccess me sale un error server 500.
    Me ha funcionado el truco del plugin no flash uploader.

    un saludo

  • http://fernandotellado.com/ Fernando Tellado

    Es una lotería. A ver si arreglan esto en la próxima actualización :(

  • Eiwazh

    flash uploader funcionando correctamente, como siempre muchas gracias ;)

  • http://www.tercermundo.ws/jaguatelevisor Alejandr

    Amigos, gracias por la solución vía .htaccess, yo tengo instalada la versión 2.5 hace meses, pero recien me dió el problema aquí descrito, y cuando estaba por llorar, pues una vez más Ayuda WordPress me salva de un llanto desaforado. Es decir, funciona el truco.

  • http://fernandotellado.com/ Fernando Tellado

    Me alegro Alejandr, aunque no funciona en todos los casos así que en el fondo has tenido suerte :)

  • sergio

    hola tengp la 2.6.1 y me es imposible subir imagenes tengo todos los permisos y nada

  • http://fernandotellado.com/ Fernando Tellado

    @sergio:

    Prueba a actualizar la versión de flash del navegador

  • Mario

    Nada mas hacer mención de que cambie de dirección mi blog “El Cuaderno Virtual” a http://elcuaderno.co.cc por si quisieran hacer la corrección al enlace proporcionado.

    Gracias.

  • http://www.fictisoftware.com DeeJay Marrulla

    Gracias pana, solucione mi problema gracias a la ayuda de este blog. todo bien.

  • http://numerof.com/blog/ numero f

    Gracias majete, ha sido instalar el plugin No Flash Uploader y solucionarme el problema. Se agradece. ;)

  • Poma

    hola buenas tardes. tengo un problema para subir imagenes a mi pagina web con el wordlpress 2.6. al subirlas me aparece el siguiente cartel "No se pudo crear el directorio /home/a9983227/public_html/wp-content/uploads/2008/12. Asegúrate de que el servidor tiene permisos de escritura para el directorio superior." A que se debe este problema? espero respuesta desde ya muchas gracias.

    • http://fernandotellado.com/ Fernando Tellado

      Hola Poma, el mismo mensaje te lo dice:

      No se pudo crear el directorio /home/a9983227/public_html/wp-content/uploads/2008/12. Asegúrate de que el servidor tiene permisos de escritura para el directorio superior.

      Lo que tienes que hacer es comprobar que esa carpeta tiene permisos de escritura y sino dárselos (lo puedes hacer por FTP o desde el panel del alojamiento ;)

  • Poma

    gracias

  • Poma

    hola nuevamente yo. Ya logre solucionar el problema con la imagenes, fue de gran ayuda, pero ahora me surge una nueva duda. Como mi pagina de internet (la cual no publico para no perder visitas) es referente a los celulares, a mi me gustaria subir, por ejemplo, un theme para nokia, y que me aparezca en mi pagina una imagen que diga "download now" y que al presionar este, directamente aparezca la opcion de guardar el archivo en el ordenador de la persona que descargue el theme. La pregunta que tengo es: como hago esto?? en mi version wordpress no aparece opcion alguna ni nada

    Desde ya gracias

  • http://www.tu-video-curriculum.com julieta

    Hola a todos!! tengo un problema al subir imágenes desde mi ordenador a todos mis blogs de wordpress. Solo me deja subirlas si las cuelgo 1 en internet y lo hago como elemento incrustado.

    Tiene que ser algún problema d mi ordenador. He probado tb subir dsd navegador y nada…

    Q puede ser?

    • http://fernandotellado.com/ Fernando Tellado

      Julieta ¿que error te da?, es poca información la que ofreces. Mejor pásate por el foro y lo vemos en detalle. Si fuera solo el cargador flash sería de la versión 10 de Flash como te dije pero si no te deja desde el navegador tampoco parece un tema de permisos de carpetas. Pero vamos, sin detalles es difícil adivinarlo.

  • http://www.tu-video-curriculum.com julieta

    EL problema es ese!! no me da ningún error específico.. la foto carga… pero luego no se ve la típica miniatura q normalmente la gente va cuando le está poniendo el title y eso… :(

  • http://escueladeprogramacion.com escueladeprogramacio

    La solución tamibén está en quitar el modo_seguro' PHP

  • Freshy

    Hola, en mi caso el problema estaba en Ajustes/Multimedia: tenía una barra (/) delante del directorio wp-content.

  • Isabel

    Podeis probar a subir imagenes de una tamaño inferior a 1'5 Mb. 
    Y aseguraros de que en la opcions de multimedia, el cuadro de texto donde pone: "Ruta URL completa a los archivos" tenga el mismo directorio donde subís las imagenes. 
    Saludos

  • francis

    No os recomiendo el plugin Image Upload Error HTTP FIx porque a mi me provocó un error interno y tuve que contactar con mi hosting

  • Ruben Orea

    Hola, tengo wordpress 3.5.1, y me aparece el susodicho error, resulta que no me aparece el fichero .htaccess por ningun sitio, ni en la carpeta raiz de wordpress ni en wp-admin, he probado a crearlo pero meda un error en el servidor, que es XAMMP, estoy trabajando en local. ¿¿A alguien se le ocurre que puede ser??

  • Chocho

    Hola.

    He intentado TODO lo que señalan aca y no PUEDO SUBIR IMAGENES…. alguien me puede decir otra opcion que funcione.

    Saludos.

    • Cherie

      Hola.
      Tengo el mismo error, de un dia a otro aparecio el problema y no he podido solucionarlo. Te ruego si sabes algo lo informes por este medio por favor. Gracias