Error class-amp-polldaddy-embed y class-amp-autoloader en la versión 0.6.0 de AMP

Si instalaste o actualizaste nada más salir a la versión 0.6.0 del plugin AMP es muy probable que todas tus páginas AMP estén mostrando errores en vez de la visualización de las mismas.

Esto es debido a un error con la carga inicial que Automattic hizo de la versión 0.6.0 del plugin AMP que, aunque solucionaron horas más tarde, al no cambiar el número de versión nadie actualizó de nuevo.

Así que si ves este feo error (o similar) al acceder a tus páginas AMP:

Warning: require(/www/wp-content/plugins/amp/wpcom/class-amp-polldaddy-embed.php): failed to open stream: No such file or directory in /www/wp-content/plugins/amp/includes/class-amp-autoloader.php on line 106

Fatal error: require(): Failed opening required ‘/www/wp-content/plugins/amp/wpcom/class-amp-polldaddy-embed.php’ (include_path=’.:/usr/share/php:/usr/share/pear’) in /www/wp-content/plugins/amp/includes/class-amp-autoloader.php on line 106

La solución está en desinstalar el plugin AMP y volver a instalarlo de nuevo. Sí, la misma versión 0.6.0 de AMP, pero que ya está sin el error.

A ver si la próxima vez están más finos, pues Google no se anda con chiquitas con los errores AMP y empieza a mostrar errores de inmediato.

No se puede dejar a medio planeta con errores en las páginas AMP por no cambiar el número de versión de un plugin subido con errores.

¿Te gustó este artículo? ¡No sabes lo que te estás perdiendo en YouTube!
VALORA ESTE ARTÍCULO PARA MEJORAR LA CALIDAD DEL BLOG…
FlojitoNo está malEstá bienMe ha servidoFantástico (1 votos, promedio: 5,00 de 5)
Cargando…

Al dejar una valoración se recopila la IP para evitar fraudes

Autor: Fernando Tellado

Fernando Tellado, apasionado de WordPress, profesor, consultor y ponente. Maquero cansino, padre de tres hijos y de una perrita Beagle, Bilbaíno de nacimiento, Español de corazón y ciudadano de donde me quieran. Mi último libro es WordPress - La guía completa. Mi blog personal es Navegando con red, donde he crecido como escritor en la red y ofrezco mis visiones acerca de la Web 2.0 y la blogosfera. Sigue a @fernandot en Twitter

Comparte esta entrada en
468 ad

Ir al contenido