Actualización automática: conflicto con el tema

Inicio Foros WordPress Instalación / Actualización Actualización automática: conflicto con el tema

Este debate contiene 6 respuestas, tiene 2 mensajes y lo actualizó  LGrusin hace 4 años, 7 meses.

  • Autor
    Publicaciones
  • #75453

    fum
    Participante

    Hola, un saludo a todos pues hace mucho que no ando por aquí.

    Hace varios años armé mi blog con mucha ayuda de este foro y funcionó bien todo este tiempo.

    Ahora, sin aviso, el Equipo de WP actualizó mi sitio automáticamente a 3.7.2 (yo tenía funcionando el 3.7.1 sin ningún problema) esta nueva versión parece que entró en conflicto con el tema que estaba usando Andreas 09 Ciberpress, al que había realizado bastantes cambios hasta ajustarlo a mis necesidades. Ahora aparece una de las columnas con un par de widgets funcionando pero el fondo aparece de un gris pleno y no se ven las entradas, está sin contenido.

    Creo que este tema es viejo y no tiene actualizaciones, escribí a su autor, Andreas Wilkund pero no tuve respuesta. Aparentemente ya no es compatible con las versiones actuales de WP

    Van dos consultas concretas:

    1- Hay modo para intentar recuperar el tema o solucionar el problema?

    2- Si les parece que la cosa no tiene remedio, qué temas de tres columnas me aconsejan, pensando sobre todo en la solidez y respaldo que pueda tener?

    Toda ayuda es bienvenida, muchas gracias desde ya..!

     

     

     

  • #75454

    fum
    Participante

    La dirección por si alguien quiere darse una vuelta y ver el problema:

    carlosfumagalli.com.ar/taller

     

     

     

  • #75461

    LGrusin
    Miembro

    En principio no observo nada extraño, claro que tampoco sé cómo estaba antes…

    Tu mayor problema es haber esperado tanto a actualizar. No sólo tienes una versión de WordPress obsoleta sino que puede que algunos plugins no sean compatibles con tu versión. El theme puede verse afectado si es muy antiguo y/o si usa plugins. Ten en cuenta que cuando actualizas WordPress también debes actualizar los plugins.

    Tanto WordPress como los plugins deben funcionar para las versiones que han sido creadas. Si no es así se producen inconsistencias y errores en el código.

    Un saludo

  • #75601

    fum
    Participante

    Hola cuando entraste no viste el tema roto sino uno que ya estaba probando con el sitio actualizado a 3,9

    Ahora estoy probando el Exray, parece que  va bastante bien y es actual, espero que tenga soporte y se mantenga en el tiempo. Adaptar el sitio es un trabajo que me demanda mucho tiempo y ajustes. Luego comento como me fue.

    Es lógica la necesidad de actualizar los programas, y  estoy muy agradecido de poder usar un programa como WP gratuitamente, pero la actualización forzada es realmente violenta, debieron mandar un aviso, no entiendo que se metan en los sitios como hackers. Estaba usando el 3.7.1 tampoco andaba en la edad de piedra.

    Muchas gracias por tu atención LGrusin, saludos!

  • #75608

    LGrusin
    Miembro

    Las actualizaciones no sólo se deden a mejoras en la seguridad, a veces hay cambios en las versiones de PHP, MySQL, que obligan a realizar modificaciones y/o optimizaciones de código. Si los cambios son muy profundos afectan a la base de datos, themes, plugins y códigos personalizados.

    Sin embargo, estoy totalmente de acuerdo con lo que dices. Aquí tienes un artículo que te indica cómo controlar las actualizaciones automáticas.
    https://ayudawp.com/desactivar-actualizaciones-automaticas-a-partir-de-wordpress-3-7/

    La actualización forzada a veces genera más problemas que los que se pretendían evitar. Supuestamente iba destinada a facilitar la actualización a los usuarios despistados. Claro que si son despistados difícilmente sabrán qué versiones tienen instaladas y los conflictos que les puede ocasionar al actualizar… 😉

    Cuando actualizas manualmente tienes tiempo de averiguar los cambios que se han hecho y anticiparte a los posibles errores, pero automáticamente no hay forma.

    Un saludo

  • #75611

    fum
    Participante

    Me decidí a simplificar el asunto, acepto un cambio total en la estética del sitio y me quedo con Twenty Eleven. Este cambio hace a la identidad del sitio, pero bueno será el momento de la renovación. Hasta ahora va bien, sino encuentro dificultades quedaré con este theme.

    Twenty Eleven es un theme oficial de WP, no? Si es así supongo que será de los más seguros en cuanto a compatibilidad hacia las futuras versiones… quedé sensible con ese asunto !

    Igual voy a desactivar las actualizaciones automáticas, por suerte no me encuentro entre los usuarios más despistados, en realidad estaba renuente a las actualizaciones porque el problema del theme me lo veía venir, ya me había ocurrido con el plugin Next Gen Gallery, no podía emplear la última versión porque ya surgían conflictos.

    Gracias por todo, siempre está aquí la respuesta amiga.

  • #75615

    LGrusin
    Miembro

    Pues me temo que mi respuesta no te dejará tranquilo. Twenty Eleven se creó en el 2011, como su nombre indica. Esto quiere decir que cuando haya actualizaciones de WordPress puede que también requiera actualizaciones del theme, y por lo tanto podrías perder las modificaciones que hayas realizado en él.

    Afortunadamente tienes dos opciones:
    – Crear un child Theme de Twenty Eleven
    o bien
    – Crear tu propio theme partiendo del Twenty Eleven (cambiando el nombre) al que nunca afectarán los cambios.

    Un saludo

El foro ‘Instalación / Actualización’ está cerrado y no se permiten nuevos debates ni respuestas.

Pin It on Pinterest