Actualizado a 2,9 sin problemas.

Inicio Foros WordPress Instalación / Actualización Actualizado a 2,9 sin problemas.

Este debate contiene 28 respuestas, tiene 10 mensajes y lo actualizó  Anónimo hace 8 años, 11 meses.

  • Autor
    Publicaciones
  • #15391

    imported_medievalia
    Participante

    <p>No parece haber problemas al actualizar a 2,9.
    </p>

  • #35154

    imported_Fernando
    Participante

    Yo aún no he tenido tiempo.

    Buena idea la de exponer como va la actualización 😉

  • #35159

    Yoyo
    Participante

    Hola, acabo de probar a actualizar desde la actualización automática y me dá este error

    Fatal error: Out of memory (allocated 30146560) (tried to allocate 2515174 bytes) in /homepages/11/d273835030/htdocs/wp-includes/http.php on line 1331

    Si alguien sabe algo lo agradecería.

    Saludos.

  • #35160

    musicadeptos
    Participante

    Hola

    al intentar actualizar 2,9 sale este error, que nos impide administrar la web y no sabemos cómo repararlo.
    [b]
    Fatal error: Call to undefined function is_admin() in /usr/home/musicadeptos.com/web/wp-includes/vars.php on line 16[/b]

    Sabeis cómo repararlo?

    Gracias

  • #35182

    imported_j.conti
    Participante

    [php]Musicadeptos No estoy muy seguro, pero da la sensación que no te ha realizado bien la actualización.

    Mira de dascargartelo desde wordpress.org y sube los archivo por FTP

    Yoyo, debes aumentar la memoria que puede utilizar php en apache.

    Un saludo

  • #35184

    Yoyo
    Participante

    Yoyo, debes aumentar la memoria que puede utilizar php en apache.
    Un saludo

    Pues perdona mi torpeza pero no tengo ni idea de como se hace eso, es la primera vez que lo escucho.

    Tengo otro blog yoyofv.es también alojado en 1&1 y se ha actualizado sin problemas, pero ese segundo blog aún está vacio y casi sin plugin, en mi blog principal el del error tendré como unos 24 plugins.

    ¿Como se hace eso de la memoria?

    Saludos y gracias

  • #35185

    ToKoTo
    Participante

    Yo estoy como yoyo, no sé como aumentar la memoria.

    Yo he actualizado automáticamente a 2.9 y me ha dejado escribir sin problemas, pero ahora he escrito una entrada con fotos y lleva 15 minutos para actualizar… no sé, algo raro pasa (o es mi blog, que está hecho un desastre)

  • #35187

    imported_Fernando
    Participante

    Hola, acabo de probar a actualizar desde la actualización automática y me dá este error
    Fatal error: Out of memory (allocated 30146560) (tried to allocate 2515174 bytes) in /homepages/11/d273835030/htdocs/wp-includes/http.php on line 1331
    Si alguien sabe algo lo agradecería.
    Saludos.

    Te he contestado en el blog 😉

  • #35188

    imported_Fernando
    Participante

    Para el error de memoria probar esto:

    Mira en wp-settings.php y pon esto así:


    Normalmente pondrá 32M, está en las primeras líneas

  • #35190

    Yoyo
    Participante

    Hola Fernando.

    Ha funcionado lo que comentas de memoria para la actualización y he actualizado a la 2.9, pero ahora al entrar a la administración de mi blog no me sale nada, solo una página en blanco.

    ¿Como arreglamos esto?

    Gracias por todo

    Edito: No abre el blog tampoco de manera normal, solo sale una página en blanco

  • #35193

    Josemi
    Participante

    Me pasa lo mismo que a yoyo. ¡¡AYUDA!!!

  • #35194

    Yoyo
    Participante

    Yo estoy mirando esto a ver si puedo arreglarlo, Josemi, hechale un vistazo

    ¡Mi Blog está en Blanco!, ¿que hago?

  • #35195

    Josemi
    Participante

    Gracias, pero ya le he echado un vistazo y nada T.T.

  • #35197

    imported_Fernando
    Participante

    ¿Habéis probado a cargar la 2.9 por ftp?

  • #35198

    Yoyo
    Participante

    ¿Habéis probado a cargar la 2.9 por ftp?

    Yo con lo que le recomendé a Joemi tampoco lo areglo.

    Fernando si lo cargamos por ftp que hay que subir ¿todo menos el directorio wp-content?

    Un saludo.

  • #35199

    Josemi
    Participante

    Yoyo, así creo que es.

  • #35200

    imported_Sabogal
    Participante

    Creo que no es buena idea actualizar wordpress de forma automática. La razón es que los archivos se sobreescriben y en ese proceso puede resultar algún error.

    Lo más sano en mi opinión es eliminar todos los archivos por ftp [menos wp-content] y luego subir todo desde cero. Eso a mí nunca me ha fallado.

    Saludos!

  • #35202

    ToKoTo
    Participante

    A mi el caso es que después de escribir aquí me volvió a funcionar, instalé un par de temas nuevos que quiero probar y ha petado otra vez… Ahora no sé si es problema de haber actualizado online y no por vía FTP o porque mi hosting ha hecho catacrack (Ferca), bueno, ahora ya no se llama así 😳

  • #35204

    Yoyo
    Participante

    Creo que no es buena idea actualizar wordpress de forma automática. La razón es que los archivos se sobreescriben y en ese proceso puede resultar algún error.
    Lo más sano en mi opinión es eliminar todos los archivos por ftp [menos wp-content] y luego subir todo desde cero. Eso a mí nunca me ha fallado.
    Saludos!

    Pues tienes razon compañero, ya me funciona todo de nuevo.

    Al final es lo que he hecho, he borrado todos todos los archivos y directorios desde el panel de admistración de mi hosting exceptuando el directorio wp-content luego he subido por ftp de nuevo wordpress en ingles (con el español no me funcionaba no se por que) luego he configurado el wp.config.sample.php con los datos de mi base de datos (valga la redundancia) renombrado a wp.config.php subido de nuevo y ya me ha funcionado, aunque esto de meter los datos tambien puede hacerse desde el navegador. Luego solo es subir el idioma español y poner en el wp.config.php es_ES por defecto

    El unico quebradero de cabeza ha sido tener que sacar otra contraseña de mi base de datos pues no la recordaba y ahí fué donde me lié antes un poco.

    Muchas gracias, gracias a Fernando y a todos.

    Saludos.

  • #35208

    imported_Fernando
    Participante

    A ver, os comento … 

    La traducción estaba correcta pero había unos ficheros heredados (de los que no tenía conocimiento) de otras versiones de traducción anteriores, que eran los que provocaban las páginas en blanco.

    Investigando un poco he sustituido los ficheros por los core y ya va todo perfecto tanto en la descarga oficial como actualizando:

    Error de página en blanco tras actualizar

    Lo bueno es que al haber identificado el problema ya no volverá a pasar

  • #35214

    imported_medievalia
    Participante

    Pero fernando, yo leyendo el post, el foro y aun no me he enterado de lo que hay que hacer exactamente para sortear el problema.
    Tengo la pagima del admin en Blanco, y no deja acceder.
    ¿Que hay que hacer exactamente?
    Porque yo he actualizado la version hace solo 15 minutos y tengo el mismo problema.
    Mi dce:
    “No tienes autorización para acceder a esta página”

  • #35215

    imported_Fernando
    Participante

    medievalia, el problema de “No tienes autorización para acceder a esta página” es por las secret keys, nada que ver con la traducción, pasa en muchas actualizaciones.

  • #35216

    imported_medievalia
    Participante

    Entonces que hago para neutralizarlo.
    Es un problema nuevo para mi.

  • #35223

    imported_Fernando
    Participante

    Completa la información requerida.

    Encontrarás esto:

    Vas a la url sugerida: https://api.wordpress.org/secret-key/1.1/

    Y te dará 4 claves (en realidad 4 líneas completas). Sustituyes las del wp-config por las nuevas.

  • #35228

    imported_medievalia
    Participante

    Solucionado, Fernando. Mil gracias

  • #35238

    imported_Fernando
    Participante

    Me alegro. A ver si ya hoy tenemos el día normalito que no veas que sábado el de ayer. Mi familia no entiende tantas horas de trabajo para algo gratis.

  • #35240

    imported_medievalia
    Participante

    Ya somos dos, fernando.

  • #35243

    thinway
    Participante

    @Fernando, @medievalia, me uno al club. Yo creo que esto es el germen de WordPresseros Sin Fronteras 😆

  • #35245

    Anónimo

    Hola,

    He actualizado a wp 2.9 y después de pulsar el botón para actualizar la
    base de datos, se queda mucho tiempo esperando y no sucede nada.

    Dondé puede estar el problema?

    Gracias

El foro ‘Instalación / Actualización’ está cerrado y no se permiten nuevos debates ni respuestas.

Pin It on Pinterest