Adsense dentro del sidebar se muestra en todas las paginas menos en la index

Inicio Foros WordPress General WordPress.org Adsense dentro del sidebar se muestra en todas las paginas menos en la index

Etiquetado: ,

Este debate contiene 16 respuestas, tiene 5 mensajes y lo actualizó  guardafaro hace 8 años, 6 meses.

  • Autor
    Publicaciones
  • #16381

    Micke
    Participante

    <p>Hola, he agregado el código de adense mediante un widget de texto en el sidebar, este se muestra en todas las paginas y temas pero en el index no es asi, no se muestran los anuncios y deberia ser todo lo contrario ya que es donde mas hay texto debido a los temas, alguien sabe por que sucede esto.</p>
    <p>La url en cuestión es http://hipermegared.net</p&gt;
    <p>Gracias de antemano por la ayuda.
    </p>

  • #38058

    josep
    Participante

    pues yo lo veo en el index con el FF y con el IE, hasta en la p´gina CONTACTO. lo que veo también es que no cabe completo el cuadradote

  • #38062

    esnine
    Participante

    yo veo bien la publi en la página principal

  • #38075

    Micke
    Participante

    Casualmente ya sale, siempre es asi, cuando viene la ayuda los problemas ya no están, espero que se mantenga así desde ahora y se muestre la publicidad, y si! el rectángulo es un poco grande pero mas chico descompaginaría un poco, solo son detalles.

    Gracias por el comentario de todos modos.

  • #38081

    josep
    Participante

    Cuando insertas un código nuevo hay un tiempo de carencia, que depende de la página ya que Adsense busca anuncios afines al contenido de la página en cuestión.

    Seguramente se debía a eso el retraso.

    1 saludo

  • #38088

    Micke
    Participante

    Cuando insertas un código nuevo hay un tiempo de carencia, que depende de la página ya que Adsense busca anuncios afines al contenido de la página en cuestión.
    Seguramente se debía a eso el retraso.
    1 saludo

    El bloque de anuncios ya lleva varias semanas creado, el único defecto es que no se muestran anuncios en la pagina principal pero si en las demás, y bueno, hasta ayer todo funcionaba normal e incluso algunos lo vieron, pero hoy día de nuevo no se muestra nada de anuncios -.-!

  • #38089

    josep
    Participante

    Pues será cosa de google, mike, ahora mismo me he asomado de nuevo y sigo viéndolo 😯

  • #38114

    Micke
    Participante

    Pues será cosa de google, mike, ahora mismo me he asomado de nuevo y sigo viéndolo 😯

    Bueno dare por resuelto este tema, quedara como un misterio mas de Google, pero un ultimo detalle, cuando entra al blog, cuantos enlaces muestra el banner de adesense?

    Ademas, cuando logro ver alguno, los enlaces no tienen ninguna relación con el contenido de la pagina principal, sabes alguna forma para que los enlaces se enfoquen específicamente o lo mas cercano a las keyworks?

  • #38125

    josep
    Participante

    cuando no es grafico, muestra 4 enlaces en un /* rectangulo 300×250 */

  • #38127

    imported_j.conti
    Participante

    El tipo de anuncio, lo puedes controlar desde AdSense.

    Puedes poner los tipos de anuncio que quieres que te salgan o incluso lo que no quieres que te salgan, pudiendo llegar a decir de que empresa no quieres que te salgan.

    Si lo dejas genérico. AdSense, se basará en la
    descripción quebré el aninciante.

    Si la hace muy generalista, podría ser que te saliera cualquier cosa. Un ejemplo son las
    páginas de juegos, la lacra que hubo con miara que dia te vas a morir.

    Ya digo, entra en AdSense y configura el anuncio para que sea.para temas mas unidos a tu página.

    Un saludo

  • #38128

    imported_j.conti
    Participante

    Una cosa.

    Otra posibilidad es que estés bloqueando el spider de AdSense.

    ¿No habrás bloqueado el acceso al spider sin querer?

    Mediante metatags o robot.txt

  • #38164

    Micke
    Participante

    Una cosa.
    Otra posibilidad es que estés bloqueando el spider de AdSense.
    ¿No habrás bloqueado el acceso al spider sin querer?
    Mediante metatags o robot.txt

    No, no he bloquedo dicho spider si mal no recuerdo.

  • #38184

    imported_j.conti
    Participante

    Estas bloqueando a todos los spiders (mediante el robots.txt) el acceso a ?s=

    y este debe ser tu problema.

    Si vas a http://hipermegared.net/?s= veras que vas al índex.

    Si lo que quiere es que no hayan URL repetidas por los diferentes
    sistemas, añade rel canonical.

    Prueba a eliminar esa línea a ver si se resuelve el problema.

    Un saludo

  • #38197

    Micke
    Participante

    Estas bloqueando a todos los spiders (mediante el robots.txt) el acceso a ?s=
    y este debe ser tu problema.
    Si vas a http://hipermegared.net/?s= veras que vas al índex.
    Si lo que quiere es que no hayan URL repetidas por los diferentes
    sistemas, añade rel canonical.
    Prueba a eliminar esa línea a ver si se resuelve el problema.
    Un saludo

    He eliminado la linea [b]Disallow: /?s=[/b] del robots.txt y no veo nada de diferente, según tú, si no es al index, a donde mas debería enviar la url http://hipermegared.net/?s=

    De hecho sinceramente no se mucho de las reglas para el robots.txt, lo saque de un manual y no tengo idea para que sea la linea [b]Disallow: /?s=[/b]

    Aun así he retirado todo lo raro del robots.txt y solo he dejado lo mas básico, quedo así:

    User-agent: *
    Disallow: /cgi-bin/
    Disallow: /wp-admin/
    Disallow: /wp-includes/
    Disallow: /wp-content/plugins/
    Disallow: /wp-content/themes/

    # BEGIN XML-SITEMAP-PLUGIN
    Sitemap: http://hipermegared.net/sitemap.xml
    # END XML-SITEMAP-PLUGIN

    De todas formas los enlaces de adsense se muestran muy poco, al menos yo me topo con esa situación, de 10 veces que entro al blog solo 2 veces se muestran enlaces.

    [b]Pero lo raro es que solo sucede en la index, en las paginas o temas se muestra todo normalmente.[/b]

  • #38251

    guardafaro
    Participante

    Pues mira tú por donde, mi hija tiene un problema parecido en su blog.
    Ella llevo tiempo con Adsense. Los códigos de los bloques de anuncios principales se encuentran en los tres sidebars laterales del blog,(uno doble y dos sencillos) que son comunes para todas las páginas del blog con WordPress, o template files.

    En la vista en página principal (index.php) todos los anuncios se muestran correctamente todo el tiempo. Lo mismo ocurre con las vistas en distintas páginas del template file (page.php). Pero cuando se quiere leer el post completo, en la vista en single.php hasta hace poco se veía el anuncio de dos sidebars, pero no el del sidebar derecho. Sin embargo, desde hace unos dias no se está viendo los anuncios de ninguno de los dos sidebar verticales en single.php. Como sabeis, los escripts de Adsense en los sidebars son comunes para todos los template files, por lo que no entiendo lo que ocurre.
    Yo he dejado la consulta en el foro de Adsense, pero no he optenido respuesta.

    La URL de su bog es: http://diariodebodas.es

  • #38255

    Micke
    Participante

    Pues mira tú por donde, mi hija tiene un problema parecido en su blog.

    Un padre hablando de los anuncios adsense del blog de su hija, me sorprende 😀

    Volviendo al tema, tiene razon, en el index.php se muestran los 3 bloques adesense, PERO en el simgle.php tb se muestran tres bloques, aunque esta intentando mostrar 5 lo cual va en contra de las reglas, se muestra el bloque de 336×280 y dos pequeños de 468×60 al final del tema.

    Los otros dos bloques restantes no cargan.

  • #38278

    guardafaro
    Participante

    Gracias, Micke. Tienes razón. Con eso de que pueden coexistir 3 bloques de anuncios estandar, 3 de enlaces y 2 cuadros de búsqueda por página, ella fue a probar añadiendo un bloque de enlaces debajo del bloque de anuncios gráficos estandar en el pie del post en single, pero colocó el código repetido del mismo bloque que tenia, con lo que, como has dicho, había más de tres de ellos, no presentando entonces el del sidebar.
    Misterio aclarado. Ya me parecía a mi que nada tenía que ver con el código de la página.
    Gracias.

El foro ‘General WordPress.org’ está cerrado y no se permiten nuevos debates ni respuestas.

Pin It on Pinterest