Al activar algunos plugins me sale este codigo error

Inicio Foros WordPress Plugins Al activar algunos plugins me sale este codigo error

Este debate contiene 6 respuestas, tiene 3 mensajes y lo actualizó  imported_medievalia hace 9 años, 7 meses.

  • Autor
    Publicaciones
  • #12404

    imported_medievalia
    Participante

    <p>Hola amigos y amigas,<br />
    Tengo un problema con algunos plugins. Me es imposible instalarlos, y una vez instalados no hay manera de activarlos. Sale esto por encima del blog:<br />
    –<br />
    Warning: main(/var/www/vhost/dominio.com/home/html/wp-content/plugins/__MACOSX/): failed to open stream: Success in /var/www/vhost/dominio.com/home/html/wp-settings.php on line 473<br />
    –<br />
    ¿alguien puede ayudarme? Gracias y saludos
    </p>

  • #26764

    Jose Moreno
    Participante

    hola medievalia, algunos plugin vienen con dos versiones dentro de la misma carpeta, una para PC y otra para MAC, al descomprimir el archivo zip del plugin vas a ver que, dentro de la carpeta principal, vienen por lo general 2 carpetas más una con el nombre del plugin y otra que se llama MACOSX, esta última no la subas … es el plugin para los que usan MAC

  • #26771

    imported_medievalia
    Participante

    Hice lo que me recomendaste y nada. Seguió dando el mismo error. No hay manera.
    Y al intetarlo por ftp tampoco. Y ahora tengo archivos que no puedo borrar en el servidor.
    Alguien puede decirme que hacer con archivos que se te pegan en el servidor y no hay manera de eliminar.
    Esto me recuerda a los programas que istalamos en la computadoras y que al desinstalarlos siempre acaban dejando huella.

  • #26773

    imported_study
    Participante

    Por esas lineas en el archivo wp-config.php deberia haber algo así:
    [code]if ( get_option(‘active_plugins’) && !defined(‘WP_INSTALLING’) ) {
    $current_plugins = get_option(‘active_plugins’);
    if ( is_array($current_plugins) ) {
    foreach ($current_plugins as $plugin) {
    if ( ” != $plugin && 0 == validate_file($plugin) && file_exists(WP_PLUGIN_DIR . ‘/’ . $plugin) )
    include_once(WP_PLUGIN_DIR . ‘/’ . $plugin);
    }
    }
    }

    require (ABSPATH . WPINC . ‘/pluggable.php’);[/code]

    ¿El tuyo lo tiene igual? Sino te conviene hacer una copia de seguridad del codigo que tiene actualmente y reemplazar todo por una versión nueva. Si funciona dejalo así, sino restaura la antigua.

  • #26809

    imported_medievalia
    Participante

    Lo siento, pero no entiendo nada de lo que me dices.
    ¿No hay otra forma mas facil de hacer?
    Reemplazar el codigo siempre me sale mal.

  • #26814

    imported_study
    Participante

    primero copias [b]todo[/b] el archivo wp-setting.php y lo salvas. Despues borras el original. Despues te descargas la misma versíon de wordpress que tengas desde [url=http://wordpress.org]wordpress.org[/url]. Descomprimis. y reemplazas el original que borraste por este. Si funciona (podes llegar a perder alguna configuración) lo dejas así. sino reemplazas de nuevo por el original que tenes copiado.

    [b]Importante:[/b] si no sabés mucho de esto y esos plugins que necesitás no son realmente importantes para vos. Te recomendaria que lo dejes como esta a riesgo de dejarlo peor.

  • #28441

    imported_medievalia
    Participante

    Hice con tu última recomendacion.

El foro ‘Plugins’ está cerrado y no se permiten nuevos debates ni respuestas.

Pin It on Pinterest

Ir al contenido