AYUDA. NO SÉ SUBIR MI BLOG A UN SERVIDOR

Inicio Foros WordPress Dominios – Hosting AYUDA. NO SÉ SUBIR MI BLOG A UN SERVIDOR

Etiquetado: , , , ,

Este debate contiene 6 respuestas, tiene 3 mensajes y lo actualizó  locuela hace 9 años, 3 meses.

  • Autor
    Publicaciones
  • #14253

    locuela
    Participante

    <p>Hola a todos, compañeros.</p>
    <p>Bueno, soy una novata en esto de WordPress. Llevo sólo 2 meses usándolo, aunque he hecho muchos avances.<br />
    Mi problema:<br />
    Llevo 2 meses desarrollando contenidos y diseños de un blog wp en un localhost. Ahora que ya lo tengo montado prácticamente, decido subirlo a mi alojamiento en un servidor de pago, y llevo 2 días realizando lo siguiente:<br />
    – Subo toda la carpeta de worpress a mi servidor.<br />
    – Borro de ahí el archivo wp-config.php para que se configure solo.<br />
    – Creo una base de datos para wordpress en mysql de mi servidor.<br />
    – En el navegador introduzco http://www.midominio.com/wp-admin/install.php<br />
    – Introduzco los datos que me pide: nombre base datos, contraseña, etc.<br />
    – WordPress me da una contraseña para mi admin, la copio y la pego para entrar.<br />
    – Exporto mi base de datos localhost.<br />
    – La importo en la base de datos que creé en mi servidor de pago.</p>
    <p>- Y aquí vienen las dudas existenciales y quebraderos de cabeza:</p>
    <p>Cuando me vuelvo a meter en el tablero, pego la clave nueva, me sale un mensaje de "ERROR: Incorrect password. Lost your password?" y me redirecciona al tablero wp de mi localhost para que introduzca la clave.</p>
    <p>He visto que tras la instalación de wordpress en mi servidor, no me ha creado el archivo de wp-config.php. ¿Tengo que grabarlo cambiando antes en él los datos de mi nueva base de datos?<br />
    ¿Cómo lo hago para trabajar en mi blog desde el nuevo servidor de pago, porque se trabaja así, no?</p>
    <p>¿Qué estoy haciendo mal?</p>
    <p>Uso WordPress 2.8, domino XHTML, CSS, y tengo conocimientos elementales de ActionScript, PHP y JavaScript.</p>
    <p>Por favor, ayuda.
    </p>

  • #31822

    fum
    Participante

    Hola Locuela soy principiante pero creo poder responder, espero no decir alguna burrada, según recuerdo de mi instalación el config.php no va a crearse solo.

    [quote]He visto que tras la instalación de wordpress en mi servidor, no me ha creado el archivo de wp-config.php. ¿Tengo que grabarlo cambiando antes en él los datos de mi nueva base de datos?[/quote]

    Sí, tenés que crearlo, entre los archivos de WP vas a encontrar [b]wp-[/b]config-sample.php tenés que editarlo y rellenar:

    [code]/** MySQL database username */
    define(‘DB_USER’, ‘usernamehere’);

    /** MySQL database password */
    define(‘DB_PASSWORD’, ‘yourpasswordhere’);

    /** MySQL hostname */
    define(‘DB_HOST’, ‘localhost’);

    /** Database Charset to use in creating database tables. */
    define(‘DB_CHARSET’, ‘utf8’);

    /** The Database Collate type. Don’t change this if in doubt. */
    define(‘DB_COLLATE’, ”);[/code]

    Tal como dicen los comentarios ingresás el nombre de la BD, tu usuario y contraseña, y la ip del host que lo preguntás a soporte del hosting.

    DB_charset y DB_Collate quedan tal cual si uno no sabe bien qué es lo que está haciendo, como es mi caso.
    Este archivo lo renombrás como [b]wp-[/b]config.php y lo subís a la carpeta donde instalaste WP.

    Espero que ayude, saludos!

    PD: qué simpático tu nick, Locuela.

    pero la simpatía hacia tu nick me lleva a responder

  • #31839

    locuela
    Participante

    Hola, antes de nada, muchas gracias (y también por lo del nick simpático, es por quitarle tanta rigidez a los asuntos, jeje).

    Pues no sé si el instalador me creó el wp-config o yo no lo borré (despiste). El caso es que miré en mi alojamiento y sí que lo tenía.

    Ahora mi problema es el siguiente:
    -Está instalado WP en mi servidor externo y funciona el admin perfectamente.
    – Pero cuando importo la base de datos del localhost en la del servidor externo, ya no funciona el admin, me redirecciona al admin del localhost para que me registre y trabaje ahí.
    Por lógica, yo creo que el problema viene en alguno de los campos de mi tabla en el que reconoce el registro del admin del localhost y lo reemplaza en mi servidor externo una vez que importo la base de datos. Borré los campos de wp-users y wp-usersmeta pero sigue dando el mismo problema.
    ¿Sabéis cuál es?

    MIL GRACIAS DE ANTEMANO.

  • #31841

    Anónimo

    Locuela: soy un neófito en esto, pero si te puedo sugerir dos cosas: El config.php, lo tienen que configurar tu misma, no se crea sólo, tal cual te lo dice fum. Si no te funciona inténtalo con los datos anteriores -con los que ingresaban a tu otro blog-
    Y en el caso de
    [quote] /** MySQL hostname */
    define(‘DB_HOST’, ‘localhost’);

    /** Database Charset to use in creating database tables. */
    define(‘DB_CHARSET’, ‘utf8’);

    /** The Database Collate type. Don’t change this if in doubt. */
    define(‘DB_COLLATE’, ”);[/quote]
    Yo te recomiendo no tocarlos. El DB_Host, incluos te lo dice en la parte baja del mismo archivo config.php

    Espero te funcione esto…

  • #31842

    locuela
    Participante

    Gracias, Perionotas.
    Está así el wp-config. Lo he abierto en un editor para comprobarlo.
    El problema es que al importar mi base de datos del localhost a la del servidor de pago, ya no me reconoce la contraseña del admin del nuevo servidor y me redirecciona a la del localhost, aunque en mi dominio el blog reconoce todo los posts, css, plugins, etc. Por lo que una de dos: o trabajo con el admin del localhost y voy exportando cada dos por tres la base de datos (cosa que me parece muy poco práctica) o tengo que hacer todo prácticamente de nuevo para posteriormente trabajar sólo con el admin de mi servidor de pago.
    Vamos, que me encantaría no tener que copiar y pegar, y revisar todos los post, entradas, plugins, etc, de un admin a otro… ¡Qué curro….! No sé si me explico…

    Sois un encanto por vuestro interés y ganas de ayudar.

  • #31843

    Anónimo

    Locuela, se me ocurre otra cosa que yo hice por sugerencia de Fernando, al no poder ingresar a mi blog:

    [quote]…en el foro de General WordPress.org hay un hilo destacado al efecto:

    http://ayudawp.com/foro/topic/problemas-con-el-login [/quote]
    Espero te sirva

  • #31851

    locuela
    Participante

    Genial. Eso es lo que necesitaba saber!!!
    Mil gracias, Perionotas!!! Jo, qué majos todos.

El foro ‘Dominios – Hosting’ está cerrado y no se permiten nuevos debates ni respuestas.

Pin It on Pinterest

Ir al contenido