Caracteres Especiales PHP

Inicio Foros WordPress Plugins Caracteres Especiales PHP

Este debate contiene 4 respuestas, tiene 2 mensajes y lo actualizó  LGrusin hace 6 años, 8 meses.

  • Autor
    Publicaciones
  • #23657

    mark
    Participante

    <p>Hola. He aquí de nuevo mi ignorancia.<br />
    El problema que tengo ahora es el siguiente:<br />
    Tengo instalado el plugin "Recommend a friend". Cuando le doy a compartir un post en Facebook, los caracteres españoles (ñ, tildes), me los pone en php, por lo que se hace un poco ininteligible la descripción.<br />
    ¿Alguien puede ayudarme a solucionarlo?<br />
    Gracias y Feliz Año!!
    </p>

  • #59161

    mark
    Participante

    Hola de nuevo. Para que no se alargue la respuesta, y si el “salvador” que lea este post necesita más datos: Tengo instalada la última versión de wordpress 3.3.1 en español y el tema Brandford Magazine.
    Sigo esperando…;)
    Gracias.

  • #59164

    LGrusin
    Miembro

    El plugin sólo te permite compartir el enlace.

    No entiendo a qué caracteres te refieres.

    ¿En Facebook o en la ventana del plugin? Además Facebook te pide una descripción.

    Saludos

  • #59207

    mark
    Participante

    Hola, LGrusin.
    Es en Facebook donde me sustituye la ñ y las tildes por los caracteres raros en las descripciones automáticas de los posts que recomiendo. En el blog siempre me los muestra correctos.
    Tengo otros blogs con otras plantillas y no me ocurre este problema.
    ¿Hay algún modo de arreglarlo sin cambiar el tema? Cambiarlo supondría un esfuerzo muy grande ya que el blog lleva meses en internet, con muchos posts y un diseño que no quisiera cambiar.
    Por cierto, en este foro también ocurre el mismo problema. Si le das a recomendar este post en facebook verás cómo la tilde de “aquí” la cambia por otra letra.
    Gracias por tu interés.
    Un saludo.

  • #59212

    LGrusin
    Miembro

    Pues por lo que he podido averiguar Facebook coge los caracteres que se encuentran en la cabecera de tu blog en la etiqueta

    <meta name=”description” content=”

    Por ejemplo, en el foro sale mal porque tiene:

    “<meta name=”description” content=”Hola. He aquí de nuevo mi ignorancia. El problema que tengo ahora es el siguiente: Tengo instalado el plugin “Recommend a friend”. Cuando le doy” />”

    y eso es exactamente lo que sale en Facebook.

    Si ahí no figura bien el texto salen esos caracteres extraños. Intenta con algún plugin de SEO modificar un post y prueba.

    Un saludo

El foro ‘Plugins’ está cerrado y no se permiten nuevos debates ni respuestas.

Pin It on Pinterest