como arreglar este error ?

Inicio Foros WordPress Instalación / Actualización como arreglar este error ?

Este debate contiene 13 respuestas, tiene 3 mensajes y lo actualizó  _eMyDeA_ hace 8 años, 3 meses.

  • Autor
    Publicaciones
  • #11967

    cucoalmeria
    Participante

    <p>Al cambiar los permalinks de forma predeterminada a fecha y nombre del post, cuando quiero acceder desde el blog a las pestañas entradas anteriores me dice esto http://cucoalmeria.net/index.php/Index.php/page/2/ por lo que este error me impide seguir visionando otras entradas. Tiene solución o arreglo para que funcione y poder ver older entradas y new entradas ?.<br />
    Saludos a todos.
    </p>

  • #25700

    CalinSoft
    Participante

    Cual es la estructura de permenlink tienes?
    Otra cosa tu servidor es IIS (Internet Information Server) es por eso que no acepta las urls amigables por que no tiene Mod_Rewrite.

    Entonces en la estructura de permen link podrias poner algo asi

    /index.php/XX/XX/XX donde las xx correspondrian a mes año y el titulo de la noticia

    y asi creo que se resolveria lo de la paginacion tambien.

    pero me parece muy raro. eso se debia hacer automaticamente. que version tienes de wp?

    Saludos.

  • #25701

    cucoalmeria
    Participante

    wp 2.7 gracias por estar ahi

    y esto en .htaccess

    Options +Indexes
    Options +FollowSymLinks
    RewriteEngine on
    RewriteCond ${HTTP_HOST} .
    RewriteCond %{HTTP_HOST} !^cucoalmeria.net
    RewriteRule (.*) http://cucoalmeria.net/$1 [L,R=301]

    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_URI} !(.*)/$
    RewriteRule (.*) http://cucoalmeria.net/$1/ [L,R=301]

    Options All -Indexes

  • #25702

    cucoalmeria
    Participante

    tenia la predeterminada y ahora quiero poner mes y nombre

  • #25703

    cucoalmeria
    Participante

    es que cuando cuando cambio a mes nombre me sale la url anterior que he puesto y veo que sobra un index.php, no ?. El Index que sale con la I en mayuscula.

  • #25708

    CalinSoft
    Participante

    quien cambio tu htacces?
    tu?

    si no borralo todo lo que tienes en el htacces y te vas a permalinks y pones

    /indexp.php/%year%/%monthnum%/%day%/%postname%/

    guardalo

    y cuantame como te fue.

  • #25761

    cucoalmeria
    Participante

    No funciona, si no vuelvo a poner el predeterminado no puedo ver las entradas anteriores, sobre un Index.php en la url, fijate y veras.

  • #25763

    cucoalmeria
    Participante

    He encontrado esta posible solución pero no lo entiendo.

    ……….Luego me enteré bajo IIS, PHP devuelve un valor incorrecto de $ _SERVER [ "REQUEST_URI"]. El enlace a la página anterior se index.php/Index.php/page/2 /. Aviso hay dos "index.php" (para Windows, índice e índice son de la misma.)

    solución es añadir una simple línea de código en el clean_url () en wp-includes/formatting.php:

    $ url = str_replace ( ‘index.php / index.php’, ‘index.php’, $ url);

    Que debo hacer ?

  • #25783

    cucoalmeria
    Participante

    dentro de formating.php, exactamente donde va esa linea ?. Entre que caracteres ?

  • #25795

    CalinSoft
    Participante

    Donde as leido eso ahi deben decir como añadirlo aver pasa la pagina!

  • #25819

    cucoalmeria
    Participante
  • #25849

    cucoalmeria
    Participante

    Calin estás ahi ?

  • #25970

    cucoalmeria
    Participante

    Ayuda he puesto $ url = str_replace ( ‘index.php / index.php’, ‘index.php’, $ url); en la linea 1675 del archivo formatting.php:. El blog funciona perfectamente ahor y se ha ido el doble Index y puedo y paseando por la entradas anteriores pero me da este error cuando quiero entrar al tablero del wp

    
    Warning: Cannot modify header information – headers already sent by (output started at C:Inetpubvhostscucoalmeria.nethttpdocswp-includesformatting.php:1) in C:Inetpubvhostscucoalmeria.nethttpdocswp-includespluggable.php on line 846.

    Alguien tiene la solucion ?.

    gracias.

  • #44987

    _eMyDeA_
    Participante

    Hola! tengo el mismo problema respecto a lo de que me aparece dos veces index.php, pero no acabo de comprender donde tengo que poner ese código dentro de “formatting.php” alguien podría darme alguna linea de referencia? :S

    Gracias!

El foro ‘Instalación / Actualización’ está cerrado y no se permiten nuevos debates ni respuestas.

Pin It on Pinterest

Ir al contenido