Configurar bb-attachments de bb-press

Inicio Foros Otros WordPress y similares bbPress – TalkPress Configurar bb-attachments de bb-press

Etiquetado: 

Este debate contiene 31 respuestas, tiene 8 mensajes y lo actualizó  carloslinux hace 7 años, 2 meses.

  • Autor
    Publicaciones
  • #14327

    imported_Paulo
    Participante

    <p>Hola a todos! Recientemente he realizado un cambio en el sistema de foros, y ahora estoy liadillo con el tema de los plugins y demás modificaciones para poner el foro lo mejor posible…</p>
    <p>He seguido las instrucciones al pie de la letra de como instalar bb-attachements, y en apariencia va bien, pero no soy capaz de subir las imagenes a la carpeta /bb-attachements/…</p>
    <p>Las instrucciones de instalación en inglés son las siguientes:</p>
    <p>

    Quote:
    * make a directory <code>/bb-attachments/</code> ABOVE your webroot ie.<code>/home/username/bb-attachments/</code><br />
    * <code>chmod 777</code> the above <code>/bb-attachments/</code> directory<br />
    * (skip this step if your bbPress is 0.9.0.2 or newer) edit <code>edit-post.php</code> and below <code>&lt;?php edit_form(); ?&gt;</code> put <code>&lt;?php if (function_exists(&#39;bb_attachments&#39;)) {bb_attachments();} ?&gt;</code><br />
    * install plugin in it’s own bb-attachments directory in <code>my-plugins</code> then activate plugin<br />
    * there are some optional settings you can adjust in <code>bb-attachments.php</code>

    </p>
    <p>Igual mi fallo está en lo de crear la carpeta /bb-attachments/… la verdad no se bien donde crearla. En cuanto al tema de los permisos no hay problema.</p>
    <p>Un saludo!
    </p>

  • #32047

    imported_Fernando
    Participante

    la carpeta debe estar en el raiz y tener permisos 777

  • #32057

    imported_Paulo
    Participante

    Nada Fernando, no hay manera… creé la carpeta en la raiz del bbpress le di permisos 777, borré el plugin lo volví a subir, lo activé… lo volvía a desactivar… otra vez todo le proceso cambiando la forma de hacerlo… y nada de nada.

    ¿Alguna sugerencia?

    Gracias de antemano!

    PD: si le quieres echar un vistazo el foro es: http://mundozippo.com/foro/

  • #32082

    imported_Fernando
    Participante

    A ver, rectifico, la carpeta bb-attachments tiene que estar “por encima” de tu carpeta raiz del servidor: http://bbpress.org/plugins/topic/bb-attachments/installation/

  • #32093

    Es decir por encima de la carpeta plubic_html o www si no entiendo mal

  • #32095

    imported_Paulo
    Participante

    Lo que pasa es que no se a que se refiere con “por encima” se supone que la carpeta raiz del foro es mundozippo.com/foro/ una carpeta por encima sería mundozippo.com/ ¿no?

    Es confuso… pero de todas formas he probado situando la carpeta en la carpeta raiz del wordpress y tampoco va… ¿Alguna solución?

    Gracias a todos! 😉

  • #32096

    imported_j.conti
    Participante

    Hola,

    No se habla de carpeta raiz del foro: make a directory /bb-attachments/ [b]ABOVE your webroot ie./home/username/bb-attachments/[/b]

    Si no de la carpeta raíz web, es decir, debes colocarlo en /home/usuario/ aquí crea la carpeta y dale permisos 777 la carpeta se denomina /bb-attachments/ da igual donde tengas instalado bbPress

    Es decir, debes crear la carpeta al mismo nivel que public_html, public_ftp, www, etc…

    Un saludo

  • #32103

    Ya veo creo que lo entendi bien vamos a ello y os comento.

    Ah no todos los hospaedajes te dejan este tipo de acceso al completo,espero que no sea para algunos usuarios un problema.

  • #32106

    Sip ya no me sale el error

    En la version 1.0.2 es necesario insertar las etiquetas php como se menciona o no hace falta, en este paso me pierdo.

  • #32109

    imported_Paulo
    Participante

    Ya he creado la carpeta y le he dado permisos 777.

    Por si a alguien le interesa he creado la carpeta un nivel por encima de donde tengo las carpetas de wordpress (y la del foro).

    Ahora sube las fotos a la perfección, el problema está en que la ruta que pone no es la adecuada y no se muestran… de hecho… que ruta es?

    No se como solucionar el problema… esta es la situación actual tras 4 o 5 pruebas: http://mundozippo.com/foro/topic/fotos-de-zipos

    Saludos!

  • #32112

    Lo ke veo que esta restringida el acceso, puede que sea un problema de permisos.

  • #32283

    imported_Paulo
    Participante

    Hola, el problema persiste… la carpeta que cree tiene permisos 777 está todo tal cual pone en las instrucciones de instalación…alguna sugerencia??

    Saludos y gracias de antemano

  • #32540

    imported_Paulo
    Participante

    |__ -raiz
    ….|__ -mundozippo
    ……..|__ +bb-attachments
    ……..|__ -wordpress
    …………|__ +foro
    …………|__ +wp-includes
    …………|__ +wp-admin
    …………|__ demás carpetas

    Esta es la disposición de las carpetas en mi servidor. la de bb-attachments está con permisos 777 y se pueden subir a ella las fotos y demás archivos perfectamente. Lo que pasa es que a la hora de acceder desde el foro, no las muestra, solo muestra el icono de 16×16 de imagen no encontrada.

    ¿Alguien me puede ayudar? La versión del bbpress es la 1.0.2 la de bb-attachments es la 0.2.7 y las instrucciones de instalación las he seguido al dedillo…

    Gracias de antemano y un saludo!

  • #32542

    imported_j.conti
    Participante

    ¿Has mirado en primer lugar si las imágenes se guardan?
    Ves por FTP y mira si hay imágenes en su interior.

    Y después, en un principio, el directorio no está donde dice en las instrucciones de instalación, debe estar por encima del directorio raíz web. Más arriba lo explico bien.

    Un saludo

  • #32543

    imported_Paulo
    Participante

    Las imagenes se guardan en la carpeta. Así que en un principio, se supone que esa es la ubicación para la carpeta. El problema está despues aquí: http://mundozippo.com/foro/topic/fotos-de-zippos

    Gracias de nuevo 😉

  • #32606

    |__ -raiz
    |___ -bb-attachments
    ….|__ -mundozippo
    ……..|__ -wordpress
    …………|__ +foro
    …………|__ +wp-includes
    …………|__ +wp-admin
    …………|__ demás carpetas

    Paulo caundo nos referimmos a raiz es asi como este ejemplo.
    [b]No se si lo has hecho asi, si es asi pues bueno no he dicho nada, si no hazlo asi.[/b]

  • #32712

    imported_Paulo
    Participante

    Hola de nuevo… sigo daldole vueltas al tema..

    Como comenté anteriormente, las fotos se suben a la carpeta (ya que desde el ftp se pueden ver y descargar sin problema).

    Si pruebo desde el navegador google chrome me sale un mensaje que da pistas del error, pero sigo sigo sin saber cual es… la pista es este mensaje: Sorry, download is restricted. El cual sale en la linea 504 del bb-attachments.php

    Recuerdo que los permisos de la carpeta son 777… ¿Alguien se le ocurre algo?

    Gracias, de antemano y un saludo!

  • #32816

    imported_Paulo
    Participante

    Problema resuelto. ¿Cómo? pues simple. Lo único que hice fue subir la carpeta del plugin a my-plugins (antes la tenía en bb-plugins).

    En fin…tanto lio, y el problema estaba en la carpeta, eso me pasa por no leer….

    Un saludo y gracias a todos!

    PD: Repito por si a alguien le pasa… el plugin se instala en [b]my-plugins[/b] y no en bb-plugins.

  • #32823

    imported_Fernando
    Participante

    Paulo, haznos un repaso de la configuración del tema de carpetas, seguro que nos aclaras con un resumen de como ponerlo bien en marcha 😉

  • #32829

    imported_Paulo
    Participante

    Para la instalación hay que tener en cuenta lo siguiente:

    1. La carpeta de instalación del plugin debe de ser my-plugins
    2. Copiar la carpeta bb-attachments en my-plugins
    3. Muy importante ubicar la carpeta bb-attachments un nivel por encima de donde tengamos instalado el foro. Es decir, si tenemos el foro en la carpeta “foro” que a su vez está en la carpeta “wordpress” debemos crear la carpeta bb-attachments a la misma altura que “worpdress”.

    …-MiBlog
    ……..+[b]bb-attachments[/b]
    ……..-wordpress
    ……………-foro
    ………………..+bb-admin
    ………………..+bb-plugins
    ………………..+bb-templates
    ………………..-my-plugins
    …………………….+bb-attachments
    ……………+wp-admin
    ……………+wp-includes
    ……………+wp-config
    ……………+demás carpetas de wordpress

    4. A la carpeta bb-attachments asignarle permisos 777 (lectura, escritura y ejecución para todo el mundo)
    5. Activar el plugin desde el panel de administración de bbpress.
    6. Listo 🙂 se puede traducir al español modificando un par de lineas del archivo bb-attachments.php

    Un saludo y gracias por la ayuda 😉

  • #32837

    imported_Fernando
    Participante

    ¡Ole! 🙂

    Te ha quedado de rechupete 😉

  • #33206

    carlosdelab
    Participante

    Saludos a todos,

    Yo tengo el mismo problema, no puedo visualizar las imagenes dentro del foro.

    Segun he entendido, creo haber instalado todas las carpetas como debería ser.
    Sin embargo no consigo visualizar las imagenes dentro del foro, sólo un icono que dice que es una imagen. las imagenes las puedo descargar y las puedo ver desde el ftp.

    Pero no consigo visualizar las imagenes. he probado diferentes cosas pero hasta ahora nada me ha funcionado.

    Se que hay un par de líneas de código que se deben chequear dentro de bb-attachments.PHP y tambien lo he hecho.

    Probablemente se me este pasando algo y no lo veo.
    Esperando su respuesta
    saludos y gracias.
    carlos de la b.

    direccion al foro si puede ayudar con información extra.
    http://www.designemergente.org/foro/

    Asi es como las tengo dentro de mi ftp:
    /
    —–bb-attachments/(con los permisos 777)
    ———-0(carpeta donde están las imagenes)
    —–errors
    —–logs
    —–tmp
    —–web/
    ———-foro/
    —————bb-admin
    —————bb-includes
    —————bb-plugins
    —————bb-templates
    —————my-plugins/(permisos 777)
    ——————–bb-attachments(carpeta con el codigo, permisos 777)
    ———-wp-admin
    ———-wp-content
    ———-wp-includes

  • #33207

    EG
    Participante

    utiliza el plugin allow images… es por eso que no se muestran quizas las imagenes no es de bb-attachments

  • #33213

    carlosdelab
    Participante

    Hola Maverick, Muchas Gracias por responder,
    Acabo de instalar el plugin allow Images, y está es la lista de plugins que tengo activados.

    allowimages———–Version 0.7.1
    akismet—————Version 1.1
    bb-pressAttachments—Version 0.2.7
    bozo users————Version 1.1
    Hello Louie———–Version 1.0

    Hay alguna manera de saber si todos ellos estan funcionando correctamente? talvez no me funciona por una razón extra de configuracion u otra cosa.

    Por cierto puedo acceder a las imagenes desde mi ftp. que se encuentran en la carpeta 0 dentro del directorio bb-attachments en la raiz.

    gracias,
    carlos

  • #33215

    EG
    Participante

    para colocar imagenes en el post podrias utilizar bb code toolbar y bb code lite… son plugin para las respuestas… busca en bbpress.org extend… 🙂

  • #33229

    carlosdelab
    Participante

    Muchas gracias Maverick,

    He instalado los plugins que me dices y en principio aparecen los botones, justo como en el recuadro de responder, pero aún sigo sin ver las que subo.

    Me interesa que los usuarios puedan subir sus imagenes desde su ordenador.
    bb-attachment es el unico plug in que hace esto?
    hay otros plugins que permitan subir imagenes y visualizarlas?

    o tengo idea donde puede estar el problema!
    muchas
    gracias.

    http://www.designemergente.org/foro/
    la pagina del foro.
    gracias
    Carlos de la B.

  • #33230

    carlosdelab
    Participante

    está es la direccion donde se guardan mis imagenes.
    http://www.midominio.com/foro/topic.php?id=12&bb_attachments=22&bbat=16
    puede darte algo de información extra?

    Otra cosa es que en el botón IMG donde se linkean las imagenes con la dirección URL, tampoco las visualiza. Sin embargo el botón URL si me permite crear los links.

    gracias
    esperando sus ideas y ayudas.
    c.

  • #33257

    imported_Paulo
    Participante

    A mi me pasaba algo parecido, pero la solución estuvo en cambiar el plugin de carpeta (ya que yo lo tenía en la carpeta bb-plugins y debía estar en la de my-plugins).

    En principio la única carpeta que tiene que tener permisos 777 es la de bbatachtments que creas tu para subir ahí las fotos. La del plugin no tiene que tener los permisos 777.

    Igual el problema está ahí.

    Prueba a borrar el plugin, instalarlo de nuevo, y dale permisos 777 a la carpeta que creas para subir las fotos.

    Saludos!

  • #33269

    carlosdelab
    Participante

    Gracias Paulo,

    Básicamente lo mismo, elimine el plugin y la carpeta de bb-attachments y las volví a subir a través del ftp a los lugares correspondientes, y los mismo.
    no pasa nada.

    tendrá algo que ver el theme? de bb-press que estoy usando?
    Kakumei Blue 1.0

    esperando ideas,
    gracias
    c.

  • #33811

    malder
    Participante

    Como ve en tu foro paulo, seguimos teniendo un problema, a mi me pasa lo mismo
    el sistema de subida va genial, me encanta, pero los iconos de adjunto, que salen en la lista de topics notificando que ese mensaje tiene un adjunto, no se visualizan!

    la buena es que la ruta esta bien puesta, pero no se visualizan y tiene pinta de ser algo de permisos, pero ni dando 777 se muestran, que sera?

    http://www.blogdemotos.com/foro-de-motos/

    Mirad en la principal, la imagen que falta por mostrarse, en firefox no sale xq no muestra este tipo de errores, pero si en chrome y en ie

  • #33870

    imported_Paulo
    Participante

    Si, a mi me pasa lo mismo, pero he desistido… las fotos de los iconos no se muestran porque están en la carpeta my-plugins.

    Cuando instalas el plugin en la carpeta bb-plugins los iconos de los mensajes se muestran pero no se pueden subir las fotos…

    Es un plugin realmente pesado…no hay quien lo entienda…

    Si lo pones en la carpeta bb-plugins no sube las imagenes pero muestra los iconos, y si lo pones en la carpeta my-plugins sube las imagenes pero no se muestran los iconos…

    no se que hacerle…

    Un saludo!

  • #54738

    carloslinux
    Participante

    Hola soy nuevo en este foro y aunque ya ha pasado un año de la última entrada, tengo el mismo problema que comentáis aquí, es decir las imágenes suben pero no se muestran, tengo los 2 plugins activos el Allow images y el bb-attachments, por cierto por si sive de ayuda, las imágenes empezaron a subir cuando hice el cambio siguiente de ruta en el archivo: bb-attachments.php
    $bb_attachments[‘path’]=”/var/www/vhosts/midominio.es/httpdocs/bb-attachments/”;
    Pues mi foro esa en un hosting de los económicos.

    Bueno, si después de un año no encontraron respuesta, ya me rindo con el dichoso plugin, que por cierto cunado lo instalé en mi PC funcionó perfecto.
    muchas gracias a todos

El foro ‘bbPress – TalkPress’ está cerrado y no se permiten nuevos debates ni respuestas.

Pin It on Pinterest