Cree el sitio pero ya no tengo admin (hack)

Inicio Foros WordPress General WordPress.org Cree el sitio pero ya no tengo admin (hack)

Este debate contiene 5 respuestas, tiene 2 mensajes y lo actualizó  imported_j.conti hace 8 años, 1 mes.

  • Autor
    Publicaciones
  • #18752

    bananajota
    Participante

    <p>Bueno, voy a tratar de ser lo más claro posible.<br />
    Soy el creador del sitio, y el admin. O lo era. Porque he detectado que:<br />
    1- no veo el panel de usuarios ni puedo ingresar manualmente (con que haciendo trampa eh?)<br />
    2- no veo el panel de widgets (No tienes suficientes permisos para acceder a esta página).<br />
    3- en pos de solucionar el problema, quise crear usuarios con rol de administrador y si bien crea el usuario, no tiene permisos de administrador (al hacerlo me dijo: con que haciendo trampas eh?)<br />
    4- Puedo cambiar, actualizar y editar plugins y themes.<br />
    5- Crear contenido, borrarlo, subir multimedia, etc.<br />
    6- Ya desactivé todos los plugins y volví al theme por default.</p>
    <p>7- En el PHPMYADMIN tengo el User ID 1 en WP_users y en WP_usermeta tengo<br />

    Quote:
    5 1 wp_capabilities a:1:{s:13:"administrador";b:1;}<br />
    7 1 wp_user_level 108 1 wp_usersettings m0=c&amp;m1=o&amp;m2=c&amp;m3=c&amp;m4=c&amp;m5=o&amp;m6=c&amp;m7=c&amp;m8=o&amp;align…<br />
    9 1 wp_usersettingstime 1283190335<br />
    10 1 wp_autosave_draft_ids a:33:{i:-1262206039;i:362;i:-1262238473;i:366;i:-1…<br />
    11 1 closedpostboxes_dashboard a:7:{i:0;s:25:"dashboard_recent_comments";i:1;s:24…<br />
    12 1 metaboxhidden_dashboard a:5:{i:0;s:24:"dashboard_incoming_links";i:1;s:15:…<br />
    20 1 closedpostboxes_post a:1:{i:0;s:13:"trackbacksdiv";}<br />
    21 1 metaboxhidden_post a:1:{i:0;s:7:"slugdiv";}<br />
    302 1 wp_user-settings-time 1285361772<br />
    23 1 screen_layout_dashboard 2<br />
    24 1 plugins_last_view all<br />
    38 1 first_name El Gran<br />
    39 1 last_name Bonete<br />
    41 1 author_image admin-3.jpg<br />
    42 1 description El Gran Bonete<br />
    300 1 wp_dashboard_quick_press_last_post_id 966<br />
    301 1 wp_user-settings m0=o&amp;m1=c&amp;m2=c&amp;m3=c&amp;m4=c&amp;m5

    </p>
    <p>8- Tengo la versión de WP 3.01 en español.<br />
    9- Tengo el role manager plugin que daba permisos a los usuarios que colaboraban con mi sitio.<br />
    10- Tuve varios usuarios spam (tipo viagra online, etc) y los borré desde el PHPmyAdmin de wp_users y WP_usermeta usando su user_ID<br />
    11- Ya reinstalé los archivos del WP.</p>
    <p>Ayuda por favor? Diganme qué necesitan para poder estudiar este problema. Muchas gracias!
    </p>

  • #45503

    bananajota
    Participante

    Bueno, gracias por las lecturas de mi problema. Acá les dejo dos fotos, una del CPANEL y la otra de mi PHPmyAdmin, con los valores que tiene el ID_User 1 que es el admin.

    [url=http://www.diegocosta.com.ar/software/Trashware/pics/cpanel.jpg]CPANEL[/url]
    [url=http://www.diegocosta.com.ar/software/Trashware/pics/phpmyadmin.jpg]PHPMYADMIN[/url]

    por favor, ¿algún consejo!?

  • #45505

    bananajota
    Participante

    Bueno, me cansé y volví atrás mi WP, de la 3.01 pasé directo a la 2.9.
    Todo se solucionó. Evidentemente, hay un ENORME BUG que produce estas cosas en algunos usuarios.
    GRRRRRRRRRRRRRRR
    No me quiero quedar en la versión 2.9 para siempre!!! 🙁

  • #45507

    imported_j.conti
    Participante

    Nunca toques una base de datos si no sabes lo que haces.

    Los usuarios los debes eliminar desde la administración de WordPress.

    Cuando eliminas desde la administración de wp, no solo eliminas al usuario si no toda su actividad, es decir, limpias el sistema de todo el spam que hayan introducido.

    Dicho esto.

    No has comentado algo y es que has trasteado también al usuario admin en la base de datos o has utilizado algún plugin que te ha trasteado al usuario admin.

    Para modificar al usuario admin hay que saber muy bien linaje se hace o ye quedas sin poder hacer nada en la administración, como te ha pasado.

    Bien, soltado todo el rollo y que espero que cualquiera que lo lea lo tenga muy en cuenta (haced siempre una copia de seguridad de la base de datos antes de hacer nada). Tienes que hace lo siguiente.

    Ves a phpmyadmin y ves a tu base de datos.

    Ves a wp_usermeta y después a wp_capabilities y cambia “administrador” por “admin”

    Si no has trasteado mas cosas, ya volverás a tener acceso a todo.

  • #45517

    bananajota
    Participante

    Bueno, lamento informarte que no es así. Sé bien lo que hice. Te detallo los pasos brevemente.
    1-Fui a phpmyadmin y desde allí eliminé usuarios SPAM, como vos bien comentaste, utilizando su id_user en wp_user y wp_usermeta. Al admin (id 1) nunca lo toqué obviamente y siempre tuvo todos sus valores inalterados. Prueba de esto es que al volver a versiones anteriores de WP mi admin funciona perfecto y los datos son exactamente los mismos.

    2- simplemente volví a la versión 2.9.2 del 19/feb/2010 y todo anduvo perfecto.

    3- Luego segui tu consejo y el de [url=http://wordpress.org/support/topic/users-dissapeared-from-my-control-panel?replies=8#post-1709900]esmi [/url] (foro en ingles de wp) y desactivé los plugins y puse el theme de default y actualizé el WP a la última versión 3.0.1 del 29/jul/2010. Ete aquí que volvieron a desaparecer la página de users y de widgets y además, cuando quería ingresar manualmente me pasaba lo mismo que detallé más arriba en este post.

    4- volví a eliminar esa instalación y subí esta vez la inmediata anterior, la 3.0 del 17/jun/2010 y todo seguía igual que con la 3.0.1,

    5-asi que finalmente, volví a la 2.9.2 y todo anda perfecto.

    En efecto, se trata de alguna clase de bug, porque yo en mi pc tengo una instalación local de la 3.0.1 y tengo los widgets y los users. La única diferencia es la base de datos que apenas tiene unos pocos post de prueba y se llama diferente.

    Tengo una copia de la base de datos en phpmyadmin durante la versión 3.0.1 y ahora durante la 2.9.2 por si alguno está interesado. Supongo que puede ser útil porque con cada instalación el WP modifica en algún lado la base datos, o eso dice que hace.

    Me gustaría reportar esto como bug, dónde puedo hacerlo?
    Muchas gracias a todos.

  • #45538

    imported_j.conti
    Participante

    Quizás tu no hayas cambiado directamente el usuario admin, pero si el Rol Manager. Seguramente hay algún apartado donde puedas personalizar el nombre de o algo por el estilo.

    No se de daonde lo has descargado, pero en la versión que he encontrado del plugin:

    http://svn.redalt.com/projects/RoleManager/tags/1.4.5/role-manager.php

    Pone que es compatible hasta la versión de WordPress 2.1, lo que seguramente lo hace compatible con todas las versiones 2.x

    La 3.x tiene muchos cambios en cuentión de usuarios y de ahí el problema que debes estar teniendo.

    Si en la versión 2.9.2 pones como nombre de usuario admin (que ya digo que no lo he usado pero casi seguro que por aquí van los tiros) y desactivas el plugin y después actualizas a la versión 3.x casi seguro que no tendrás problemas.

    Estas usando un plugin no actualizado, y que toca el tema de los usuarios, así que casi al 100% que es el que te está causando los problemas.

El foro ‘General WordPress.org’ está cerrado y no se permiten nuevos debates ni respuestas.

Pin It on Pinterest