¿Dónde coloco el archivo de favicon?

Inicio Foros WordPress General WordPress.org ¿Dónde coloco el archivo de favicon?

Etiquetado: ,

Este debate contiene 13 respuestas, tiene 8 mensajes y lo actualizó  Abraham Alvarez hace 9 años.

  • Autor
    Publicaciones
  • #13316

    <p>Hola a todos,</p>
    <p>Como dice el título, ¿dónde se coloca el archivo para un favicon?.</p>
    <p>Gracias
    </p>

  • #29479

    imported_Neri
    Participante

    Hola, en la raíz del sitio, por ejemplo https://ayudawp.com/favicon.ico
    Saludos

  • #29481

    imported_Fernando
    Participante

    Pero puedes colocarlo donde quieras, siempre que le indiques la ruta al código que tienes que añadir al fichero header.php:

    [quote][code]<link rel="shortcut icon" href="<?php bloginfo(‘url’); ?>/favicon.ico" />[/code][/quote]

    En este ejemplo cogería la ruta del blog como te dice Neri, pero puedes sustituirlo por una ruta completa a donde lo tengas.

  • #29531

    imported_lalaale
    Participante

    YO recimiendo colocarlo en la raiz del sitio y en la carpeta del theme… también revisar lo que mencionó Fernando, el código del theme por si las moscas…

  • #30708

    oboepalas
    Participante

    Hola, estoy volviendome loco porque intento colocar el favicon y no hay forma: lo subo a la carpeta contents y coloco esta linea <link rel=”shortcut icon” href=”http://www.misitio.com/wp-content/uploads/favicon.ico” />

    entre las etiquetas: <head></head>

    Pero no hay forma no se ve. No se si el problema puede ser porque tengo varios dominios ya que en el principal si que tengo favicon y se ve correctamente pero no es una web hecha con wordpress. Los otros dos dominios con wordpress no logro colocar el favicon. Esto parece cosa de brujas.

    Saludos

  • #30724

    metacortex
    Participante

    @oboepalas, asumiendo que ya colocaste el archivo y la etiqueta en tu header: Para que se muestre el ícono sólo vacía la caché del navegador, ciérralo (todas las ventanas del navegador) y vuélvelo a abrir.

  • #30756

    oboepalas
    Participante

    Pues esto también lo he hecho y nada. La verdad es que no tengo idea de código y no se si es que estoy colocando mal la línea, yo la tengo colocada a continuación de esta:

    <title><?php bloginfo(‘name’); ?> <?php if ( is_single() ) { ?> » Blog Archive <?php } ?> <?php wp_title(); ?></title>
    <link rel=”shortcut icon” href=”http://www.misitio.com/wp-content/uploads/favicon.ico” />

    Gracias y saludos

  • #30762

    imported_jaume
    Participante

    Yo creo que tendrías que añadir como dice Fernando y los demás,en el [b]header.php[/b] de tu [b]Theme[/b]:
    [quote]<link rel="shortcut icon" href="<?php bloginfo(‘url’); ?>/favicon.ico" />[/quote]

    Y tener el archivo favicon.ico(imagen),en el directorio de tu espacio web de tu Hosting.

    A mi me funciona bien así. 😕

  • #30764

    oboepalas
    Participante

    He probado también de esta forma que me recomiendas y tampoco. No se lo que pueda pasar. Quizá lo mejor sería alguien que entienda de código para que me revisará el [b]header.php[/b] para ver que pueda pasar.

    Gracias

  • #30768

    imported_jaume
    Participante

    Normalmente va en la cabecera,dentro de la etiqueta -head-.

    [quote]<html xmlns="http://www.w3.org/1999/xhtml&quot; <?php // language_attributes(‘xhtml’); // -> generates invalid markup 🙁 ?>>

    <[b][u]head[/u][/b] profile="http://gmpg.org/xfn/11"&gt;

    <meta http-equiv="Content-Type" content="<?php bloginfo(‘html_type’); ?>; charset=<?php bloginfo(‘charset’); ?>" />

    <?php if($metakeywords<>”) { ?>

    <meta name="keywords" content="<?php echo $metakeywords; ?>" />

    <meta name="description" content="<?php bloginfo(‘description’); ?>" />

    <?php } ?>

    <title><?php wp_title(‘«’, true, ‘right’); ?><?php bloginfo(‘name’); ?></title>

    <link rel="alternate" type="application/rss+xml" title="<?php bloginfo(‘name’); ?> RSS Feed" href="<?php bloginfo(‘rss2_url’); ?>" />

    <link rel="alternate" type="application/atom+xml" title="<?php bloginfo(‘name’); ?> Atom Feed" href="<?php bloginfo(‘atom_url’); ?>" />

    <link rel="pingback" href="<?php bloginfo(‘pingback_url’); ?>" />

    [b][u]<link rel="shortcut icon" href="<?php bloginfo(‘url’); ?>/favicon.ico" />[/u][/b]
    [/quote]

    Suerte.

  • #30769

    oboepalas
    Participante

    Así lo tengo y el favicon.ico en la raiz del sitio, pero no aparece. No se si será cosa del Theme que tengo: The last fall. Esto parece cosa de misterio.

    Muchas gracias de todas formas colega. A ver de que forma puedo solucionarlo.

  • #30771

    oboepalas
    Participante

    Así es como tengo [b]header.php[/b] si alguien sabe si hay algo mal que me eche un cable:

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"&gt;
    <html xmlns="http://www.w3.org/1999/xhtml&quot; <?php language_attributes(); ?>>

    <head profile="http://gmpg.org/xfn/11"&gt;
    <meta http-equiv="Content-Type" content="<?php bloginfo(‘html_type’); ?>; charset=<?php bloginfo(‘charset’); ?>" />

    <title><?php bloginfo(‘name’); ?> <?php if ( is_single() ) { ?> » Blog Archive <?php } ?> <?php wp_title(); ?></title>

    <link rel="stylesheet" href="<?php bloginfo(‘stylesheet_url’); ?>" type="text/css" media="screen" />
    <link rel="alternate" type="application/rss+xml" title="<?php bloginfo(‘name’); ?> RSS Feed" href="<?php bloginfo(‘rss2_url’); ?>" />
    <link rel="pingback" href="<?php bloginfo(‘pingback_url’); ?>" />

    <link rel="shortcut icon" href="<?php bloginfo(‘url’); ?>/favicon.ico" />

    <script type="text/javascript" src="http://jqueryjs.googlecode.com/files/jquery-1.3.2.min.js&quot; ></script>
    <script type="text/javascript" src="<?php bloginfo(‘template_directory’); ?>/js/javascript.js" ></script>

    <?php wp_head(); ?>
    </head>
    <body>
    <div id="page">
    <h1 id="header">

    /">
    <?php bloginfo(‘name’); ?>

    <div id="description">
    <?php bloginfo(‘description’); ?>
    </div>
    </h1>

  • #30776

    imported_jaume
    Participante

    Si tienes varios dominios en el mismo hosting,tendrías que ponerlo en el WordPress que quiereas que salga.Al lado de los index.php,wp-header.php,etc..

    O que la imagen favicon.ico esté corrupto,medidas,o algo así..

    Salud.

  • #30855

    Abraham Alvarez
    Participante

    Hice como lo indicaron:
    <link rel="shortcut icon" href="<?php bloginfo(‘url’); ?>/favicon.ico" />
    y el favicon se ve bien en FiraFox, pero en IExplorer no lo muestra, en cambio el favicon del foro se muesra correctamente en ambos exploradores.

    Se aradecerá cualquier orientación.
    Abraham Alvarez

El foro ‘General WordPress.org’ está cerrado y no se permiten nuevos debates ni respuestas.

Pin It on Pinterest