El código de un mapa de imágenes cambia al pasar de html a visual en el editor

Inicio Foros WordPress General WordPress.org El código de un mapa de imágenes cambia al pasar de html a visual en el editor

Etiquetado: 

Este debate contiene 3 respuestas, tiene 2 mensajes y lo actualizó  trochilus hace 6 años.

  • Autor
    Publicaciones
  • #65519

    trochilus
    Participante

    Hola, quería comentaros un problema que me surge con los mapas de imágenes cuando edito o simplemente abro la página en modo “visual”, cosa que no ocurre en “html”.

    La web es para que la lleven otras personas, por lo que me gustaría arreglar de alguna manera esto, porque en el momento que entren en estas páginas van a desaparecer los mapas de imágenes, ya que utilizarán el modo visual, puesto que es más cómodo para ellos.

    Al mapa de imágenes le tengo insertado el plugin Tippy, para que se despliegue un cajetín con información. Tal vez sea que interfiera esto…

    El caso es que el código funciona perfectamente si utilizo el modo “html”:

    <p style=”text-align: center;”><img src=”http://localhost/wordpress/wp-content/…” alt=”” width=”925″ height=”543″ usemap=”#Map” /><br />

    <map name=”Map”> <area shape=”circle” coords=”478,136,6″ href=”#” alt=[tippy title=”” height=”45″ width=”180″]Trepador azul<br />

    Pico picapinos<br />

    Ardilla roja[/tippy]<area shape=”circle” coords=”558,146,6″ href=”#”alt=[tippy title=”” height=”45″ width=”180″]Gavilán<br />

    Corzo<br />

    Curruca zarcera[/tippy]<area shape=”circle” coords=”615,202,7″ href=”#” alt=[tippy title=”” height=”45″ width=”180″]Ratonero común<br />

    Mosquitero papialbo<br />

    Reyezuelo listado[/tippy]<area shape=”circle” coords=”590,294,6″ href=”#” alt=[tippy title=”” height=”45″ width=”180″]Alcaudón dorsirrojo<br />

    Cuco<br />

    Acentor común[/tippy]<area shape=”circle” coords=”491,286,6″ href=”#” alt=[tippy title=”” height=”45″ width=”180″]Cernícalo vulgar<br />

    Codorniz[/tippy]<area shape=”circle” coords=”527,355,6″ href=”#” alt=[tippy title=”” height=”45″ width=”180″]Curruca rabilarga[/tippy]<area shape=”circle” coords=”500,492,8″ href=”#” alt=[tippy title=”” height=”45″ width=”180″]Aguilucho pálido<br />

    Aguilucho cenizo<br />

    Bisbita alpino[/tippy]<area shape=”circle” coords=”273,367,7″ href=”#” alt=[tippy title=”” height=”45″ width=”180″]Carbonero común<br />

    Herrerillo común<br />

    Mito[/tippy]<area shape=”circle” coords=”72,365,7″ href=”#”alt=[tippy title=”” height=”45″ width=”180″]Lavandera blanca<br />

    Lavandera cascadeña<br />

    Golondrina común[/tippy]<area shape=”circle” coords=”186,299,7″ href=”#”alt=[tippy title=”” height=”45″ width=”180″]Mirlo acuático<br />

    Rastros de mamíferos[/tippy]<area shape=”circle” coords=”289,242,7″ href=”#”alt=[tippy title=”” height=”45″ width=”180″]Trepador azul<br />

    Carbonero garrapinos[/tippy]<area shape=”circle” coords=”396,205,7″ href=”#”alt=[tippy title=”” height=”45″ width=”180″]Búho chico<br />

    Chochín<br />

    Rana patilarga[/tippy]<area shape=”circle” coords=”493,181,7″ href=”#”alt=[tippy title=”” height=”45″ width=”180″]Herrerillo capuchino[/tippy]</map></p>

     

    Pero si paso a utilizar el modo “visual”, este código anteriormente citado se transforma, sin yo hacer nada, pasando a ser el siguiente código:

    <p style=”text-align: center;”><img src=”http://localhost/wordpress/wp-content/…” alt=”” width=”925″ height=”543″ usemap=”#Map” />

    <map name=”Map”> <area title=”” shape=”circle” coords=”478,136,6″ href=”#” alt=”[tippy” /></map>

    <map name=”Map”> Pico picapinos</map>

    <map name=”Map”> Ardilla roja[/tippy]<area title=”” shape=”circle” coords=”558,146,6″ href=”#” alt=”[tippy” /></map>

    <map name=”Map”> Corzo</map>

    <map name=”Map”> Curruca zarcera[/tippy]<area title=”” shape=”circle” coords=”615,202,7″ href=”#” alt=”[tippy” /></map>

    <map name=”Map”> Mosquitero papialbo</map>

    <map name=”Map”> Reyezuelo listado[/tippy]<area title=”” shape=”circle” coords=”590,294,6″ href=”#” alt=”[tippy” /></map>

    <map name=”Map”> Cuco</map>

    <map name=”Map”> Acentor común[/tippy]<area title=”” shape=”circle” coords=”491,286,6″ href=”#” alt=”[tippy” /></map>

    <map name=”Map”> Codorniz[/tippy]<area title=”” shape=”circle” coords=”500,492,8″ href=”#” alt=”[tippy” /></map>

    <map name=”Map”> Aguilucho cenizo</map>

    <map name=”Map”> Bisbita alpino[/tippy]<area title=”” shape=”circle” coords=”273,367,7″ href=”#” alt=”[tippy” /></map>

    <map name=”Map”> Herrerillo común</map>

    <map name=”Map”> Mito[/tippy]<area title=”” shape=”circle” coords=”72,365,7″ href=”#” alt=”[tippy” /></map>

    <map name=”Map”> Lavandera cascadeña</map>

    <map name=”Map”> Golondrina común[/tippy]<area title=”” shape=”circle” coords=”186,299,7″ href=”#” alt=”[tippy” /></map>

    <map name=”Map”> Rastros de mamíferos[/tippy]<area title=”” shape=”circle” coords=”289,242,7″ href=”#” alt=”[tippy” /></map>

    <map name=”Map”> Carbonero garrapinos[/tippy]<area title=”” shape=”circle” coords=”396,205,7″ href=”#” alt=”[tippy” /></map>

    <map name=”Map”> Chochín</map>

    <map name=”Map”> Rana patilarga[/tippy]<area title=”” shape=”circle” coords=”493,181,7″ href=”#” alt=”[tippy” /></map></p>

    ¿A alguien le ha ocurrido esto? y ¿cómo lo ha solucionado o cómo se puede solucionar?

    Gracias

    Un saludo

  • #65521

    trochilus
    Participante

    Acabo de hacer la prueba a hacer un mapa de imágenes sin incluir los tooltips del plugin Tippy, y probar a pasar de “html” a “visual” y viceversa, y no se producen los cambios que he expuesto en el primer mensaje. Así que me imagino que es cosa del plugin.

  • #65529

    LGrusin
    Miembro

    No sólo te va a pasar en las páginas sino en los posts también. Pueden desaparecer códigos, espacios, párrafos, etc.

    En principio, si no haces modificaciones, no afecta cuando cambias de un modo a otro.

    Lo que está claro es que cuando quieras introducir código HTML tienes que usar el modo HTML.

    Un saludo

  • #65856

    trochilus
    Participante

    Gracias LGrusin

    Ya me había pasado que el código cambie, sobretodo con los formatos de párrafo, pero nunca hasta el punto que he recogido aquí arriba. Y es que sólo me ocurre cuando abro la página para modificar algo en modo visual.

    He mandado un correo con el problema al desarrollador del plugin, para ver si me puede aconsejar algo, o que me descarte que el problema sea del plugin. Cuando tenga noticias sobre el tema lo publicaré en este hilo.

    Un saludo

El foro ‘General WordPress.org’ está cerrado y no se permiten nuevos debates ni respuestas.

Pin It on Pinterest