Error 404 al editar post, páginas y guardar configuraciones

Inicio Foros WordPress Instalación / Actualización Error 404 al editar post, páginas y guardar configuraciones

Este debate contiene 4 respuestas, tiene 3 mensajes y lo actualizó  imported_pablofb hace 9 años, 3 meses.

  • Autor
    Publicaciones
  • #17909

    imported_pablofb
    Participante

    <p>Hola a todos:</p>
    <p>Llevo unas 6 horas tratando de resolver este problema por mi cuenta, pero no soy capaz. Pido ayuda.</p>
    <p>Recibo el ERROR 404 cada vez que intento:<br />
    – Guardar cambios en una sección del panel de administrador. Por ejemplo, en "ajustes de escritura" doy a guardar y me lleva a la página "/wp-admin/options-writing.php" mostrando un ERROR 404 y, a veces, en la barra del navegador, el mensaje "Nothing found for WP-admin Page Php".<br />
    – Actualizar o Editar una página o un post. Por ejemplo al editar y pulsar el botón Actualizar de esta página http://www.pabloburgueno.com/articulos-y-ponencias/ soy dirigido a un ERROR 404 en esta otra página http://www.pabloburgueno.com/wp-admin/page.php</p&gt;
    <p>El error surgió sin más, sin instalar nada nuevo ni hacer cambios de ningún tipo.</p>
    <p>Hasta el momento, esto es lo que he intentado:<br />
    – Desactivar todos los plugins<br />
    – Reinstalar WP 3.0 (tanto automáticamente como borrando todo del ftp e instándolo manualmente)<br />
    – Instalar WP 2.9.2 por si era problema de la nueva versión<br />
    – Actualizar la estructura de permalinks<br />
    – Revisar el .htaccess: lo he dejado únicamente con las líneas que me indica WP al actualizar los permalinks cuando el fichero no tiene permisos de escritura<br />
    – Resetear permisos de escritura para que todo sea modificable vía FTP<br />
    – Reparar (y ya de paso optimizar) las BBDD<br />
    – Dejar pasar un día</p>
    <p>He creado otra página (http://www.pabloburgueno.com/prueba/) por lo que sí puedo publicar. Pegué en ella una gran cantidad de texto copiado del html de una de las páginas que daban error y al editar me volvió a dar ERROR 404 por lo que pensé que podría ser un problema de capacidad de subida PHP así que incluí la última línea que aparece en el .htaccess que copio a continuación:</p>
    <p>

    </p>
    <p>El problema no se ha solucionado.</p>
    <p>Datos útiles<br />
    – Mi conocimiento de WP es medio. No sé programar pero trataré de comprender lo mejor posible vuestras indicaciones.<br />
    – El blog problemático es http://www.pabloburgueno.com<br />
    – Tengo instalado WP 2.9.2, sin plugins<br />
    – El theme es Unnamed 1.23 de Xu Yiyang (http://xuyiyang.com/wordpress-themes/unnamed/)</p>
    <p>Actualización (22:22h – 2/7/2010)<br />
    Cuando copio el contenido desde la vista de edición (visual o html, da lo mismo) de una página de las que falla y lo pego en la de prueba, da ERROR 404. Pero si copio el contenido simplemente de la web (por ejemplo, de aquí) y lo pego en la página de prueba (visual o html indistintamente) no falla y se actualiza correctamente. No sé muy bien cómo interpretar esto.
    </p>

  • #43441

    imported_Fernando
    Participante

    Hola Pablo … de los habituales culpables te faltan 3 cositas:

    1. Sube un wp-config-sample.php limpio de la versión en inglés que estés usando y pon tus datos de la base de idem
    2. Añade las secret keys al wp-config.php
    3. Prueba a ver si también te pasa con el tema default

    Nos cuentas luego

  • #43445

    imported_ruben
    Participante

    Hola, a mí también me pasa.

    He hecho también todo lo habido y por haber; he desactivado plugins, he actualizado a la nueva versión, he retrocedido… he buscado infinidad de tutoriales por internet…

    Me rindo 🙁

  • #43478

    imported_ruben
    Participante

    Hola Pablo, acabo de encontrar la solución en:

    http://blog.mattrudge.net/2010/06/30/wordpress_404_error/

    Por lo que decidí ponerme en contacto con mi proveedor de servicios de hosting, y ésta fue su respuesta:

    «Tuvimos que realizar una modificación en la configuración de mod_security porque se estaban hackeando cuentas por error en un script utilizado por los clientes, estamos actualizando dichos script y luego procederemos a revisar la configuración asignada en el mod_security.»

  • #43484

    imported_pablofb
    Participante

    Hola:

    Ha sido problema del hosting, tal y como dice [url=https://ayudawp.com/foro/edit.php?id=26140#post-26133]Ruben[/url], y ya está arreglado. Todos los meses me hacen una distinta… Me parece que me queda poco tiempo con ellos.

    PD: Fernando. Se me olvidó citar a los tres Dalton en el post original, ya proscritos de entre las posibles causas. ¡Pero mil gracias por la ayuda!

El foro ‘Instalación / Actualización’ está cerrado y no se permiten nuevos debates ni respuestas.

Ir al contenido