Error 404 permalinks con .htaccess correcto

Inicio Foros WordPress SEO – SEM Error 404 permalinks con .htaccess correcto

Este debate contiene 4 respuestas, tiene 3 mensajes y lo actualizó  sergi77 hace 9 años, 1 mes.

  • Autor
    Publicaciones
  • #14024

    makiaji
    Participante

    <p>Hola,</p>
    <p>Pues he cambiado la estructura de los permalink de mi web a /%postname%.html y ahora al intentar entrar en cualquier post o página me sale error 404.<br />
    He comprobado el .htaccess y tiene la información de WordPress agregada.</p>
    <p>El error 404 que me da es el típico de Apache:</p>
    <p>

    Quote:
    Not Found</p>
    <p>The requested URL /web/proba-permalinks.html was not found on this server.</p>
    <p>Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.<br />
    Apache/2.2.9 (Debian) PHP/5.2.6-1+lenny3 with Suhosin-Patch Server at http://www.ispatech.com Port 80

    </p>
    <p>Este es mi .htaccess colocado en la raíz del servidor (el wordpress lo tengo dentro del directorio /web/):</p>
    <p>htaccess.jpg</p>
    <p>Utilizo WP 2.8.4 con todos los plug-in actualizados.
    </p>

  • #31339

    imported_Fernando
    Participante

    Pero no tiene la información correcta. Haz una cosa, protege contra escritura htaccess, cambia los permalinks, como no podrá escribir te dará el código correcto y lo pones a mano.

  • #31342

    makiaji
    Participante

    Pero no tiene la información correcta. Haz una cosa, protege contra escritura htaccess, cambia los permalinks, como no podrá escribir te dará el código correcto y lo pones a mano.

    Hola,

    He quitado los permisos de escritura del .htaccess del que tengo en la raiz y no me ha hecho nada. Me he fijado también que tengo otro .htaccess dentro de la carpeta donde tengo instalado WP. A ese se lo he quitado también y ya me ha aparecido lo de que he de agregarlo manualmente. Me ha dado el siguiente código:

    [code]<IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /web/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /web/index.php [L]
    </IfModule>
    [/code]

    Pero sigue sin funcionar correctamente pese a haber cambiado el codigo ese en el .htaccess de la raíz del host y el .htaccess de la carpeta del WordPress.

  • #31363

    makiaji
    Participante

    Estoy probando otra vez pero no hay manera 😥 he borrado el .htacces que tenia en la raíz del host y el .htaccess de la carpeta del WordPress y he vuelto a actualizar los permalinks asi que me ha creado un .htaccess en la carpeta de WordPress pero siguen sin funcionar los malditos link.

  • #31379

    sergi77
    Participante

    el permalink es incorrecto pon %postname%.html sin el / por ello te sale errro.

    Espero ayudarte, si no es asi podemos volverlo a mirar e intentar de nuevo.

    Saludos.

El foro ‘SEO – SEM’ está cerrado y no se permiten nuevos debates ni respuestas.

Pin It on Pinterest