Error al Subir Imágenes mediante form en el front end

Inicio Foros WordPress General WordPress.org Error al Subir Imágenes mediante form en el front end

Etiquetado: ,

Este debate contiene 3 respuestas, tiene 2 mensajes y lo actualizó  Fliberty hace 6 años, 5 meses.

  • Autor
    Publicaciones
  • #60325

    Fliberty
    Participante

    Hola a todos, lo que sucede es que hace poco en mi web de clasificados: http://www.contigoperuclasificados.com no puedo subir imagenes mediante el cargador de imágenes del formulario de publicación en el front end.
    Estoy en el proceso de realización de un nuevo diseño, pensando que sería un problema de programación, sin embargo he subido el theme en proceso, y me arroja el mismo error al intentar subir los archivos, aunque en local no me arroja ninguno. Pueden probar el formulario de subida, registrándose, y aunque he logrado integrar el editor y cargador de imágenes de wordpress, el otro medio para subir imágenes se utiliza para subir las imágenes que iran en la galería de imágenes.
    Los errores que arrojan parecen ser de permisos, el hecho es que tanto la carpeta uploads como la carpeta imgs tiene permisos 777, y como dije empezó a salir el error de la nada.


    Warning: chmod() [function.chmod]: No such file or directory in /home/contigop/public_html/wp-content/themes/classyperu/post-process.php on line 111

    Warning: mkdir() [function.mkdir]: Permission denied in /home/contigop/public_html/wp-content/themes/classyperu/post-process.php on line 109

    Warning: copy(/imgs/se-vende-semillas-de-409369463.jpg) [function.copy]: failed to open stream: No such file or directory in /home/contigop/public_html/wp-content/themes/classyperu/post-process.php on line 110

    Y al final aparece un error ubicado en el archivo pluggable que se encuentra en wp-includes, pero por el apuro no copié el detalle del error. Espero la ayuda de lo más sabiondos, ya que además de ese error sólo me falta crear los archivos de edición de post y de escritorio personalizado para los usuarios.

  • #60330

    LGrusin
    Miembro

    Los errores que da son porque no encuentra el archivo o directorio. ¿El mkdir() está funcionando bien?

    Un saludo

  • #60332

    Fliberty
    Participante

    Que tal Lgrusin a los tiempos, bueno te comento, de un momento a otro dejó de funcionar la subida, anteriormente esto si se realizaba, y antes de modificar el theme del sitio, me puse a desarrollar otro (el actual), lo he probado una y otra vez en local y funciona perfectamente. Pero no cuando lo subo al server, aqui es donde aparecen los errores.
    La carpeta “img” ubicada en wp-content/uploads/ si existe ya que como te dije, la subida de imágenes estaba funcionando.
    Ahora voy a reinstalar wordpress, en un espacio nuevo, voy a eliminar el actual y crear uno nuevo, haber si eso soluciona el problema.
    Los permisos que le acabo de dar para probar son:
    wp-content 777
    uploads 777
    img 777

    leí en un lugar que debía crear una carpeta cache en el theme con permisos 777, también lo hize y nada.

    La reinstalación completa es lo ultimo que me queda a menos que me puedas echar una mano.

  • #60342

    Fliberty
    Participante

    Bueno ya parece que se solucionó, eliminé el host y volví a crear otro nuevo y reinstalé de cero, recuperando claro está, usuarios, entradas y paginas que es lo más importante.

El foro ‘General WordPress.org’ está cerrado y no se permiten nuevos debates ni respuestas.

Pin It on Pinterest