Error base de datos

Inicio Foros WordPress Instalación / Actualización Error base de datos

Etiquetado: 

Este debate contiene 3 respuestas, tiene 2 mensajes y lo actualizó  estefania_cs hace 4 años, 8 meses.

  • Autor
    Publicaciones
  • #74577

    estefania_cs
    Participante

    Hola, qué tal? Tengo un problema bastante gordo. Actualicé WordPress a la última versión, pero lo hice mal, es decir que actualicé sin desactivar plugins y de forma automática (desde WordPress). Como vi que me empezó a dar errores, desactivé todo y subí el anterior vía ftp. Desde ese momento me da cada dos por tres este error:
    ———————–
    Error de conexión con la base de datos
    Esto puede deberse a que los datos de usuario y contraseña de tu wp-config.php son incorrectos o a que no es posible contactar con el servidor de base de datos en db400669802.db.1and1.com, lo que podría significar que el servidor de bases de datos de tu host está inactivo.

    ¿Estás seguro de que el nombre de usuario y la contraseña son correctos?
    ¿Estás seguro de que el nombre del host es correcto?
    ¿Estás seguro de que el servidor de bases de datos está activo?
    Si no tienes muy claro lo que significan los términos anteriores, ponte en contacto con tu proveedor de alojamiento. Si necesitas más ayuda, puedes visitar los Foros de ayuda de WordPress.
    ———————————-
    He desactivado todos los plugins para ver si crea conflcto con alguno y nada, sigue dando el error.
    Es una locura, cada vez que subo posts, me da error o me dice que lo ha subido y está como borrador….
    Podéis ayudarme?
    Muchas gracias.

  • #74583

    LGrusin
    Miembro

    ¿Y cómo actualizabas antes WordPress?

    Lo mejor es que subas la nueva versión por FTP, recuerda que no puedes sobreescribir la carpeta wp-content y el archivo wp-config.php

    Para desactivar todos los plugins mejor que renombres la carpeta plugins desde FTP, después ya irás comprobando uno por uno.

    Un saludo

  • #74587

    estefania_cs
    Participante

    Hola, LGrusin! Qué tal? Antes lo actualizaba como recomendáis, desactivando los plugins primero, luego subía la nueva versión sin el wp-content por ftp y finalmente me volvía a conectar por el admin.
    El caso es que lo actualicé a la última versión como describí antes, me dio algunos errores y volví a la versión antigua, la 3.6.1.
    Desde ese momento me da error en la conexión con la base de datos constantemente cuando me meto en el admin y actualizo posts. No entiendo mucho de WordPress, pero creo que puede pasar esto:
    Al haber actualizado a la última versión y luego haber vuelto a otra más antigua, que me haya creado campos en la base de datos que la antigua no reconoce. Puede ser? Sabes cómo podría solucionarlo?
    Muchas gracias por tu interés.
    Un saludo.

  • #74588

    estefania_cs
    Participante

    Se me olvidó aclarar que el error sólo aparece cuando entro en el admin, cuando no, la web va bien.

El foro ‘Instalación / Actualización’ está cerrado y no se permiten nuevos debates ni respuestas.

Pin It on Pinterest