error del sistema

Inicio Foros WordPress Instalación / Actualización error del sistema

Este debate contiene 6 respuestas, tiene 2 mensajes y lo actualizó  Antonio L hace 6 años, 4 meses.

  • Autor
    Publicaciones
  • #60730

    Antonio L
    Participante

    hola a todo@s,
    tengo un web personal bajo woprdpress y de repente empezó a darme unos mensajes que no entiendo:
    Deprecated: Assigning the return value of new by reference is deprecated in /usr/home/antoniolobo.es/web/wp-settings.php on line 512
    hasta 7 lineas con el mismo mensaje.
    Ademas no puedo acceder al pane de administracion. Entonces me da un error que dice
    “Warning: Cannot modify header information – headers already sent by (output started at /usr/home/antoniolobo.es/web/wp-settings.php:512) in /usr/home/antoniolobo.es/web/wp-includes/pluggable.php on line 850
    a ver si alguien puedo recomendarme alguna solucion
    gracias,

  • #60735

    LGrusin
    Miembro

    De repente no creo que haya sido. ¿Qué fue lo último que estabas haciendo?

    Puedes probar a subir un wp-settings.php original a ver si cambia o se corrige.

    Un saludo

  • #60769

    Antonio L
    Participante

    @lgrusin
    – creo que fue de repente , quizas un cambio en el alojamiento y un wordpress no actualizado desde hace mucho?
    – probé lo que dijiste pero sin suerte
    – he llegado a una solucion temporal siguiendo una entrada del foro de wordpress : http://wordpress.org/support/topic/php-deprecated-warnings-on-every-screen
    ya no tengo mensajes de error
    – el unico problema es que no se me carga el panel de administrador. solo tengo una pantalla en blanco. supongo que por tapar los mensajes de error
    Seguire mirando, gracias , saludos

  • #60772

    LGrusin
    Miembro

    Yo creo que lo mejor es que vuelvas a subir los archivos de WordPress por FTP, una instalación manual.

    Antes de hacer nada averigua si han hecho cambios en el servidor, sobre todo la versión de PHP. Las últimas versiones de WordPress necesitan unos requerimientos.

    Un saludo

  • #60795

    Antonio L
    Participante

    gracias, lo probare. Ya publicare resultados.

  • #60797

    LGrusin
    Miembro

    Por cierto, prueba con otro theme. Eso de

    un wordpress no actualizado desde hace mucho

    me da que pensar. Lo mismo para los plugins, si era una instalación antigua es posible que plugins y/o themes existentes no estén preparados para las nuevas versiones de WordPress.

    Un saludo

  • #60812

    Antonio L
    Participante

    Desde luego llevas razon en lo de actualizar theme y wordpresss, sin duda el verdadero origen de todo el problema.
    ME HAN CONFIRMADO del alojamiento que los errores son debidos a la actualización del PHP. Otro blog que tengo, mas o menos al dia, no ha tenido problema. Ahi lo teneis. Me lo van a pasar a una servidor con PHP antiguo para actualizar y poder pasarlo al nuevo.
    No se si hay alguna forma de marcar esto como RESUELTO que lo est.a.

El foro ‘Instalación / Actualización’ está cerrado y no se permiten nuevos debates ni respuestas.

Pin It on Pinterest