Fallo al acceder al admin.

Inicio Foros WordPress Instalación / Actualización Fallo al acceder al admin.

Este debate contiene 4 respuestas, tiene 2 mensajes y lo actualizó  wsisoporte hace 6 años, 1 mes.

  • Autor
    Publicaciones
  • #64672

    wsisoporte
    Participante

    Hola, acabo de instalar WordPress 3.4.1, parecía estar todo bien, pero cuando voy a entrar al admin (justo tras la instalación) dice:

    Warning: Cannot modify header information – headers already sent by (output started at /homepages/45/d425870100/htdocs/wp-config.php:1) in /homepages/45/d425870100/htdocs/wp-login.php on line 362

    Warning: Cannot modify header information – headers already sent by (output started at /homepages/45/d425870100/htdocs/wp-config.php:1) in /homepages/45/d425870100/htdocs/wp-login.php on line 374

    Warning: Cannot modify header information – headers already sent by (output started at /homepages/45/d425870100/htdocs/wp-config.php:1) in /homepages/45/d425870100/htdocs/wp-includes/pluggable.php on line 680

    Warning: Cannot modify header information – headers already sent by (output started at /homepages/45/d425870100/htdocs/wp-config.php:1) in /homepages/45/d425870100/htdocs/wp-includes/pluggable.php on line 681

    Warning: Cannot modify header information – headers already sent by (output started at /homepages/45/d425870100/htdocs/wp-config.php:1) in /homepages/45/d425870100/htdocs/wp-includes/pluggable.php on line 682

    Warning: Cannot modify header information – headers already sent by (output started at /homepages/45/d425870100/htdocs/wp-config.php:1) in /homepages/45/d425870100/htdocs/wp-includes/pluggable.php on line 881

    He buscado qué significa ese error, y normalmente pasa cuando hay espacios en blanco antes de las marcas de PHP, o que no esté el archivo codificado en ANSI, a pesar de que me lo he bajado de la web de wordpress y no he modificado nada, lo he comprobado y sigue apareciéndome el mismo error.

    Lo estoy probando en un servidor de 1and1, previamente lo utilicé en otro distinto y también me dió error.

    ¿Alguna idea? Gracias por adelantado.

    PDT: He visto que alguien ha tenido el mismo problema que yo en otro foro de soporte de wordpress: http://es.forums.wordpress.org/topic/no-puedo-entrar-al-admin?replies=4 pero no se cuál es la solución.

  • #64679

    LGrusin
    Miembro

    1 – Anota todos los valores del wp-config.php necesarios
    2 – Elimina el archivo wp-config.php
    Al entrar WordPress te dirá que falta el archivo y si lo quieres crear. Le dices que si y te irá pidiendo los datos para crear el archivo.

    Un saludo

  • #64842

    wsisoporte
    Participante

    Hola, gracias por la respuesta.

     

    He eliminado el archivo wp-config.php y he vuelto a subir todo para comenzar la instalación desde cero, pero cuando le doy para crear nuevo archivo no me carga la página (wp-admin/setup-config.php).

     

    ¿Puede ser porque es un servidor de 1and1?

     

    Muchas gracias,

    un saludo.

  • #64843

    LGrusin
    Miembro

    Sólo tenías que renombrar o eliminar el archivo wp-config.php
    Asegurate de haber subido todos los archivos de WordPress y todas sus carpetas.

    Si por casualidad tu servidor no es capaz de crear el archivo wp-config.php tendrás que editar manualmente el wp-config-sample.php o una copia de este.

    No uses el editor de texto que has usado antes o te volverá a dar el mismo error. Desde el Panel de control del servidor, cPanel o similar, puedes editar archivos.

    Recuerda cuando termines renombrar o eliminar el archivo index.html. 1&1 da preferencia a este archivo antes que a index.php

    Saludos

  • #64845

    wsisoporte
    Participante

    He borrado todos los archivos, me he vuelto a descargar wordpress de nuevo de http://es.wordpress.org/ y lo he subido todo menos el config, y me sigue apareciendo lo mismo.

    Cuando pincho en “Crear un archivo de configuración” me aparece una página en blanco. como si no cargara.

    La vez anterior lo edité con bloc de notas, lo he probado de nuevo y me ha dado el mismo error.

    ¿Será por 1and1? Creo que con la versión anterior de wordpress no da ese error, me imagino que lo instalaré así si no se puede solucionar esto.

     

    Muchísimas gracias,

    un saludo.

El foro ‘Instalación / Actualización’ está cerrado y no se permiten nuevos debates ni respuestas.

Pin It on Pinterest