Fatal error al actualizar

Inicio Foros WordPress Instalación / Actualización Fatal error al actualizar

Este debate contiene 3 respuestas, tiene 2 mensajes y lo actualizó  Patagonia hace 9 años, 9 meses.

  • Autor
    Publicaciones
  • #12394

    Patagonia
    Participante

    <p>Hola<br />
    El error que me aparece cuando intento abrir mi blog es este:</p>
    <p>Fatal error: Call to undefined function wp_remote_request() in /home/eturismo/public_html/wp-includes/update.php on line 58</p>
    <p>y cuando intento ir a http://www.eturismoviajes.com/wp-admin/upgrade.php. que es lo que recomiendan luego de actualizar, el error que aparece es este:</p>
    <p>Warning: require(../wp-load.php) [function.require]: failed to open stream: No such file or directory in /home/eturismo/public_html/wp-admin/upgrade.php on line 18</p>
    <p>Warning: require(../wp-load.php) [function.require]: failed to open stream: No such file or directory in /home/eturismo/public_html/wp-admin/upgrade.php on line 18</p>
    <p>Fatal error: require() [function.require]: Failed opening required ‘../wp-load.php’ (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /home/eturismo/public_html/wp-admin/upgrade.php on line 18</p>
    <p>Alguien tuvo ya experiencia con estos errores, puesto que ya no se que hacer.<br />
    Hasta he subido varias veces los archivos creyendo que por ahi no cargo todos, he borrado y vuelto a subir, y aún así el problema sigue existiendo.</p>
    <p>Si alguien tiene conocimiento de esto y guiarme que se hace en estos casos…</p>
    <p>Saludos
    </p>

  • #26731

    lumbreras
    Participante

    Ah lo que busque y encontré, en ésta parte:

    Fatal error: require() [function.require]: Failed opening required ‘../wp-load.php’ (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /home/eturismo/public_html/wp-admin/upgrade.php on line 18

    Te dice que escribas .:/usr/lib/php:/usr/local/lib/php en la línea 18 de upgrade.php

    Abre ese archivo y ponlo aquí para poder verlo y saber si es ese tu problema, saludos!

  • #26739

    Patagonia
    Participante

    lumbreras dijo:
    Ah lo que busque y encontré, en ésta parte:

    Fatal error: require() [function.require]: Failed opening required ‘../wp-load.php’ (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /home/eturismo/public_html/wp-admin/upgrade.php on line 18

    Te dice que escribas .:/usr/lib/php:/usr/local/lib/php en la línea 18 de upgrade.php

    Abre ese archivo y ponlo aquí para poder verlo y saber si es ese tu problema, saludos!

    Hola lumbreras, desde ya muchas gracias por contestar

    ahi va el archivo

    <?php
    /**
    * Upgrade WordPress Page.
    *
    * @package WordPress
    * @subpackage Administration
    */

    /**
    * We are upgrading WordPress.
    *
    * @since unknown
    * @var bool
    */
    define(‘WP_INSTALLING’, true);

    /** Load WordPress Bootstrap */
    require(‘../wp-load.php’);

    timer_start();
    require_once(ABSPATH . ‘wp-admin/includes/upgrade.php’);

    if ( isset($_GET[‘step’]) )
    $step = $_GET[‘step’];
    else
    $step = 0;

    // Do it. No output.
    if ( ‘upgrade_db’ === $step ) {
    wp_upgrade();
    die(‘0’);
    }

    $step = (int) $step;

    @header(‘Content-Type: ‘ . get_option(‘html_type’) . ‘; charset=’ . get_option(‘blog_charset’));
    ?>
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"&gt;
    <html xmlns="http://www.w3.org/1999/xhtml&quot; <?php language_attributes(); ?>>
    <head>
    <meta http-equiv="Content-Type" content="<?php bloginfo(‘html_type’); ?>; charset=<?php echo get_option(‘blog_charset’); ?>" />
    <title><?php _e(‘WordPress › Upgrade’); ?></title>
    <?php wp_admin_css( ‘install’, true ); ?>
    </head>
    <body>
    <h1 id="logo">"WordPress"</h1>

    <?php if ( get_option(‘db_version’) == $wp_db_version || !is_blog_installed()) : ?>

    <h2><?php _e(‘No Upgrade Required’); ?></h2>
    <p><?php _e(‘Your WordPress database is already up-to-date!’); ?></p>
    <p class="step">/"><?php _e(‘Continue’); ?></p>

    <?php else :
    switch($step) :
    case 0:
    $goback = stripslashes(wp_get_referer());
    $goback = clean_url($goback, null, ‘url’);
    $goback = urlencode($goback);
    ?>
    <h2><?php _e(‘Database Upgrade Required’); ?></h2>
    <p><?php _e(‘Your WordPress database is out-of-date, and must be upgraded before you can continue.’); ?></p>
    <p><?php _e(‘The upgrade process may take a while, so please be patient.’); ?></p>
    <p class="step">"><?php _e(‘Upgrade WordPress’); ?></p>
    <?php
    break;
    case 1:
    wp_upgrade();

    if ( empty( $_GET[‘backto’] ) )
    $backto = __get_option(‘home’) . ‘/’;
    else {
    $backto = stripslashes(urldecode($_GET[‘backto’]));
    $backto = clean_url($backto, null, ‘url’);
    }
    ?>
    <h2><?php _e(‘Upgrade Complete’); ?></h2>
    <p><?php _e(‘Your WordPress database has been successfully upgraded!’); ?></p>
    <p class="step">"><?php _e(‘Continue’); ?></p>

    <!–

    –>

    <?php
    break;
    endswitch;
    endif;
    ?>
    </body>
    </html>

    En caso de que este sea el PROBLEMA cual seria la linea 18.

    Pregunto en caso, porque si intento ver mi blog desde la url: http://www.eturismoviajes.com
    aparece este error:
    Fatal error: Call to undefined function wp_remote_post() in /home/eturismo/public_html/wp-includes/cron.php on line 204

    y otras veces este que paase anteriormente

    Fatal error: Call to undefined function wp_remote_request() in /home/eturismo/public_html/wp-includes/update.php on line 58

    Gracias

  • #26753

    Patagonia
    Participante

    Hola Lumbreras

    Desde ya muchas gracias por responder

    No se si el archivo subio, porque justo se cayo internet, bueno por las dudas ahi

    <?php
    /**
    * Upgrade WordPress Page.
    *
    * @package WordPress
    * @subpackage Administration
    */

    /**
    * We are upgrading WordPress.
    *
    * @since unknown
    * @var bool
    */
    define(‘WP_INSTALLING’, true);

    /** Load WordPress Bootstrap */
    require(‘../wp-load.php’);

    timer_start();
    require_once(ABSPATH . ‘wp-admin/includes/upgrade.php’);

    if ( isset($_GET[‘step’]) )
    $step = $_GET[‘step’];
    else
    $step = 0;

    // Do it. No output.
    if ( ‘upgrade_db’ === $step ) {
    wp_upgrade();
    die(‘0’);
    }

    $step = (int) $step;

    @header(‘Content-Type: ‘ . get_option(‘html_type’) . ‘; charset=’ . get_option(‘blog_charset’));
    ?>
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"&gt;
    <html xmlns="http://www.w3.org/1999/xhtml&quot; <?php language_attributes(); ?>>
    <head>
    <meta http-equiv="Content-Type" content="<?php bloginfo(‘html_type’); ?>; charset=<?php echo get_option(‘blog_charset’); ?>" />
    <title><?php _e(‘WordPress › Upgrade’); ?></title>
    <?php wp_admin_css( ‘install’, true ); ?>
    </head>
    <body>
    <h1 id="logo">"WordPress"</h1>

    <?php if ( get_option(‘db_version’) == $wp_db_version || !is_blog_installed()) : ?>

    <h2><?php _e(‘No Upgrade Required’); ?></h2>
    <p><?php _e(‘Your WordPress database is already up-to-date!’); ?></p>
    <p class="step">/"><?php _e(‘Continue’); ?></p>

    <?php else :
    switch($step) :
    case 0:
    $goback = stripslashes(wp_get_referer());
    $goback = clean_url($goback, null, ‘url’);
    $goback = urlencode($goback);
    ?>
    <h2><?php _e(‘Database Upgrade Required’); ?></h2>
    <p><?php _e(‘Your WordPress database is out-of-date, and must be upgraded before you can continue.’); ?></p>
    <p><?php _e(‘The upgrade process may take a while, so please be patient.’); ?></p>
    <p class="step">"><?php _e(‘Upgrade WordPress’); ?></p>
    <?php
    break;
    case 1:
    wp_upgrade();

    if ( empty( $_GET[‘backto’] ) )
    $backto = __get_option(‘home’) . ‘/’;
    else {
    $backto = stripslashes(urldecode($_GET[‘backto’]));
    $backto = clean_url($backto, null, ‘url’);
    }
    ?>
    <h2><?php _e(‘Upgrade Complete’); ?></h2>
    <p><?php _e(‘Your WordPress database has been successfully upgraded!’); ?></p>
    <p class="step">"><?php _e(‘Continue’); ?></p>

    <!–

    –>

    <?php
    break;
    endswitch;
    endif;
    ?>
    </body>
    </html>

    En caso de que fuese este el error, cual sería la linea 18

    Saludos

El foro ‘Instalación / Actualización’ está cerrado y no se permiten nuevos debates ni respuestas.

Pin It on Pinterest

Ir al contenido