Galería que usa imágenes de otra entrada (?)

Inicio Foros WordPress General WordPress.org Galería que usa imágenes de otra entrada (?)

Etiquetado: ,

Este debate contiene 4 respuestas, tiene 3 mensajes y lo actualizó  LGrusin hace 5 años, 6 meses.

  • Autor
    Publicaciones
  • #69654

    jjpinto
    Participante

    Hola!

    Tengo un problema en mi blog: http://www.jorgepinto.es/blog

    De momento sólo tengo 2 entradas. Cada entrada tiene una galería de imágenes, de tal forma que la entrada 1 tiene 15 imágenes, y la entrada 2 tiene 5 imágenes.

    Cuando entro en alguna de las entradas a editar la galería, ahí veo las imágenes que le corresponden efectivamente.

    De hecho, cuando publico las entradas, veo las miniaturas de esas imágenes (15 y 5, respectivamente). Hasta ahí todo correcto.

    PERO, cuando entro a ver las fotos de una de las galerías en grande, me encuentro TODAS las fotos que he subido (20), independientemente de si están en una entrada o en otra (y repito, cuando edito la galería veo sólo las correctas).

    Mi versión de WP es la 3.5.1, por si sirve de utilidad.

    Os agradecería mucho la ayuda, porque estoy bloqueado!

  • #69662

    Fernando Tellado
    Jefe de claves

    Es un comportamiento extraño porque la galería muestra los IDs de las imágenes que quieras mostrar. Mira el editor HTML a ver el código corto que sale, si sale solo esto mal:

    [gallery]

    Debería ser algo cómo … 
    [gallery ids="25,33,44"]

  • #69663

    jjpinto
    Participante

    Muchas gracias Fernando por tu respuesta.

    El código corto es como dices, [ gallery ids=123,124]… la cosa está en que viendo los códigos, en una entrada se ven los números de identificación de 15 imágenes, y en la otra entrada, de 5 imágenes, osea, todo ok… y como decía, en los thumbnails se ve el número adecuado, pero cuando se ven en grande, se ven las 20!

    Si quieres, puedes entrar en el enlace que puse, y verás exactamente a lo que me refiero.

    De nuevo, muchas gracias.

  • #69664

    Fernando Tellado
    Jefe de claves

    Pues he hecho lo que dices de entrar en una entrada y solo veo las imágenes de esa entrada, no todas, y el contador del lightbox me muestra las correctas

  • #69667

    LGrusin
    Miembro

    En las entradas funciona correctamente, es en la página dónde se muestran todas las imágenes. Si observan arriba la URL ha cambiado después de activarse el Lightbox.

    Algo extraño tienes por ahí, revisa bien la configuración del theme y los plugins que tienes instalados. Si no das con ello tendrás que preguntar al autor, es un theme premium.

    Un saludo

El foro ‘General WordPress.org’ está cerrado y no se permiten nuevos debates ni respuestas.

Pin It on Pinterest