insertar imagenes en los posts

Inicio Foros WordPress Programación insertar imagenes en los posts

Este debate contiene 6 respuestas, tiene 2 mensajes y lo actualizó  jetrel hace 7 años.

  • Autor
    Publicaciones
  • #22913

    jetrel
    Participante

    <p>el tema es que si cojo una imagen y la pego en el blog automaticamente se codifica en una imagen embebida, pero lo que quiero es que la imagen aparezca con la sintasis "img src=" o similar, pero cuando lo hago asi no me aparece la imagen, sabeis porque?<br />
    gracias
    </p>

  • #56464

    almendron
    Participante

    Te parecerá una tontería pero ¿has subido primero la imagen a tu servidor?

    En cualquier caso, si no le pones leyenda a la imagen, te saldrá con la sintaxis que tu quieres.

  • #56477

    jetrel
    Participante

    se que no es una tonteria, a veces se pasan detalles pero este no es el caso, la imagen esta subida a la carpeta /images.
    asi que eso no es.
    no entiendo lo que dices sobre la leyenda y la sintaxis

  • #56479

    almendron
    Participante

    Prueba lo siguiente:

    1.- Ve a Ajustes >> Multimedia e indica allí en la sección “Guardar los archivos subidos en esta carpeta” lo siguiente: wp-content/images

    2.- Inserta una imagen de forma automática. Puedes utilizar cualquiera de las que ya tienes en el servidor. Verás que hay una campo llamado “Leyenda”. Lo dejas en blanco.

    3.- Aparecerá una imagen con la sintaxis <img scr….

    4.- Cambia de Visual a HTML y echas un vistazo a la ruta. Así verás cómo hay que ponerla.

  • #56480

    jetrel
    Participante

    configuro ajustes-multimedia, inserto una imagen, leyendo en blanco y cuando me voy a HTML veo la imagen codificada: img src=”data:image/png;base64…

  • #56481

    almendron
    Participante

    Pues una de dos: o usas un plugin que embebe las imágenes en base 64 o el propio tema es el que lo hace.

    Puedes encontrar una explicación sobre este tipo de estilo de poner las imágenes en

    http://www.librosweb.es/css_avanzado/capitulo6.html

  • #56483

    jetrel
    Participante

    plugin no creo porque los únicos que tengo instalado en este tema son:

    -all in one seo pack
    -contact form 7
    -si captcha anti-spam
    -w3 total cache
    -wp-pagenavi

    y del tema tampoco creo porque la verdad es que me habia pasado con todos los temas hasta ahora, y he probado unos cuantos, nunca me habia preocupado hasta ahora, que me he dado cuenta que al codificar las imagenes aumenta el tamaño de la base de datos increiblemente asi que he optado por cambiar de sistema. Imagino que debo de ser yo que no estoy haciendo algo bien, voy a echarle un vistazo al enlace que me has recomendado y si encuentro la solución os la comento.
    gracias

El foro ‘Programación’ está cerrado y no se permiten nuevos debates ni respuestas.

Pin It on Pinterest