la he liado parda

Inicio Foros WordPress Instalación / Actualización la he liado parda

Este debate contiene 3 respuestas, tiene 2 mensajes y lo actualizó  dondado hace 9 años, 10 meses.

  • Autor
    Publicaciones
  • #12088

    Marcos
    Participante

    <p>Hola a todos</p>
    <p>Soy nuevo en esto, necesito ayuda porque estoy al borde del suicidio.</p>
    <p>Ayer me decidía a actualizar mi blog que estaba en wordpress 2.3 al 2.7, hice copia de la base de datos y de la carpeta de content, pero resulta que la carpeta de content no se grabó bien. </p>
    <p>El caso que no em dejoóa actualizar, asi que tuve que instalar de cero el wordpress 2.7. He encontrado una copia antigua de la carpeta content sabéis si la puedo pegar en la nueva carpeta de contet?</p>
    <p>Sabeis como puedo sobreescribir la copia de la base de datos Mysql para que me reconozca los post que tenia?</p>
    <p>Hay alguna solucióna este desastre???
    </p>

  • #25995

    dondado
    Participante

    ¿por qué no te dejó actualizar?, si la base de datos es de un WP 2.3 lo suyo es que vuelvas a montar un 2.3 y después la actualices, si eso no te funciona, intenta exportar los post (desde una versión 2.3) y luego los importas en una 2.7 nuevecita.
    Si has perdido el wp-content tiene peor solución, intenta buscar un backup más actual, quizá en tu hosting tengan uno. En principio, una vez que le tengas se puede montar con tan solo copiarlo en la instalación nueva

  • #25997

    Marcos
    Participante

    Muchas gracias tio

    no sé que pasó el caso es que solo tengo una copia del content de octubre, pero bueno, lo que si hice copia es de la base de datos, pero no consiguo importarla bien y que me reconozca los post

    perdona el lio es que ya no se que hacer…

    o sea que una base de datos en wp2.3 no sería compatible con 2.7?
    como exporto los post?

    entonces lo que tengo que intentar es
    – instalar worpress 2.3
    – luego importar la copia de la base de datos nueva que tenia
    – luego copiar la carpeta de content más nueva que tenga no??

  • #25998

    dondado
    Participante

    Eso es, para pasar una base de datos de 2.3 a 2.7 tienes que ejecutar el upgrade.php que se encargará de convertirla.
    Vuelve a montar el WP 2.3 (aprovecha para hacer una exportación completa de los post por si acaso no funciona otra vez la actualización) y con el content montado vuelve a intentar el upgrade. Si no te funciona habría que revisar por qué, tal vez tengas que migrar primero a 2.5 y después a 2.7, aunque de eso no estoy seguro

El foro ‘Instalación / Actualización’ está cerrado y no se permiten nuevos debates ni respuestas.

Pin It on Pinterest

Ir al contenido