¿Las actualizaciones afectan al funcionamiento de los Themes?

Inicio Foros WordPress Themes y Diseño ¿Las actualizaciones afectan al funcionamiento de los Themes?

Este debate contiene 6 respuestas, tiene 5 mensajes y lo actualizó  Esteban Rojas hace 7 años, 10 meses.

  • Autor
    Publicaciones
  • #20005

    mt03
    Participante

    <p>Buenos dias, a ver si me podeis ayudar.</p>
    <p>Hemos contratado a una empresa para desarrollar una pagina web en WordPress.<br />
    La pagina esta casi acabada. Tiene unos cuantos plugins instalados (nada extraño, de galerias, videos, …)</p>
    <p>Han desarrollado una theme a partir del que viene por defecto en WordPress, Twentyten.<br />
    El problema que tenemos ahora es que afirman que las actualizaciones de WordPress afectan a la pagina tal como esta ahora y deja de funcionar.<br />
    Yo creo que si estuviera bien hecho, esto no deberia pasar, verdad?<br />
    Puedo entender que si intentas pasar de la version 3.0.1 a la 5.0.0 (por decir algo) haya algun problema.<br />
    Pero por pasar de la 3.0.4 a la 3.0.5 no deberia haber problemas, verdad?</p>
    <p>Un saludo y muchas gracias por vuestra ayuda
    </p>

  • #48970

    preguntarix
    Participante

    Algunos problemas pueden ocurrir al pasar de 2.9.2 a 3.x ya que algunas de las funciones que afectan a las plantillas han cambiado, pero la última versión estable es la 3.0.4 si están intentado usar una versión superior a esta eso si probablemente ocasione algunos problemas ya que son versiones aún no estabilizadas.
    ¿Que tipo de problemas has notado?

  • #48975

    mt03
    Participante

    Hola, muchas gracias por responder
    No he visto exactamente los problemas, pero me han comentado que existian.

    Lo que a mi me parece es precisamente eso, que en un cambio grande de version si que puede haber algun desajuste, pero que por pasar de la 3.0.1 a la 3.0.3, siempre que los plugins esten preparados para la ultima version, deberia seguir funcionando todo.

    Yo soy un aficionado, y en las paginas que he hecho (por pasar el rato) con plantillas gratuitas descargadas de internet nunca me ha dado problemas al actualizar.

    Algunos problemas pueden ocurrir al pasar de 2.9.2 a 3.x ya que algunas de las funciones que afectan a las plantillas han cambiado, pero la última versión estable es la 3.0.4 si están intentado usar una versión superior a esta eso si probablemente ocasione algunos problemas ya que son versiones aún no estabilizadas.
    ¿Que tipo de problemas has notado?

  • #48978

    preguntarix
    Participante

    En efecto actualizar de 3.0.1 a 3.0.3 no debería darte ningún tipo de problemas desde ya para las plantillas no hay diferencia alguna, en las propias páginas de los pluguin dice desde que versión funcionan y hasta que versión han sido probados.

    Ya te digo en cuanto a los themes y plugs no deberías tener ningún problema, ahora si han modificado otros archivos del wp puede que la actualización se complique algo y que no haya que hacerla de manera automática si no a la antigua vía ftp conservando los archivos modificados.

    Tengo entendido que entre 3.0.1 a 3.0.3 solo hay correcciones de bugs y de seguridad por lo tanto no veo que vaya a ser necesario adaptar ninguna de las modificaciones hechas al menos que justo sean sobre estas lineas modificadas.

    Pídele a la empresa contratada más detalles.

    En cuanto a pasar de 2.9.2 a 3.x claro que en muchos casos no trae ningún problema en las plantillas yo hasta ahora las pude seguir utilizando todas (pero si que puede haber problemas si la plantilla usa alguna de las funciones desaparecidas, tuve suerte) pero si e tenido problemas al intentar usar plantillas de la nueva generación (la 3.x) con instalaciones 2.9.2.

    Insisto pídele más detalles a los desarrolladores que contrataste.

  • #48982

    sergio23
    Participante

    Buenos dias, a ver si me podeis ayudar.
    Hemos contratado a una empresa para desarrollar una pagina web en WordPress.
    La pagina esta casi acabada. Tiene unos cuantos plugins instalados (nada extraño, de galerias, videos, …)
    Han desarrollado una theme a partir del que viene por defecto en WordPress, Twentyten.
    El problema que tenemos ahora es que afirman que las actualizaciones de WordPress afectan a la pagina tal como esta ahora y deja de funcionar.
    Yo creo que si estuviera bien hecho, esto no deberia pasar, verdad?
    Puedo entender que si intentas pasar de la version 3.0.1 a la 5.0.0 (por decir algo) haya algun problema.
    Pero por pasar de la 3.0.4 a la 3.0.5 no deberia haber problemas, verdad?
    Un saludo y muchas gracias por vuestra ayuda

    Tienes toda la razón los desarrolladores del theme no saben hacer su trabajo, en alguna parte del código hicieron algo mal, por eso el theme no funciona como debe.

  • #48983

    imported_fliberty
    Participante

    Yo he realizado themes desde la versión 2.9.2 de wordpress, ahora utilizo la versión 3.1.2. y los themes que he realizado siguen funcionando perfectamente bien.

    Pienso que funcionarían mal si estuviesen utilizando funciones que se utilizaban en versiones anteriores a la 2.9.2 que es la más estable y es cuando se cambiaron algunas funciones (no todas), por lo demás lo que dice preguntarix es cierto, ocurrirían errores si y solo en la elaboración del theme has tenido que modificar archivos del sistema de wordpress (lo cual es improbable).

  • #48984

    Esteban Rojas
    Participante

    Lo que te dicen no deberia pasar, de hecho esto sólo pasaría si ellos modificaron archivos de WP directamente en vez de usar actions & filters.

El foro ‘Themes y Diseño’ está cerrado y no se permiten nuevos debates ni respuestas.

Pin It on Pinterest