Me aparecen post viejos en portada

Inicio Foros WordPress Instalación / Actualización Me aparecen post viejos en portada

Etiquetado: , , ,

Este debate contiene 8 respuestas, tiene 4 mensajes y lo actualizó  dragonjar hace 7 años, 2 meses.

  • Autor
    Publicaciones
  • #21287

    dragonjar
    Participante

    <p>Acabo de hacer una migración de servidor y todo ha salido bien, solo que cuando voy a la portada de mi sitio me aparecen entradas del año 2008, las entradas nuevas están publicadas y se pueden acceder a ellas, pero en la portada solo aparecen del año 2008 para atrás…</p>
    <p>al principio pensé que era problemas de la fecha del sistema pero están bien, ya intente lo siguiente:</p>
    <p>Cambiar fecha del sistema<br />
    Publicar un nuevo tema<br />
    Cambiar todos los parámetros de Ajustes de lectura<br />
    Revisar el código fuente de la portada<br />
    Y muchas cosas mas.</p>
    <p>Yo creo que el problema radica en algún lugar en la base de datos, de pronto un campo secuencial o algo que no he notado, pero de momento no he podido dar con el problema.</p>
    <p>Alguien ha tenido este problema antes?<br />
    Podrian ayudarme?
    </p>

  • #52422

    LGrusin
    Miembro

    ¿Antes de la migración iba bien?

    Las categorías, las búsquedas y las tags van bien. Sólo afecta al index.php.

    Pon el código de este archivo.

    Saludo

  • #52441

    imported_medievalia
    Participante

    Estos errores son muy raros, pero posibles.
    Yo intentaría:
    1 – Cambiar los enlaces permamentes. Si lo tienes modificados. Y luego volver a ponerlos tal cual.
    2 – Volver a empezar desde el principio. Base de datos nueva, nueva instatalacion, etc.
    Suerte y saludos.

  • #52442

    imported_medievalia
    Participante

    Y te muevo el hilo a “Instalacion / Actualizacion, que lo publicaste en General WordPress.org

  • #52448

    dragonjar
    Participante

    @lgrusin si antes de la migración estaba perfecto, no se que pasa.

    @medievalia cambié los permalinks y no pasó nada pero acabo de notar que las noticias estas organizadas por el ID, si lograra organizarlas por el campo FECHA se resolvería el problema…

    Sabes como hacer eso?

  • #52452

    LGrusin
    Miembro

    Si pones el código te podemos decir. Así sin verlo es dificil.

    Lo que puedes hacer es comparar los archivos para ver las diferencias. Compara search.php, archive.php (estos archivos están bien) con el index.php. Si no existe index.php pues loop.php o el que cargue al inicio.

    Debes fijarte en lo que pone antes del bucle while. Algo como:

    Saludos

  • #52459

    dragonjar
    Participante

    @lgrusin esto es lo que tengo después del while

  • #52460

    almendron
    Participante

    Pon, como te ha dicho L.Grusin, lo que hay [b]antes del while[/b]. Supongo que querrá ver si se ejecuta alguna consulta antes de mostrar las entradas.
    Un saludo.

  • #52474

    dragonjar
    Participante

    @almendron Lo hice y sigue igual, pero me dio por activar el theme por defecto de WP y en ese theme no hay problema, al parecer es con mi theme headlines, pero en otra maquina tengo exactamente lo mismo y se muestra bien.

    Al darme cuenta que el problema era por el theme, le metí mano y he podido resolver mi problema cambiando

    Por este donde organizo el query antes de mostrarlo

    Esto me ha solucionado mi problema, pero si tienen una mejor solución, mas optima soy todo oídos.

El foro ‘Instalación / Actualización’ está cerrado y no se permiten nuevos debates ni respuestas.

Pin It on Pinterest