¿Me cambio a PHP5?

Inicio Foros WordPress Instalación / Actualización ¿Me cambio a PHP5?

Etiquetado: ,

Este debate contiene 6 respuestas, tiene 3 mensajes y lo actualizó  silviagm hace 7 años, 9 meses.

  • Autor
    Publicaciones
  • #20310

    silviagm
    Participante

    <p>Hola, quería consultar sobre cambiar de PHP4 a PHP5.<br />
    Estoy con WP 3.0.1 y no tengo conocimientos de informática. Pero gracias a la facilidad de uso de WP, a una página con videotutoriales (www.wordpresscurso.com) y a contar con este foro, he podido crear un sitio (www.eba-asociacion.org) bastante digno.<br />
    El motivo de pensar en cambiar a PHP5 es porque al instalar el plugin NEXTGEN Gallery no me da la opción de traducción al español. Sale la opción "TRANSLATION" pero no para usar el plugin en español, sino por si te quieres ofrecer a traducir el plugin a otros idiomas. Y hay un cuadro de advertencia de que estoy en PHP4 y que si no tengo PHP5 algunas funciones pueden no estar disponibles ¿Será la traducción una de ellas?<br />
    Había probado este plugin un dia antes en mi localhost, y ahí sí aparece la opción "TRANSLATION" para usar el plugin en español, y funciona sin problemas, no me sale el cuadro de advertencia sobre el PHP.<br />
    ¿Creeis que lo de no poder traducir el plugin tiene relación con el PHP?<br />
    ¿Me arriesgo a cambiar? He consultado con mi hosting y me pueden migrar el dominio a una máquina con PHP5, pero me advierten que algunas páginas pueden tener problemas después.<br />
    He consultado algunos mensajes en el foro y veo que sí que algunos habeis tenido problemas de acentos o de funcionamiento de plugins…<br />
    Supongo que puedo pasar sin la traducción de un plugin, pero no se si con el tiempo tendré que cambiar igual…<br />
    ¿Qué opinais?<br />
    Gracias, un saludo,<br />
    Silvia
    </p>

  • #49689

    almendron
    Participante

    Si el sitio está basado exclusivamente en wordpress, no deberías tener ningún tipo de problema. De hecho es conveniente pasar a PHP5. En mi servidor tengo instalada la versión 5.2.8 y va perfecta (Ojo: no tengo instalado el plugin que mencionas).

    Comprueba asimismo si en tu instalación local corre la misma versión de PHP que en el servidor.

  • #49703

    silviagm
    Participante

    Almendron,muchas gracias por tu respuesta.
    La instalación local la hice con Xampp, no se la versión exacta del PHP, pero sí que es PHP5.
    La página está basada exclusivamente en WP y es sencilla, asi que me parece que haré el cambio.
    ¿Hay que tener en cuenta algún preparativo? ¿Hay que desactivar o desinstalar los plugins?
    Gracias por la ayuda.

  • #49708

    almendron
    Participante

    El motivo por el que en local te funciona, es porque ahí tienes la versión 5 de PHP.

    En cuanto a los preparativos, no estaría de más de desactivaras todos los plugins, y una vez instalada la nueva versión de PHP en el servidor volver a activarlos.

    En cualquier caso, prueba primero en tu instalación local. Supongo que Xampp tendrá la opción de cambiar la versión de PHP. Si no es así, prueba a usar WampServer. Una vez instalado, si quieres usar una versión PHP4, deberás descargarla e instalarla aparte.

  • #50200

    silviagm
    Participante

    Os informo de que mi hosting ya hizo la migración de mi página a un servidor con PHP5 y la página funciona bien.
    Respecto a la opción de traducción del plugin NEXTGEN Gallery, que fue el origen de mi consulta y de pensar en migrar a una máquina con PHP5, tras la migración sí sale la opción de descargar el archivo en tu idioma. La ejecuto y confirma que la ha realizado con éxito, que sólo he de dar a recargar la página (esto lo hice en mi localhost y funcionó a la primera), pero lo hago y sigue sin aparecer en español. Cada vez que entro en la página me vuelve a salir la opción de descargar tu idioma, repito los pasos, pero sigue el aviso de recargar la página y de ahí no pasa.
    Es la única pega que he encontrado, por lo demás todo funciona correctamente.
    Si teneis alguna idea más os lo agradeceré.
    Gracias por la ayuda!

  • #50202

    imported_j.conti
    Participante

    Es muy posible que sean permisos de escritura.

    El plugin descarga el idioma y lo intenta guardar en algún sitio de la estructura (desconozco dónde).

    No puede gusrdarlo ya que no tiene permisos pero no te avisa de ello.

    Al recargar la página, al no disponer todabía de los archivos de traducción (ya que no ha podido guardarlos) te vuelve a lanzar el aviso.

    Deberás averiguar dónde los guarda y darle permisos 777.

    Una vez que los haya descargado, devuelve los permisos originales al subdirectorio.

    salu2

  • #50209

    silviagm
    Participante

    Muchas gracias por la ayuda! Ya funciona!
    Pues sí que eran los permisos de escritura. Como no me salia ninguna advertencia, no se me ocurrió.
    Para cambiarlo, he consultado la página del plugin. Ahí explica que los idiomas están en la carpeta “lang” dentro de la carpeta de “Nextgen”, carpeta que a su vez está dentro de la carpeta “Plugins”.
    He dado permisos 777 a “Lang” y ¡resuelto!
    Una última duda, ¿es conveniente dejar esta carpeta “Lang” con permisos 777, o es peligroso?
    Saludos

El foro ‘Instalación / Actualización’ está cerrado y no se permiten nuevos debates ni respuestas.

Pin It on Pinterest

Ir al contenido