Menu dropdown no funciona en chrome

Inicio Foros WordPress General WordPress.org Menu dropdown no funciona en chrome

Etiquetado: , ,

Este debate contiene 4 respuestas, tiene 3 mensajes y lo actualizó  sancocho hace 7 años, 3 meses.

  • Autor
    Publicaciones
  • #21731

    sancocho
    Participante

    <p>Pues eso, que en firefox va de maravilla pero en chrome no tira.<br />
    En concreto es este con algunas modificaciones para adpatarlo al theme.</p>
    <p>Puedes verlo en http://www.sancocho.com</p&gt;
    <p>Gracias por la ayuda !
    </p>

  • #53538

    LGrusin
    Miembro

    Hombre uno de la tierra…

    Lo veo perfectamente en Chrome. ¿Exactamente qué es lo que no sale bien?

    Si has hecho cambios elimina el historial de navegación para que se actualice el navegador.

    Saludos

  • #53542

    gventura
    Participante

    Creo que lo que no le funciona bien es pasar el cursor del menú principal hacia uno de los submenús.

    En Firefox (en mi caso en ubuntu) también falla pero mucho menos.

    Creo que se soluciona de un modo muy tonto. Las subopciones deben estar pegadas al menú principal y esos casos están separadas por 1 o 2 píxeles hecho que al pasar el cursor por allí piense que estas fuera del menú haciendo desaparecer el submenú. Si pruebas de bajar rápido hacia las subopciones falla menos. (Lo digo sin mirar código pero alguna vez me ha pasado algo parecido)

    Si quieres que el submenú parezca separado yo le haría un border-top del color y ancho deseado, con eso eliminas el espacio vacío y estéticamente queda idéntico.

    Espero que este sea el problema que cuentas y una posible solución.

    Saludos,

  • #53543

    LGrusin
    Miembro

    Anda, pues no me había dado cuenta… Falla por ejemplo el menú de “Descargas” que tiene debajo el menú “Buscamos [email protected]” Lo mismo pasa con “Artículos”. Sin embargo, no pasa con “RadioShow” si te colocas al final.

    El problema es que tiene otro enlace debajo. El enlace superior por así decirlo debe funcionar como las capas de Photoshop. Debe tener preferencia sobre el menú o enlace inferior. Eso se soluciona poniendo un z-index:200 o mayor por ejemplo en el UL:hover del submenú. No sé si ya lo tienes así.

    De todas formas comprueba lo que dice gventura porque haciéndole un zoom a la página se nota separado el submenú. Es preferible ponerle un borde si quieres un poco de separación.

    El margin-top ese de ul#navmenu-h ul a 3px parece el sospechoso.

    Un saludo

  • #53552

    sancocho
    Participante

    Muchas gracias por la ayuda. Finalmente era [quote]El margin-top ese de ul#navmenu-h ul a 3px parece el sospechoso.[/quote]

El foro ‘General WordPress.org’ está cerrado y no se permiten nuevos debates ni respuestas.

Pin It on Pinterest