Mi WordPress consume mucha CPU y me quieren echar del host

Inicio Foros WordPress Dominios – Hosting Mi WordPress consume mucha CPU y me quieren echar del host

Etiquetado: , , ,

Este debate contiene 13 respuestas, tiene 5 mensajes y lo actualizó  imported_fliberty hace 7 años, 8 meses.

  • Autor
    Publicaciones
  • #18550

    VySe
    Participante

    <p>Desde hace 5 días mi WordPress consume mucha CPU y me han avisado los del host compartido que o lo arreglo, o me echan. O también si me hago con un servidor dedicado (con 1500 visitas diaras imposible).</p>
    <p>Mi página es http://www.escuadronpikmin.com</p&gt;
    <p>Llevo meses con las mismas visitas y actividad. No he tocado absolutamente nada y de repente ha subido el consumo. He desintalado plugins por si acaso, y nada, he instalado WP Super Cache, DB Cache Reload y no noto mejoria. </p>
    <p>Estos son los datos de los ultimos 5 días:</p>
    <p>Stats for 04 Sep 2010:<br />


    <br />
    CPU Usage – %12.38<br />
    MEM Usage – %3.14<br />
    Number of MySQL procs (average) – 0.82<br />
    Top Process %CPU 52.00 [php]<br />
    Top Process %CPU 51.00 [php]<br />
    Top Process %CPU 48.00 /usr/bin/php /home/escua0/public_html/index.php</p>
    <p>Stats for 03 Sep 2010:<br />


    <br />
    CPU Usage – %2.88<br />
    MEM Usage – %1.86<br />
    Number of MySQL procs (average) – 0.00<br />
    Top Process %CPU 60.00 /usr/bin/php /home/escua0/public_html/index.php<br />
    Top Process %CPU 6.70 [php]<br />
    Top Process %CPU 1.40 [php]</p>
    <p>Stats for 02 Sep 2010:<br />


    <br />
    CPU Usage – %1.50<br />
    MEM Usage – %0.95<br />
    Number of MySQL procs (average) – 0.08<br />
    Top Process %CPU 36.00 [php]<br />
    Top Process %CPU 0.10 httpd [escuadronpikmin.com] [/wp-content/uploads/2010/09/Captura-de-pantalla-2010-09-01-]</p>
    <p>Stats for 01 Sep 2010:<br />


    <br />
    CPU Usage – %0.95<br />
    MEM Usage – %0.60<br />
    Number of MySQL procs (average) – 0.00<br />
    Top Process %CPU 20.00 [php]<br />
    Top Process %CPU 0.20 httpd [escuadronpikmin.com] [/]<br />
    Top Process %CPU 0.10 httpd [escuadronpikmin.com] [/]</p>
    <p>Stats for 31 Aug 2010:<br />


    <br />
    CPU Usage – %5.68<br />
    MEM Usage – %0.98<br />
    Number of MySQL procs (average) – 0.17<br />
    Top Process %CPU 64.00 /usr/bin/php /home/escua0/public_html/index.php<br />
    Top Process %CPU 53.00 /usr/bin/php /home/escua0/public_html/index.php<br />
    Top Process %CPU 20.00 [php]</p>
    <p>Stats for 30 Aug 2010:<br />


    <br />
    CPU Usage – %7.03<br />
    MEM Usage – %1.03<br />
    Number of MySQL procs (average) – 0.17<br />
    Top Process %CPU 65.00 [php]<br />
    Top Process %CPU 50.00 /usr/bin/php /home/escua0/public_html/index.php<br />
    Top Process %CPU 43.30 [php]</p>
    <p>Stats for 29 Aug 2010:<br />


    <br />
    CPU Usage – %1.66<br />
    MEM Usage – %1.37<br />
    Number of MySQL procs (average) – 0.25<br />
    Top Process %CPU 36.00 /usr/bin/php /home/escua0/public_html/index.php<br />
    Top Process %CPU 2.50 [php]<br />
    Top Process %CPU 0.40 /usr/bin/php /home/escua0/public_html/index.php</p>
    <p>Estoy desesperado, no se que hacer. Gracias de antemano.
    </p>

  • #45103

    images3dbank
    Participante

    No sé si puedes, pero quizás convenga que desactives varios plugins por 24 hs por ejemplo y luego veas el consumo. Si continua ya sabes que no es ninguno de ellos y si cae el consumo, ya sabrás que si que és alguno de ellos y comienzas a activarlos de a uno.

  • #45104

    VySe
    Participante

    Había quitado un montón de plugins como los de facebook, twitter etc. Y bueno, la cosa sigue igual.

    Ahora tengo estos:

    Akismet
    All in One SEO Pack
    DB Cache Reloaded
    Google XML Sitemaps
    Gravatar (and userpics)
    GZippy
    MCEComments
    MultiUploader 4 WordPress
    TPC! Memory Usage
    WP-PageNavi

    La cuestión es que desde hace 5 días el consumo de CPU ha subido de una forma muy bestia, y como ya he dicho, las visitas son las mismas y no he instalado nada.

    Los del host no me van a dar mas tiempo y el consumo de la CPU no baja….. Estoy desesperado.

    He leido que instalando Eaccelerator podría arreglarse, pero no tengo ni idea de PHP y un plugin que hay para WordPress para poder instalarlo no me deja… 😥

  • #45107

    Micke
    Participante

    Revisa que no tengas algún Cron Job activo.

  • #45108

    VySe
    Participante

    Revisa que no tengas algún Cron Job activo.

    He mirado en el CPanel del host y no hay ningún Cron Job activado. :s

    He desactivado todos los Plugins y Widgets y la cosa sigue mas o menos igual:

    CPU Usage – %6.91
    MEM Usage – %1.79
    Number of MySQL procs (average) – 0.31
    Top Process %CPU 51.00 [php]
    Top Process %CPU 49.00 [php]
    Top Process %CPU 47.00 [php]

  • #45117

    imported_Avelino FV
    Participante

    Es posible que el bot de algún motor de busqueda esté haciendo lecturas cíclicas una y otra vez incrementando los accesos a la base de datos, el consumo de ancho de banda así como de la memoria y el uso de la CPU.

    En el archivo robot que tienes en la raiz de su intalación impide el acceso de todos los bot durante un tiempo.

  • #45118

    imported_Avelino FV
    Participante

    Puedes crear el archivo robot.txt con las siguientes líneas:

    User-agent: *
    Disallow: /

    Con lo que impides a todos los bot (google, msn, etc) el acceso a tu sitio.

  • #45119

    VySe
    Participante

    Gracias por responder.

    Pregunta de novato: ¿Crear ese robot afecta de alguna manera a la indexación de mis paginas en google?

  • #45120

    imported_Avelino FV
    Participante

    El archivo robot.txt es muy útil.
    En este caso concreto evitará durante un tiempo el acceso de los bots para averigüar si son la causa de los incrementos de consumo, una vez solucionado el problema, puedes crearte un robot.txt adaptado a tus necesidades.

    Puedes leer más sobre robot.txt en:
    [url=http://alexseo.com/utiliza-un-robotstxt-para-mejorar-tu-posicionamiento/]AlexSEO[/url]
    [url=http://www.metodoprofesional.es/blog/articulos/posicionamiento-web-en-buscadores-el-archivo-robotstxt]MetodoProfesional[/url]
    [url=http://www.seofemenino.com/2009/09/06/google-rastrea-el-archivo-robotstxt-diariamente/]SEOFemenino[/url]

  • #45146

    VySe
    Participante

    He creado un robot.txt este medio día y en seis horas que lleva puesto parece que la cosa no mejora. 🙁

    Ahora la situación está así:

    CPU Usage – %4.37
    MEM Usage – %1.74
    Number of MySQL procs (average) – 0.10
    Top Process %CPU 91.00 /usr/bin/php /home/escua0/public_html/wp-cron.php
    Top Process %CPU 65.50 /usr/bin/php /home/escua0/public_html/index.php
    Top Process %CPU 60.20 /usr/bin/php /home/escua0/public_html/index.php

    No entiendo como puede consumir tanto el wp-cron.php He leido que es el encargado de las entradas programadas, y no tengo ninguna. Y después el index.php consumiendo también lo suyo…

    Tengo todos los plugins desactivados excepto akismet, gravatar y wp page navi…

    Ya no se que hacer… Ayer reinstale wordpress y lo deje limpio. 😥

  • #45147

    imported_fliberty
    Participante

    Porque no tratas de cambiar el theme, puede que sea el theme…?

  • #45148

    VySe
    Participante

    Cambie el theme al que venía por defecto en wordpress y lo mismo…

    Esta mañana estaba perfecto después de reeinstarlo y dejarlo toda la noche sin plugins:

    CPU% 1.08
    MEM% 1.09
    SQL 0.0
    Top Process %CPU 43.0 [php]
    Top Process %CPU 0.2 httpd [escuadronpikmin.com] [/wp-content/uploads/2009/09/PES2010_Wii_Packshot_TorresMess]
    Top Process %CPU 0.1 httpd [escuadronpikmin.com] [/wp-content/uploads/2010/07/metroid_other_m_boxart_japan.jp]

    Después he activado el akismet, All in One SEO Pack, Google XML Sitemaps y ha subido el consumo a como os he expuesto anteriormente.

  • #45149

    VySe
    Participante

    Por otro lado… podría ser de la base de datos?

    Me he metido en MyPhpAdmin y veo abajo el siguiente mensaje:

    [quote]Las opciones adicionales para trabajar con tablas vinculadas fueron desactivadas. Para saber porqué, dé clic aquí.[/quote]

    Le doy click y… sale todo esto:

    [quote]$cfg[‘Servers’][$i][‘pmadb’] … no recibió el OK [ Documentación ]
    $cfg[‘Servers’][$i][‘relation’] … no recibió el OK [ Documentación ]
    Opciones de relación general: Deshabilitado

    $cfg[‘Servers’][$i][‘table_info’] … no recibió el OK [ Documentación ]
    Mostrar las opciones: Deshabilitado

    $cfg[‘Servers’][$i][‘table_coords’] … no recibió el OK [ Documentación ]
    $cfg[‘Servers’][$i][‘pdf_pages’] … no recibió el OK [ Documentación ]
    Creación de los PDF: Deshabilitado

    $cfg[‘Servers’][$i][‘column_info’] … no recibió el OK [ Documentación ]
    Mostrando los comentarios de la columna: Deshabilitado
    Consulta guardada en favoritos: Deshabilitado
    Transformación del navegador: Deshabilitado

    $cfg[‘Servers’][$i][‘history’] … no recibió el OK [ Documentación ]
    Historial-SQL: Deshabilitado

    $cfg[‘Servers’][$i][‘designer_coords’] … no recibió el OK [ Documentación ]
    Diseñador: Deshabilitado[/quote]

    Es que como no sea eso yo ya no se que hacer. Pero lo mejor de todo es que no tengo ni idea de Bases de datos.

  • #45152

    imported_fliberty
    Participante

    Yo también tenía problemas de consumo de CPU, tenía un promedio de 800 visitas, hice un upgrade (aumente ancho de banda, espacio en disco, memoria, etc), pero bueno el consumo seguía, le metí y probé cuanto plugin de caché encontraba, habilité la compresión gzip, también encontré lo del eacelerator, pensé que lo podría utilizar pero luego me enteré de que eso se instalaba en el servidor, la verdad es que andaba loco… Me recomendaron eliminar plugins, cambiar de theme, y la verdad es que como tú eso no resolvía mi problema, al final no se que fue lo que pasó…

    Realicé un nuevo theme, sigo utilizando los plugins que tenía, utilizo super caché, habilité la compresión gzip desde htaccess, y bueno además de eso, estoy alojando todas la imágenes incluido los thumbnail en tinypic e insertándolas en los artículos por medio de shortcodes.

    Ahora mi consumo está bien, claro no tan normal, pero al menos no se tira abajo la CPU, pero por lo demás todo bien.

    Amigo, espero que soluciones tus problemas, se lo que estas pasando, a mi me suspendieron mi web unas 5 veces por el problema este y no es nada agradable cuando sucede.

El foro ‘Dominios – Hosting’ está cerrado y no se permiten nuevos debates ni respuestas.

Centro de preferencias de privacidad

Cookies imprescindibles

Se usan para saber si ya aceptaste nuestras políticas y para servir más rápidos los contenidos.

gpdr, wpSGCacheBypass

Cookies de terceros

Usamos cookies de terceros en las que se almacenan externamente para conocer tus usos de navegación, si ya estás suscrito al boletín y los elementos compartidos en redes sociales

cfduit_, intercom-id, intercom-lou, mailerlite:language, mailerlite:webform, _ga, _gid

Pin It on Pinterest