Mostrar solo categoria en box…

Inicio Foros WordPress Themes y Diseño Mostrar solo categoria en box…

Etiquetado: , ,

Este debate contiene 0 respuestas, tiene 1 mensaje y lo actualizó  soyloque hace 9 años, 2 meses.

  • Autor
    Publicaciones
  • #13988

    soyloque
    Participante

    <p>Hola a to2. Espero que esteis disfrutando de vuestro descanso. A mi me ha tocado currar. Os cuento el problema que tengo y que me tiene atascado.</p>
    <p>Utilizo el theme RichWP Magazine (light) 1.0 , y de momento iba todo bien hasta que me encuentro que quier restringir documentos dentro de unas mismas categorias segun usuario.<br />
    Para las restricciones de documentos uso el maravillos plugin : User Access Manager.</p>
    <p>Todo perfecto, creo los usuarios, los grupos de acceso… pero aqui viene el pero.<br />
    Si entro con un usuario de los ultimos creado si me aparecen sus post en sus recuadros con sus categorias. TODO OK.<br />
    Si cojo usuarios que he creado los post mas antiguos, no aparecen…<br />
    Creo entender que es por un tema de $recent.<br />
    Aqui tengo el codigo:<br />

    Code:
    <br />
    [b]&lt;?php $recent = new WP_Query("cat=3&amp;showposts=1"); while($recent-&gt;have_posts()) : $recent-&gt;the_post();?&gt;[/b]<br />
    &lt;?php if( get_post_meta($post-&gt;ID, "thumbnail", true) ): ?&gt;<br />
    &lt;div class="content_home_330_box"&gt;<br />
    <a>"&gt;<img />ID, "thumbnail", true); ?&gt;" border="0" alt="&lt;?php the_title(); ?&gt;" /&gt;</a><br />
    &lt;?php else: ?&gt;&lt;div class="content_home_330_box"&gt;<br />
    <a>"&gt;<img />/&lt;?php echo $magazine_color_scheme; ?&gt;/dummy_thumb.gif" border="0" alt="&lt;?php the_title(); ?&gt;" /&gt;</a><br />
    &lt;?php endif; ?&gt;<br />
    &lt;h2 class="box_h2"&gt;<a>" rel="bookmark"&gt;&lt;?php the_title(); ?&gt;</a>&lt;/h2&gt;<br />
    &lt;div class="date_home"&gt;&lt;?php the_time(__(‘F jS, Y’)) ?&gt;&lt;/div&gt;<br />
    &lt;/div&gt;&lt;!– content_home_330_box END –&gt;<br />
    &lt;?php endwhile; ?&gt;<br />

    <br />
    He mirado y reconsultado. y he probado esto: </p>
    <p>

    Code:
    [b]&lt;?php query_posts(‘showposts=1&amp;cat=3’); ?&gt;<br />
    &lt;?php while (have_posts()) : the_post(); ?&gt;[/b]<br />
    &lt;?php if( get_post_meta($post-&gt;ID, "thumbnail", true) ): ?&gt;<br />
    &lt;div class="content_home_330_box"&gt;<br />
    <a>"&gt;<img />ID, "thumbnail", true); ?&gt;" border="0" alt="&lt;?php the_title(); ?&gt;" /&gt;</a><br />
    &lt;?php else: ?&gt;&lt;div class="content_home_330_box"&gt;<br />
    <a>"&gt;<img />/&lt;?php echo $magazine_color_scheme; ?&gt;/dummy_thumb.gif" border="0" alt="&lt;?php the_title(); ?&gt;" /&gt;</a><br />
    &lt;?php endif; ?&gt;<br />
    &lt;h2 class="box_h2"&gt;<a>" rel="bookmark"&gt;&lt;?php the_title(); ?&gt;</a>&lt;/h2&gt;<br />
    &lt;div class="date_home"&gt;&lt;?php the_time(__(‘F jS, Y’)) ?&gt;&lt;/div&gt;<br />
    &lt;/div&gt;&lt;!– content_home_330_box END –&gt;<br />
    &lt;?php endwhile; ?&gt;<br />

    <br />
    Sustituyendo las lineas en negrita. pero sigo igual.<br />
    Alguien sabe donde tengo el error?<br />
    Gracias por adelantado.
    </p>

El foro ‘Themes y Diseño’ está cerrado y no se permiten nuevos debates ni respuestas.

Pin It on Pinterest