N° DE COMENTARIOS DEL POST COMO EN AYUDAWORDPRESS

Inicio Foros WordPress Programación N° DE COMENTARIOS DEL POST COMO EN AYUDAWORDPRESS

Etiquetado: 

Este debate contiene 20 respuestas, tiene 2 mensajes y lo actualizó  imported_mediastudio hace 7 años.

  • Autor
    Publicaciones
  • #23194

    <p>Hola estoy haciendo un blog y necesito que solo aparezca el Numero de comentarios que hay en el post como en el blog de ayudawordpress, es decir que no aparezca el texto comments o comentarios, al igual que en este blog estoy usando disqus.</p>
    <p>Mi código es el siguiente:<br />

    </p>
    <p>No se cual sera mi error, espero de su ayuda gracias.
    </p>

  • #57336

    almendron
    Participante

    El código que has puesto no se ha pegado bien. Usa mejor la tilde inversa (la que está a la derecha de la tecla P). Tienes que poner una al principio y otra al final de la línea de código.

    En cualquier caso, el código es

    <?php comments_number( 'No hay comentarios', '1 comentario', '% comentarios' ); ?>

    Lo de meterlo dentro del enlace es solo si el código va en el index. Si lo pones en el single no es necesario.

    Con enlace:

    <a href="<?php comments_link(); ?>"><?php comments_number( 'No hay comentarios', '1 comentario', '% comentarios' ); ?></a>

    Si no te funciona, dinos en qué archivo añades el código y si lo utilizas con enlace o sin él.

  • #57344

    Hola almendron, gracias por tu respuesta y gracias por tu código, lo que yo necesito es eso mismo pero sin que diga el texto “comentarios” es decir que solo aparezca el numero (cantidad) de comentarios.

    He probado con estos dos códigos:

    <a href="<?php">"<?php comments_number('0','1','%'); ?>"></a>
    aparece: texto 0 comentarios.

    <a href="<?php">"<?php comments_number('0','1','%'); ?>"></a>
    no aparece texto pero al final me deja esto: 0″>

    Voy a dejar una imagen para que se entienda mejor mi problema:
    [img]https://lh6.googleusercontent.com/-KQbfR-LMpTU/TsrnixLUs5I/AAAAAAAAAOQ/0LaKxTmPTNs/s300/error-comentarios.jpg[/img]

  • #57350

    almendron
    Participante

    Con enlace:

    <a href="<?php comments_link(); ?>"><?php comments_number( '0', '1', '%' ); ?></a>

    Sin enlace:

    <?php comments_number( '0', '1', '%' ); ?>

    El que te salga 0"> es porque has puesto mal el código.

  • #57374

    almendron gracias por tu respuesta, efectivamente necesito el código con enlace, con lo que me has descrito: <a href="<?php comments_link(); ?>"><?php comments_number( '0', '1', '%' ); ?></a> me sigue saliendo el texto “comentarios” como aparece en la imagen.

    Para dar más detalles estoy ocupando el sistema de comentarios Disqus, y me he fijado que no tengo el archivo comments.php podrá ser que el error este en eso?

  • #57375

    almendron
    Participante

    Lo primero de todo:

    1) ¿en qué archivo está metiendo el código?

    2) El código: ¿estás entre el “while” y el “endwhile”?

    Sigo creyendo que el “0”>” es un error debido a que has puesto mal el código.

    Usa http://tinypaste.com/ y pega allí el código. A ver si vemos cuál es el problema.

  • #57376

    1) ¿en qué archivo está metiendo el código?
    En un archivo category personalizado: category-nombre.php

    2) El código: ¿estás entre el “while” y el “endwhile”?

  • #57377

    almendron
    Participante

    Pues ahora nos queda comprobar que no hayas puesto mal el código. Pega el código del archivo en http://tinypaste.com/ y le echamos un vistazo.

    Archivo comments.ph: aún cuando fuera necesario, no debería afectar para nada al hecho de mostrar el número de comentarios en un archivo de categorías.

  • #57378

    De acuerdo almendron, acá este el link con mi código completo:

    http://tinypaste.com/6ad999a2

  • #57380

    almendron
    Participante

    Pues parece estar bien.

    Haz una cosa: prueba a quitarle el class “icono-commentarios-categorias” de la división.

    <div>
    <a href="<?php comments_link(); ?>"><?php comments_number( '0', '1', '%' ); ?></a>
    </div>

  • #57381

    He sacado la clase al div pero sigue con el texto: [b]comentarios[/b]

  • #57382

    almendron
    Participante

    Pregunta: ¿ya no sale lo de “0”>”?

    Pues cada vez nos quedan menos opciones.

    1.- Prueba a poner <?php comments_number(); ?> y que coja los valores por defecto.

    2.- Cambia de tema y prueba el código.

  • #57383

    Cuando salia el [b]0″>[/b] era con este código:
    <a href="<?php">"<?php comments_number('0','1','%'); ?>"></a>

    1.- Probé solo con <?php comments_number(); ?> y sale el numero con el texto comentarios como siempre.

    2.- Prefiero no arriesgarme a cambiar el tema estando online, pero lo probare en local eso me tomara un poco más de tiempo.

  • #57384

    almendron
    Participante

    ¿El blog está en línea? Inserta el código y pasa la URL donde podamos verlo.

    <div>
    <a href="<?php comments_link(); ?>"><?php comments_number( '0', '1', '%' ); ?></a>
    </div>

  • #57385

    Al parecer el ultimo código que pusiste se ve mal no?
    Te parece si te doy la URL por algún mensaje interno o a tu correo ?

  • #57386

    almendron
    Participante

    No era nada. Una idea tonta.

    Supongo que tendrás tus razones para no hacerlo público… Mandalo a mi correo. Entra en mi página y allí tienes la dirección

  • #57387

    El correo con la URL ya te lo he enviado.

  • #57388

    almendron
    Participante

    Creo que se va a ser el plugin que usas para los comentarios. Prueba a desactivarlo un momento que he puesto un comentario y enseguida veremos si es por eso. Avisa por aquí.

    Y dime qué código tienes puesto ahora.

  • #57389

    plugin disqus desaactivado, ese es el problema, ahora veo correctamente lo que buscaba, muchas gracias por tu tiempo y ayuda !! investigare como solucionar este problema con disqus

  • #57390

    almendron
    Participante

    Ya vero que es el plugin. Una última cosa: si encuentras la solución, pasa por aquí y deja la forma de solventarlo. Le podría venir bien a otros usuarios que usen el mismo plugin.

  • #57391

    Ya esta solucionado tenia que haber configurado bien el plugin, sorry por mi ignorancia.

    [img]https://lh3.googleusercontent.com/-tAv5HmIy0kM/TsvY_GQE6YI/AAAAAAAAAOw/ou0KfzTIcwU/s580/disqus-comments.png[/img]

El foro ‘Programación’ está cerrado y no se permiten nuevos debates ni respuestas.

Pin It on Pinterest

Ir al contenido