No funciona esta parte del código

Inicio Foros WordPress Themes y Diseño No funciona esta parte del código

Este debate contiene 11 respuestas, tiene 3 mensajes y lo actualizó  LGrusin hace 6 años, 8 meses.

  • Autor
    Publicaciones
  • #23324

    javierm5
    Participante

    <p>Saludos, estoy haciendo para que muestre unos posts, pero me da un error de Parse error: syntax error, unexpected T_ECHO, expecting ‘,’ or ‘;'</p>
    <p>¿Podéis encontrar la perte en la questá el error? Gracias.</p>
    <p>


    </p>

  • #57778

    imported_fliberty
    Participante

    Dice:


    Debe decir:

    Te falta lo mismo para el campo $imagen1

  • #57794

    javierm5
    Participante

    Eso, ya lo solucioné, pero el error dice que es por falta de ;, y los problemas de echo. En la línea:

    Gracias

  • #57795

    javierm5
    Participante

    Estoy haciendo caso a otro amigo, y el código sigue sin ir:

    Gracias 🙂

  • #57798

    LGrusin
    Miembro

    Los códigos que estás poniendo no salen bien, utiliza las comillas invertidas.

    Saludos

  • #57799

    javierm5
    Participante

    ¿Comillas invertidas?

  • #57801

    javierm5
    Participante

    ¿Y este código?

  • #57812

    LGrusin
    Miembro

    No hace falta echo para eso.

    Estas son las comillas invertidas ` al lado de la tecla P

    Fijate la diferencia de poner el código con comillas a como lo has puesto:

    Lo que no sé quien es $imagen1, 2, 3, 4, 5…

    Creo que hay un error, en lo que he puesto, no es lo mismo:

    que

    Compruebalo…

    Saludos

  • #57834

    javierm5
    Participante

    Hola, en otra web ya me han ayudado y lo he solucionado. Pongo el código para que a otro no le pase este error:

    Gracias y saludos.

  • #57839

    LGrusin
    Miembro

    Ni caso me hacen, no sé para que respondo…. 😉

    Gracias a ti…
    Un saludo

  • #57911

    imported_fliberty
    Participante

    El error ocurre cuando utilizas código php dentro de un “echo”; por ejemplo si lo utilizas de esta manera: echo ‘<div align=”center”>$funcionphp</php>’; lógicamente arrojará error, pero si eso mismo lo colocas de esta forma: echo ‘<div align=”center”>’ . $funcionphp . ‘</php>’; se ejecutará la función php correctamente y si errores.

  • #57914

    LGrusin
    Miembro

    Insisto, el código no se muestra correctamente en el Foro si no se usan las comillas invertidas.

    fliberty, me temo que no ha salido bien el código que has puesto por esta misma razón.

    Así es complicado ayudar…

    Saludos

El foro ‘Themes y Diseño’ está cerrado y no se permiten nuevos debates ni respuestas.

Pin It on Pinterest