No me funciona la paginación

Inicio Foros WordPress Themes y Diseño No me funciona la paginación

Este debate contiene 5 respuestas, tiene 2 mensajes y lo actualizó  almendron hace 7 años, 7 meses.

  • Autor
    Publicaciones
  • #20964

    fb91
    Participante

    <p>cuando voy a una categoría de un sitio web que estoy haciendo, y me dirijo a la página de una categoría me lista todas las entradas que pertenecen a esa cartegoría y al final aparece el enlace "Ver entradas anteriores". Al darle click me lleva a http://www.misitio.com/categoria/page/2 (hasta ahí todo bien), el problema está en que la url que acabo de escribir me sale un cuadro de búsqueda, como si funcionara la paginación.</p>
    <p>Gracias desde ya
    </p>

  • #51531

    almendron
    Participante

    Pon aquí el código que usas para ver si hay algún error. Y otra cosa: en el enlace que has puesto debería salir el slug de la categoría después de “categoria”.

  • #51532

    fb91
    Participante

    <?php /* Display navigation to next/previous pages when applicable */ ?>
    <?php if ( $wp_query->max_num_pages > 1 ) : ?>
    <div id=”nav-below” class=”navigation”>
    <div class=”nav-previous”><?php next_posts_link( __( ‘<span class=”meta-nav”>←</span> Older posts’, ‘twentyten’ ) ); ?></div>
    <div class=”nav-next”><?php previous_posts_link( __( ‘Newer posts <span class=”meta-nav”>→</span>’, ‘twentyten’ ) ); ?></div>
    </div><!– #nav-below –>
    <?php endif; ?>

    es el original que viene en el TwentyTen… agradezco tu respuesta

  • #51533

    fb91
    Participante

    la categoría se llama fiestas, y al colocar en la url “www.misitio.com/fiestas” me lista todo lo que tiene la categoría fiestas.

    Al poner “www.misitio.com/fiestas/page/2” NO FUNCIONA
    Al pone “www.misitio.com/category/fiestas/page/2” SI FUNCIONA

    El problema es que wordpress me coloca la primer manera que no funciona. El problema está en hacer que me lo muestre de la manera que funciona…

  • #51535

    fb91
    Participante

    en los permalinks tengo la siguiente estructura personalizada : /%category%/%postname%/

  • #51538

    almendron
    Participante

    Si el código es el original del tema, es evidente que ahí no está el problema. Tal vez sea la estructura personalizada ya que no es conveniente poner lo de category.

    Prueba a poner /%post_id%/%postname%/ o solo /%postname%/. En “categoría base” puedes poner [b]categoria[/b], y en “Etiqueta base” pon [b]etiqueta[/b].

El foro ‘Themes y Diseño’ está cerrado y no se permiten nuevos debates ni respuestas.

Pin It on Pinterest