No muestra imagenes al cambiar Theme

Inicio Foros WordPress Themes y Diseño No muestra imagenes al cambiar Theme

Este debate contiene 0 respuestas, tiene 1 mensaje y lo actualizó  microhome hace 5 años, 9 meses.

  • Autor
    Publicaciones
  • #68462

    microhome
    Participante

    Buenas Tardes a todos hace unos días que instalé Wp en mi hosting, y uno con los problemas con los que me encuentro es que no muestra las imagenes que publico, hasta el momento y despues de mucho mirar por el foro he aplicado las siguientes correcciones sobre los ficheros index.php y content.php pero no ha resultado servir de mucho ya que sigo teniendo el mismo problema, aunque hoy me he dado cuenta que si utilizo el tema por defecto que se instala con Wp (Twenty Twelve ó Twenty Ten) las imagenes se muestran sin ningún tipo de problema, pero soy incapaz de averiguar el problema por muchas vueltas que ya le he dado.

    Las modificaciones que he realizado sobre index.php

    – Modificar la función the_content() y en su lugar utilizar the_excerpt()

    Las modificaciones que he realizado sobre content.php

    – Elimanación de la linea <?php the_post_thumbnail(); ?>

    El tema que me da el error se llama Ajaxify y requiere del plugin Options Frameworks

    El contenido del fichero index.php de este tema es el siguiente:

    <?php
    /**
    * The main template file.
    *
    * This is the most generic template file in a WordPress theme
    * and one of the two required files for a theme (the other being style.css).
    * It is used to display a page when nothing more specific matches a query.
    * E.g., it puts together the home page when no home.php file exists.
    * Learn more: http://codex.wordpress.org/Template_Hierarchy
    *
    * @package web2feel
    * @since web2feel 1.0
    */

    get_header(); ?>

    <div id=”primary”>
    <div id=”content” role=”main”>

    <?php if ( have_posts() ) : ?>

    <?php //web2feel_content_nav( ‘nav-above’ ); ?>

    <?php /* Start the Loop */ ?>
    <?php while ( have_posts() ) : the_post(); ?>

    <?php
    /* Include the Post-Format-specific template for the content.
    * If you want to overload this in a child theme then include a file
    * called content-___.php (where ___ is the Post Format name) and that will be used instead.
    */
    get_template_part( ‘content’, get_post_format() );
    ?>

    <?php endwhile; ?>

    <div>
    <?php
    $big = 999999999; // need an unlikely integer

    echo paginate_links( array(
    ‘base’ => str_replace( $big, ‘%#%’, esc_url( get_pagenum_link( $big ) ) ),
    ‘format’ => ‘?paged=%#%’,
    ‘current’ => max( 1, get_query_var(‘paged’) ),
    ‘total’ => $wp_query->max_num_pages
    ) );
    ?>
    </div>

    <?php elseif ( current_user_can( ‘edit_posts’ ) ) : ?>

    <?php get_template_part( ‘no-results’, ‘index’ ); ?>

    <?php endif; ?>

    </div><!– #content .site-content –>
    </div><!– #primary .content-area –>

    <?php get_sidebar(); ?>
    <?php get_footer(); ?>

    El contenido del fichero content.php de este tema es el siguiente:

    <?php
    /**
    * @package web2feel
    * @since web2feel 1.0
    */
    ?>

    <article id=”post-<?php the_ID(); ?>” <?php post_class(‘cf’); ?>>
    <div>
    <div>
    <div><?php the_time(‘j’); ?></div>
    <div><?php the_time(‘F’); ?></div>
    </div>
    <div>
    <?php _e(‘Posted by’, ‘web2feel’) ?> <?php the_author_posts_link(); ?>
    </div>
    <div>
    <?php comments_popup_link(__(‘0 Comments’, ‘web2feel’), __(‘1 Comment’, ‘web2feel’), __(‘% Comments’, ‘web2feel’)); ?>
    </div>
    <div>
    <?php _e(‘Posted in’, ‘web2feel’) ?> <?php the_category(‘, ‘); ?>

    </div>
    </div>
    <div>
    <?php
    $thumb = get_post_thumbnail_id();
    $img_url = wp_get_attachment_url( $thumb,’full’ ); //get full URL to image (use “large” or “medium” if the images too big)
    $image = aq_resize( $img_url, 540, 300, true ); //resize & crop the image
    ?>

    <?php if($image) : ?>
    <a href=”<?php the_permalink(); ?>”><img src=”<?php echo $image ?>”/></a>
    <?php endif; ?>

    <header>
    <h1><a href=”<?php the_permalink(); ?>” title=”<?php echo esc_attr( sprintf( __( ‘Permalink to %s’, ‘web2feel’ ), the_title_attribute( ‘echo=0’ ) ) ); ?>” rel=”bookmark”><?php the_title(); ?></a></h1>
    </header><!– .entry-header –>

    <?php if ( is_search() || is_home() || is_archive() ) : // Only display Excerpts for Search ?>
    <div>
    <?php the_excerpt(); ?>
    </div><!– .entry-summary –>
    <?php else : ?>
    <div>
    <?php the_content( __( ‘Continue reading <span>&rarr;</span>’, ‘web2feel’ ) ); ?>
    <?php wp_link_pages( array( ‘before’ => ‘<div>’ . __( ‘Pages:’, ‘web2feel’ ), ‘after’ => ‘</div>’ ) ); ?>
    </div><!– .entry-content –>
    <?php endif; ?>

    </div>

    </article><!– #post-<?php the_ID(); ?> –>

    Si alguno tuviera un rato y me pudiera echar una mano para encontrar el fallo le estaría muy agradecido, porque ya no se ni por donde seguir metiendole mano al código y es un poco desesperante.

    Saludos!!

El foro ‘Themes y Diseño’ está cerrado y no se permiten nuevos debates ni respuestas.

Pin It on Pinterest

Ir al contenido