No puedo añadir widgets a la barra lateral

Inicio Foros WordPress Themes y Diseño No puedo añadir widgets a la barra lateral

Etiquetado: , , , ,

Este debate contiene 4 respuestas, tiene 4 mensajes y lo actualizó  imported_study hace 8 años, 8 meses.

  • Autor
    Publicaciones
  • #15555

    iesquiroz
    Participante

    <p>Hola a tod@s,<br />
    Recientemente he contratado un hosting al que he subido un WP 2.9 (actualizado a RC1) y un tema que estoy modificando poco a poco. El problema es que, por mucho que lo intente, al agregar widgets a la barra lateral, no me da ningún error pero después no aparecen. Tan sólo veo lo que vienen por defecto configurados en el tema que he instalado.<br />
    ¿Alguien podría indicarme qué debo hacer para poder agregar los widgets desde la consola de administración?</p>
    <p>Saludos y muchas gracias.
    </p>

  • #35703

    bananajota
    Participante

    Me pasó algo parecido una vez, y era porque uno de los plugins que había instalado “congelaba” todo el panel de widgets. Fijate de desactivar todos los plugins que pusiste (no los que vienen por default) y empezar a activarlos de a uno y mientras te vas fijando si es por alguno de ellos.
    Saludos

  • #35735

    iesquiroz
    Participante

    Que va, también lo he probado y no hay forma. Creo que tiene más relación con el desarrollo del “theme” que con los componentes. De hecho, he probado a cambiar el fichero sidebar.php por el que viene con el tema “default” y, a pesar de los consiguientes problemas con el CSS, este sí me ha permitido añadir widgets.
    Gracias de todos modos por tu ayuda.
    Saludos,

  • #35736

    esnine
    Participante

    quizas tiene que ver con el theme.
    el sidebar.php tiene que tener una funcion if(algo) algo
    (no recuerdo ahora como es, si no te contesta nadie te lo miro luego cuando tenga tiempo)
    que hace que se publiquen los widgets ahí.

    Es decir, es probable que te falte eso en tu sidebar del theme

  • #35794

    imported_study
    Participante

    Alo que se refiere esnine es a que en alguna parte del código de tu sidebar deberias tener lo siguiente (o algo similar):

    Para comprobarlo rapido, fijate si con otro theme los widgets te funcionan. Otra cosa, dado que la parte del dashboard que maneja los widgets utiliza ajax, yo me fijaria si el error no esta ahí, intentando configurar los widgets desde otro navegador (opera, firefox, opera, safari, opera u opera, no es que tenga mis preferidos 🙂 )

El foro ‘Themes y Diseño’ está cerrado y no se permiten nuevos debates ni respuestas.

Pin It on Pinterest