No puedo acceder a wp-admin porque cambié algo mal en los ajustes

Inicio Foros WordPress Dominios – Hosting No puedo acceder a wp-admin porque cambié algo mal en los ajustes

Etiquetado: , , ,

Este debate contiene 4 respuestas, tiene 4 mensajes y lo actualizó  LGrusin hace 7 años, 10 meses.

  • Autor
    Publicaciones
  • #20856

    sungjijae
    Participante

    <p>Buenas. Primero de todo quiero aclarar que soy una total inexperta en todo esto, de ahí que "la haya liado".</p>
    <p>Yo tengo un blog en worpress.org y uso 1and1. Mi versión de worpress es la anterior al 3.1, ya que aún no lo había actualizado.</p>
    <p>El caso es que para acceder a mi web la dirección es http://coreaporsiempre.com/blog pero siempre he querido poner solo http://coreaporsiempre.com y estaba trasteando en wordpress y la he liado bien. He cambiado en Ajustes Generales los campos Dirección de WordPress (URL) y Dirección del sitio (URL) donde tenía puesto http://coreaporsiempre.com/blog y puse http://coreaporsiempre.com/. Claro que al darle a guardar cambios (como una tonta ¬¬) me ha dado error 404 (de 1and1). El blog se ve, pero sin formato y no puedo acceder a wp-admin.</p>
    <p>¿alguien puede ayudarme?
    </p>

  • #51064

    almendron
    Participante

    La solución más sencilla es acceder a phpMyAdmin, buscar la tabla wp_options y cambiar allí los valores erróneos por lo correctos.

    En concreto deberás buscar en dicha tabla los campos “siteurl” (editar y poner la dirección correcta) y “home” (editar y dejar en blanco).

    Dado que según comentas eres “inexperta”, te aconsejo que hables con los administradores de tu hosting a ver si ellos pueden ellos hacer el cambio.

    Una vez retomes el control del blog, y si aún quieres realizar los cambios de la URL que comentas, abres un nuevo hilo

  • #51085

    sungjijae
    Participante

    Gracias por responder Almendron. La verdad es que lo que me cuentas me suena a chino xD Ayer me puse en contacto con mi hosting, pero aún no contestaron…

    Esperaré a ver que me dicen, no me atrevo a tocar nada más… Espero que al menos no se me borre el blog. ¡¡Gracias!!

  • #51342

    rodomube
    Participante

    Podrías avisar cómo te fue. Tengo el mismo problema y no he podido solucionarlo.
    Gracias.

  • #51343

    LGrusin
    Miembro

    Quizás lo más fácil sea poner lo siguiente en el archivo functions.php del theme, debe ir al principio. Si no tienes ese archivo créalo.
    <?php
    update_option('siteurl','http://tudominio.com ' );
    update_option('home','http://tudominio.com ' );
    ?>
    Lógicamente cambia tudominio.com por la URL correcta.
    Una vez entres elimina lo anterior del archivo functions.php o en su caso elimina el archivo si no lo tenías antes.
    Un Saludo

El foro ‘Dominios – Hosting’ está cerrado y no se permiten nuevos debates ni respuestas.

Centro de preferencias de privacidad

Cookies imprescindibles

Se usan para saber si ya aceptaste nuestras políticas, si ya estás suscrito a nuestra newsletter, para reconocer el estado de tu sesión si la tuvieses y para servir más rápidos los contenidos.

No se captura IPs ni siquiera para el servicio de Analytics así que tu visita es privada.

JSESSIONID, _cfuid, wpSGCachePypass, mailerlite, gdpr, gawp
mailerlite, _cfuid

Cookies de terceros

Usamos cookies de terceros con servicios, también garantes de tu privacidad, que analizan tus usos de navegación para que podamos mejorar los contenidos, si ya estás suscrito al boletín y los elementos compartidos en redes sociales y el formulario de comentarios.

1P_JAR, APISID, CONSENT, HPSID, NID, SAPISID, SID, SIDCC, SSID, disqus_unique, disqusauth
disqus_unique, disqusauth
1P_JAR, APISID, CONSENT, HPSID, NID, SAPISID, SID, SIDCC, SSID

Pin It on Pinterest

Ir al contenido