No puedo acceder a wp admin

Inicio Foros WordPress Instalación / Actualización No puedo acceder a wp admin

Este debate contiene 4 respuestas, tiene 2 mensajes y lo actualizó  Joe23 hace 5 años, 6 meses.

  • Autor
    Publicaciones
  • #69383

    Joe23
    Participante

    Bueno comentarles que cree mi blog con la ultima version de wordpress en local, con xamp y todo normal todo ok. Sin embargo ahora quize a modo de prueba subirlo a un servidor gratuito en el cual suelo subir otras plataformas y todo normal siempre ha funcionado, y resulta que al intentar acceder al panel de administracion wp-admin me da error 404.

    Intente ya de todo lo que encontre en la red, edite con phpmyadmin la tabla wp options actualizando tanto la url y el home, elimine los plugins, trate de instalar desde cero sin usar la base de datos de localhost, cambie todos los permisos de las carpetas y los archivos que contienen a 755, cambie de temas a los que trae por defecto, lo unico que logre es que los enlaces de las entradas ya no me manden a localhost  modificando el archivo htacces que dicho sea de paso me parece que ahi podria estar la solucion, pero encuentro de todo de como proteger el wp-admin y no de como acceder mas bien al wp admin usando el htacces.

    Si alguien pudiera guiarme se lo agradecere bastante, si desean ver el sitio les dejo el enlace

    http://pampacolca.herobo.com

    y no puedo acceder a   http://pampacolca.herobo.com/wp-admin

    Agradezco su atencion

     

     

     

     

  • #69385

    LGrusin
    Miembro

    No dices los pasos que has dado para importar el blog en el servidor. Tocar la base de datos no ha sido una buena idea.

    Elimina el .htaccess, cuando entres lo podrás volver a crear de nuevo.

    Quizás te interese leer este comentario de otro hilo sobre lo mismo:
    https://ayudawp.com/foros/hilo/problemas-para-acceder-al-admin/#post-69227

    Un saludo

  • #69393

    Joe23
    Participante

    Estimados, hice lo que indica el enlace y no funcionó, sin embargo agradezco por darme una alternativa de solución les detallo lo que hice:

    Borre todos los datos de mi base de datos en el servidor remoto
    en el servidor local instale el puglin que hacen referencia y lo configure a mis datos del servidor, donde solo quiero que me indiquen si hice bien sobre lo que coloque
    Current address (URL): http://localhost/pampacolca

    New address (URL): http://pampacolca.herobo.com

    current file path : C:\xampp\htdocs\pampacolca

    New file path: /usr/local/apache/htdocs/public_html

    Para averiguar la ruta del “New file path” hice un archivo ruta.php con el siguiente texto

    ?php

    echo $_SERVER[‘DOCUMENT_ROOT’];
    ?>

    este archivo lo subi a la raiz del servidor remoto y me salio la siguiente direccion

    /usr/local/apache/htdocs

    yo le agregue “public_html” porque es la carpeta que visualizo en mi servicio de ftp y dentro de la cual meti todos mis archivos del wordpress

    Finalmente genere con dicho plugin la base de datos a exportar y la importe desde la base de datos del servidor remoto

    Luego abri mi pagina http://pampacolca.herobo.com y voila, hay una mejora que ya recupere el enlace a todas mis imagenes, sin embargo al intentar abrir http://pampacolca.herobo.com/wp-admin nuevamente me da error 404.

    Elimine el htacces y trate de entrar y solo carga la pagina principal, mas no los enlaces que tambien da error, me imagino que en todo esto el htacces tiene algo que ver que impide que abra mi wp-admin. actualmente en el htacces tengo el siguiente texto

    # BEGIN WordPress

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    Les agradeceré me ayuden a identificar que podría estar mal o si hay algo que agregar al htacces…?, ya me cerciore que el wp-config esta bien configurado. gracias por su atención y espero su ayuda. salu2

  • #69395

    LGrusin
    Miembro

    En principio parece que lo has hecho correctamente, pero el archivo .htaccess lo tiene que generar WordPress, no vale añadirlo manualmente, y para eso necesitas entrar en el escritorio.

    Creo que deberías hacer las pruebas sin .htaccess no importa que te de errores en los enlaces. Intenta partir de cero, sin .htacces y sin plugins, hasta que averigues lo que pasa. El tener un servidor gratuito hace desconfiar de si es 100% operativo.

    Un saludo

  • #69400

    Joe23
    Participante

    Saludos a todos, les cuento al detalle lo que paso

    Yo estaba tratando de acceder al wp-admin desde dos laptops (personal y la de mi novia) y como ya les comente nada de nada, use todas las maneras posibles, siendo la ultima la del plugin que me recomendaron aqui. Ayer en mi laptop personal aplique el plugin y nada de nada.

    Hoy temprano hice algo ilogico, pero tenia que intentarlo todo, y en el servidor local de la pc de mi novia genere una base de datos pero desde el phpmyadmin local, luego en el servidor local de mi pc borre la base de datos actual e importe la base que habia creado previamente en la pc de mi novia (usando tambien el phpmyadmin de mi pc) y luego entre en el escritorio del wordpress local de mi pc, active el plugin y genere la base de datos de exportación nuevamente, la que luego aplique en el servidor remoto y voila, navegue primero por todos los enlaces y lo mas importante logre ingresar al wp-admin como por arte de magia, y la verdad no entiendo que pudo pasar.

    Revise el htacces, seguia siendo el mismo que coloque en el anterior mensaje, es como si el servidor remoto no le gustaba que genere la base de datos desde mi PC  con mi databse pero si con la db de la PC de mi novia, no tenia sentido  ya que en ambas tengo el mismo servidor XAMP, quiza el unico detalle distinto es que en la PC de mi novia la configuracion de enlaces permanentes  estaba en predeterminado, mientras que en mi PC le puse el nombre de entrada.

    Bueno disculpen si todo esto es enredoso, lo concreto quiero agradecer por su ayuda, y si todo este enredo puede servir alguien tambien a solucionar algun problema parecido, de todas maneras me gustaria que me pudieran dar algunas pautas de lo que pudo haber sucedido, ya que apesar que estoy tranquilo de poder accesar al wp-admin, la verdad de intentar colgar otro sitio no se a ciencia cierta que hacer para tener exito en el primer intento.  Saludos

     

El foro ‘Instalación / Actualización’ está cerrado y no se permiten nuevos debates ni respuestas.

Pin It on Pinterest