No se ve el contenido de mis entradas

Inicio Foros WordPress General WordPress.org No se ve el contenido de mis entradas

Este debate contiene 5 respuestas, tiene 3 mensajes y lo actualizó  vektor hace 7 años, 9 meses.

  • Autor
    Publicaciones
  • #19731

    prensaas
    Participante

    <p>Gente. ¿Cómo les va? En principio, voy a agradecer infinitamente por el tiempo que alguien pueda dedicar a ayudarme con un problema que tengo.<br />
    Abrí un blog hace poco (www.elestablosanvicente.com.ar/blog/) usando una plantilla gratuita que diseñó WpClassic de nombre Cozy Colin, que pueden encontrar acá (wpclassic.com/cozy-colin/).<br />
    El template es bastante bueno, y me permitió hacer todos los cambios que necesitaba. El único problema que tengo es que cuando creo una entrada nueva, le agregó contenido. Hasta ahí todo ok, pero cuando quiero visualizar la entrada en mi blog sólo veo un espacio en blanco. Por alguna razón que desconozco, ni texto ni imagen ni nada aparece cuando se visualiza el post. Ejemplo, acá: http://elestablosanvicente.com.ar/blog/?p=26<br />
    ¿A qué se puede deber? Estuve viendo la programación de las entradas individuales (single.php) pero todo parece estar bien. Probé borrar el contenido de la sidebar, por si ese era el origen del problema, pero tampoco funcionó.<br />
    Aclaro que no soy un usuario avanzado de WordPress ni sé mucho de programación. Sólo lo mínimo como para crear un blog, modificar alguna que otra plantilla y demás. Busqué en google ayuda o alguien al que le hubiera pasado algo similar, pero no encontré nada.<br />
    Me encantaría ayudar a otros para alimentar esta comunidad. Si bien mis conocimientos son regulares, veré si por allí puedo aportar en algo.<br />
    Nuevamente, gracias al que me pueda ayudar. Un abrazo!
    </p>

  • #48209

    imported_josec
    Participante

    si puedieras colocar el codigo de single.php.. creo que ahi radica el problema

  • #48210

    prensaas
    Participante

    Por supuesto, maestro. Muchas gracias!
    Ahí va:

  • #48271

    imported_josec
    Participante

    me doy cuenta que tu codigo no tiene el loop.. el cual quedaría algo así:

    [quote]< div id=”post-< ?php the_ID(); ? >” < ?php post_class(); ? > >

    < h1 class=”entry-title” >< ?php the_title(); ? >< /h1 >

    < div class=”entry-meta” >
    < ?php the_time(‘F j, Y ‘); ? > < ?php the_category(‘ , ‘);? >
    < /div >< !– .entry-meta — >

    < div class=”entry-content” >

    < div class=”social-media” >
    < div id=”twit” >
    Tweet< script type=”text/javascript” src=”http://platform.twitter.com/widgets.js” >< /script >
    < /div >
    < div id=”fb” >
    &t=< ?php the_title(); ? >” share_url=”< ?php the_permalink() ? >” >Share
    < script src=”http://static.ak.fbcdn.net/connect.php/js/FB.Share” type=”text/javascript” >< /script >
    < /div >

    < /div >

    < ?php the_content(); ? >

    < /div >< !– .entry-content — >
    < ?php if ( get_the_author_meta( ‘description’ ) ) : // If a user has filled out their description, show a bio on their entries ? >
    < div id=”entry-author-info” >
    < div id=”author-avatar” >
    < ?php echo get_avatar( get_the_author_meta( ‘user_email’ ), apply_filters( ‘twentyten_author_bio_avatar_size’, 60 ) ); ? >
    < /div >< !– #author-avatar — >
    < div id=”author-description” >
    < h2 >< ?php printf( esc_attr__( ‘About %s’, ‘twentyten’ ), get_the_author() ); ? >< /h2 >
    < ?php the_author_meta( ‘description’ ); ? >
    < div id=”author-link” >
    ” >
    < ?php printf( __( ‘View all posts by %s < span class=”meta-nav” >→< /span >’, ‘twentyten’ ), get_the_author() ); ? >

    < /div >< !– #author-link — >
    < /div >< !– #author-description — >
    < /div >< !– #entry-author-info — >
    < ?php endif; ? >

    < div id=”sharer” >
    < h3 id=”sharer-title” >Share This Post< /h3 >
    < ?php social_bookmark_share(urlencode(get_permalink()),urlencode(get_the_title()),urlencode(get_the_excerpt()));? >

    < /div >

    < ?php comments_template( ”, true ); ? >

    < /div >< !– #post — >[/quote]

    saludos

  • #48314

    prensaas
    Participante

    Excelente, José. Muchísimas gracias por tu ayuda desinteresada.
    Efectivamente, no me había percatado de la ausencia del loop. Ubiqué el código en el php de las entradas individuales (single.php) tal como lo indicaste, y el contenido de los post’s se visualizan a la perfección.
    Nuevamente gracias, y ojalá le sirva a alguien que esté con mi mismo problema (ya resuelto).
    Un saludo!

  • #49631

    vektor
    Participante

    Hola como les va? Quisiera que me ayudaran tambien tengo un problema con mis post todo lo que publico no lo puedo ver a menos que sea en vista previa… Mi pagina se basa en jpg y en gif por lo tanto sin entran no veran nada porque como no se ven los post pues no se ven las imagenes :s si pudieran porfavor ayudarme. Gracias de antemano
    Por si lo nesecitas aqui esta mi single.php (si tiene el loop):

    [quote]<?php get_header(); ?>
    <?php if (have_posts()) : while (have_posts()) : the_post(); ?>
    <h6 class=”underlined”><?php the_title(); ?></h6>
    <div <?php if(function_exists(‘post_class’)) : ?><?php post_class(); ?><?php else : ?>class=”post post-<?php the_ID(); ?>”<?php endif; ?>>
    <div class=”content clearfix”>
    <?php
    $values = get_post_custom_values(“multimedia”);
    if (isset($values[0])) {
    ?>
    <div class=”multimedia clearfix”>
    <?php $values = get_post_custom_values(“multimedia”); echo $values[0]; ?>
    </div>
    <?php } ?>

    <?php the_content(); ?>
    <?php wp_link_pages( array( ‘before’ => ‘<div class=”page-link”>’ . __( ‘Pages:’ ), ‘after’ => ‘</div>’ ) ); ?>
    </div>
    </div>

    <p class=”postmetadata”><?php the_time( get_option( ‘date_format’ ) ); ?> | Filed under <?php the_category(‘, ‘) ?><?php if (get_the_tags()) the_tags(‘ and tagged with ‘); ?>. <?php edit_post_link(‘Edit’, ‘| ‘, ”); ?> </p>
    <p class=”postmetadata”><?php the_tags(); ?></p>

    <div class=”nav prev left”><?php next_post_link(‘%link’, ‘←’, TRUE); ?></div>
    <div class=”nav next right”><?php previous_post_link(‘%link’, ‘→’, TRUE); ?></div>
    <div class=”clear”></div>

    <?php endwhile; else : ?>

    <h2 class=”center”>Not Found</h2>
    <p class=”center”>Sorry, but you are looking for something that isn’t here.</p>
    <?php get_search_form(); ?>

    <?php endif; ?>
    <?php comments_template(); ?>
    <?php get_template_part( ‘bottom’ ); ?>
    <?php get_footer(); ?>[/quote]

    Tambien tengo una duda puedo colocar imagenes gif en la cabecera de mi pagina? Es que monto el gif pero se queda estatico :s

El foro ‘General WordPress.org’ está cerrado y no se permiten nuevos debates ni respuestas.

Pin It on Pinterest