Página en blanco al intentar actualizar

Inicio Foros WordPress Instalación / Actualización Página en blanco al intentar actualizar

Este debate contiene 12 respuestas, tiene 4 mensajes y lo actualizó  Camelot hace 8 años, 10 meses.

  • Autor
    Publicaciones
  • #13349

    Camelot
    Participante

    <p>Hola,<br />
    Con la novedad de wordpress 2.8 he intentado actualizar mi sitio. Al intentar actualizar automáticamente (tenía wp2.7.1) me salía un mensaje de que no podía encontrar la carpeta de instalación y me mandaba un mensaje de instalación fallida. </p>
    <p>Intenté entonces con el modelo manual, borrando la instalación anterior y subiendo las carpetas y archivos correspondientes (o sea no borré la carpeta de contenidos ni los archivos index.php ni wp-config.php), la cuestión es que hecho todo esto al intentar ingresar a http//miblog.com/wp-admin/upgrade.php después de intentar cargar la página se queda en blanco y más nada.</p>
    <p>Como mi hosting tiene instalado wordpress en la carpeta htdocs intenté agregar esto en la ruta pero me manda a una página con el erro 404. </p>
    <p>No tengo idea que pueda estar saliendo mal, excepto que hace algunas semanas hice un pequeño agregado al archivo wp-config.php para que no guarde tantas copias de respaldo cada vez que edito mis entradas. Por lo demás todo está igual y seguí todos los pasos de los tutoriales que han puesto.</p>
    <p>Espero que puedan ayudarme.
    </p>

  • #29611

    imported_Fernando
    Participante

    index.php si que hay que sobrescribirlo. Prueba de nuevo. Sube todo menos wp-content

  • #29613

    metacortex
    Participante

    ¿Desactivaste los plugins antes de actualizar?

  • #29626

    Camelot
    Participante

    No sólo desactivé todos los plugins sino que incluso puse el tema por defecto de WordPress. Tengo también un backup de mi base de datos y de mis entradas, comentarios, etc.

    Fernando, ya subí y reemplacé el index.php y sigue apareciendo la página en blanco… incluso he probado con otros navegadores (yo uso Firefox) pero igual, sólo me queda suponer que tuve mala suerte ¿?

    Por cierto, aunque subí y reemplacé todos los archivos por los de wordpress 2.8 mi sitio sigue funcionando, pero como dije, está irreconocible porque está con el tema por defecto y sin plugins jejejeje.

    Que el sitio siga funcionando a pesar de haber reemplazado todos los archivos ¿qué quiere decir? Capaz sí se actualizó sólo que yo no puedo loguearme, porque cuando lo intento sale este mensaje:

    [code]http://yggdrasilfansub.22web.net/wp-admin/upgrade.php?_wp_http_referer=%2Fwp-admin%2F[/code]

    Esperando respuestas….

  • #29645

    David Cortes
    Participante

    Tal vez sería bueno que lo volvieras a instalar, puede funcionar.

    Saludos

  • #29666

    Camelot
    Participante

    Bueno, lo he intentado y no he podido, hay que reconocer nuestras limitaciones. He vuelto a subir los archivos de la versión anterior (2.7.1) y más nada tuve que hacer para volver a loguearme sin problemas en mi sitio.

    Creo que esperaré que mi hosting (ZobyHost) actualice su instalador Fantástico a WordPress 2.8 para intentar una instalación en limpio que ya vi que la actualización esta media complicada. He dejado una consulta en el sitio de soporte por si acaso, a ver que me responden.

    Saludos.

  • #29676

    imported_Fernando
    Participante

    ¿Que versión de php y mysql tiene tu servidor?

  • #29727

    Camelot
    Participante

    Anotado de mi cuenta:

    Server Information

    * VistaPanel Version 2.4.0 RC1
    * Operating system Linux
    * Apache version 2.2.11 (Unix)
    * PHP version 5.2.9
    * MySQL version 5.0.81

    Según me respondieron en foro de mi hosting tomarán su tiempo implementar 2.8 en el instalador fantástico y que primero van a realizar varias pruebas para comprobar que funcione correctamente. Supongo que es lo más prudente tratándose de una versión reciente. En fin, me lo tomaré con calma aunque siempre he actualizado las versiones rápidamente y hasta ahora nunca habia tenido problemas.

    Lo curioso es que la actualización automática no funciona y me dice que NO encuentra la carpeta de instalación. Por cierto, en un blog (Genbeta) un usuario hizo el comentario de que existe un bug en wp28 que borra aleatoriamente carpetas de instalación, no indica ni hosting ni nada más. Podría ser un alarmista pero de todas formas me sonó inquietante.

    Saludos.

  • #29735

    imported_Fernando
    Participante

    WP 2.8 no borra nada, solo puede reescribir ficheros que hayas modificado, como cualquier instalación 😉

    Pues los requisitos son los habituales. Yo en tu caso probaría a hacer una instalación "al uso" por FTP y comprobar que todo está bien y marcha, tras desactivar los plugins (renombra la carpeta plugins).

  • #29850

    Camelot
    Participante

    Perdón, a qué le llamas instalación "al uso", o sea, en qué se diferencia de la que yo he hecho hasta ahora.

    Estoy confundido, y más cuando sacaste el tema donde advertía no actualizar, como comenté antes, he vuelto a WP 2.7.1 pero ahora tengo el problema de los que sí actualizaron: Editor de textos en HTML, el Visual aparece pero no se ve ninguno de sus botones/opciones.

    ¡Qué enredo con este WP 2.8! y ¡Bienaventurados lo que actualizaron perfectamente!

    Saludos.

  • #29857

    imported_Fernando
    Participante

    Pues me refiero a cargar por ftp todo menos wp-content.

  • #29946

    Camelot
    Participante

    Pues si se trata sólo de eso es lo que hice con Filezilla… incluso rehice el archivo wp-config.php añadiendo manualmente todos mis datos… pero el problema es cuando intento hacer el upgrade.

    Lamentablemente creo que me esperaré a la versión 2.8.1 porque estoy teniendo problemas, ahora con el editor en visual que se malogró y sólo puedo hacerlo por HTML. Además, hay gente reportando que no puede subir imágenes… tengo temor a que al próximo intento se me fastidie algo más. En fin, ojalá no demoren en reparar todos estos inconvenientes en la próxima actualización.

  • #35489

    Camelot
    Participante

    El soporte técnico de ZobyHost me recomendaron añadir algunas lineas en el archivo wp-config.php y he podido actualizar automáticamente a la versión 2.9.

    No sé si el truco fundiona para otros sitios por eso no pongo el código. En todo caso hice otro cambio con relación a las instalaciones fallidas anteriormente. Como durante la actualización manual dejaba intacta la carpeta wp-content no me había fijado que mantenía la carpeta de languages, no sé si tenga algo que ver pero pasando wordpress al ingles y actualizando desde allí he podido lograrlo. No sé si tendra algo que ver o si todo el mérito corresponde a las líneas que me recomendaron añadir en el soporte técnico de mi hosting. Lo cierto es que en el futuro cuando tenga que actualizar volveré a poner mi instalación en inglés, por las dudas. 😀

El foro ‘Instalación / Actualización’ está cerrado y no se permiten nuevos debates ni respuestas.

Pin It on Pinterest