Paginacion

Inicio Foros WordPress Plugins Paginacion

Este debate contiene 4 respuestas, tiene 2 mensajes y lo actualizó  mariogalacho hace 8 años.

  • Autor
    Publicaciones
  • #19075

    mariogalacho
    Participante

    <p>He instalado un Theme – TheProfessional. Pero la vinculación "páginas anteriores" no funcionan.<br />
    He instalado el Plugin WP-PageNavi, veo la botonera al final de la página, pero al darle a la "2" sale lo mismo:</p>
    <p>

    Quote:
    No Results Found<br />
    The page you requested could not be found. Try refining your search, or use the navigation above to locate the post.

    </p>
    <p>El caso es que no puedo ver el resto de artículos. Ahora veo 3, si selecciono 5 por página se ven 5, pero los que faltan no.</p>
    <p>Gracias por vuestra ayuda.
    </p>

  • #46457

    mariogalacho
    Participante

    Tengo que aclarar que deseo la paginación, solo en CATEGORIAS y no en la página principal

  • #46460

    imported_medievalia
    Participante

    En este caso depende de tu themes, ponlo en la pagina Archive de tu themes, o si tienes Category.

    Si al darle a los numeros y no te salta la pagina, seguro que has retocado mal y sin querer el codigo.

    Me paso una vez que volver a subir el themes y sobre escribir

  • #46470

    mariogalacho
    Participante

    En este caso el THEME no tiene nada que ver.
    Lo he eliminado y cargado otro y nada.
    He puesto un THEME que gestiona todas las entradas, ahí SI funciona y si le doy a las páginas siguientes las muestra correctamente.
    Dentro de este mismo THEME (el que funciona gestionando entradas), voy a la categoría y muestra la primera página e incluso he metido mas entradas en esa categoría y muestra que hay más páginas para mostrar, ósea se incrementa, pero ninguna de las páginas restantes me deja mostrarlas. Es en una de las CATEGORIAS donde falla.

  • #46527

    mariogalacho
    Participante

    NO HAY MANERA HEEELP !!!

    Me desdigo, he probado otro THEME y funciona.
    El problema es que lo probé con otro THEME que también fallaba (casualidad).

    Retomando el consejo de “Medievalia” he vuelto a subir el Theme (el Puglin PageNavi quedó instalado), he sobreescrito la plantilla, posteriormente he verificado que aparece la linea ..

    [i]<?php if(function_exists(’wp_pagenavi’)) { wp_pagenavi(); } ?>[/i]

    .. como recomienda el Plugin, el caso es que la plantilla ya utiliza dicha linea dentro del código de index.php, PERO NADA, TODO SIGUE IGUAL.
    __________________________________________________________________________________________

    <?php if (is_archive()) $post_number = get_option(‘professional_archivenum_posts’);
    if (is_search()) $post_number = get_option(‘professional_searchnum_posts’);
    if (is_tag()) $post_number = get_option(‘professional_tagnum_posts’);
    if (is_category()) $post_number = get_option(‘professional_catnum_posts’); ?>
    <?php get_header(); ?>

    <div id=”content-top” class=”top-alt”></div>
    <div id=”content” class=”clearfix content-alt”>
    <div id=”content-area”>
    <?php include(TEMPLATEPATH . ‘/includes/breadcrumbs.php’); ?>

    <?php global $query_string;
    if (is_category()) query_posts($query_string . “&showposts=$post_number&paged=$paged&cat=$cat”);
    else query_posts($query_string . “&showposts=$post_number&paged=$paged”); ?>

    <?php if (have_posts()) : while (have_posts()) : the_post(); ?>

    <?php include(TEMPLATEPATH . ‘/includes/entry.php’); ?>

    <?php endwhile; ?>
    <div class=”hr-separator”></div>
    <div class=”entry page-nav clearfix”>
    <?php if(function_exists(‘wp_pagenavi’)) { wp_pagenavi(); }
    else { ?>
    <?php include(TEMPLATEPATH . ‘/includes/navigation.php’); ?>
    <?php } ?>
    </div> <!– end .entry –>

    <?php else : ?>
    <?php include(TEMPLATEPATH . ‘/includes/no-results.php’); ?>
    <?php endif; wp_reset_query(); ?>
    </div> <!– end #content-area –>

    <?php get_sidebar(); ?>

    </div> <!– end #content –>
    <div id=”content-bottom” class=”bottom-alt”></div>

    <?php get_footer(); ?>
    ______________________________________________________________________________

    A ver si algún lumbrera se luce 😉

El foro ‘Plugins’ está cerrado y no se permiten nuevos debates ni respuestas.

Pin It on Pinterest