Parse error: syntax error, unexpected T_ENDIF

Inicio Foros WordPress Instalación / Actualización Parse error: syntax error, unexpected T_ENDIF

Este debate contiene 12 respuestas, tiene 2 mensajes y lo actualizó  jetrel hace 7 años, 4 meses.

  • Autor
    Publicaciones
  • #20894

    jetrel
    Participante

    <p>cuando subo los archivos al servidor e intento abrir: http://tudominio.com/wp-admin/install.php<br />
    me da el siguiente mensaje:<br />
    Parse error: syntax error, unexpected T_ENDIF in C:Inetpubvhostsgrupodariza.comsubdomainsbloghttpdocswp-includesfunctions.php on line 2782<br />
    alguien sabe porque?<br />
    gracias
    </p>

  • #51250

    LGrusin
    Miembro

    El error debe originarlo algún archivo mal. Descarga la última versión de [url=http://wordpress.org/][b]WordPress[/b][/url] la 3.1.1, y vuelve a subirla. Preferiblemente en inglés porque es nueva y no sé si les habrá dado tiempo a traducida. Ya la pondrás en español cuando esté todo funcionando.

    Mejor elimina todo y vuelve a subir la última versión descargada. Si quieres conserva el archivo wp-config.php que es el que te permite acceder a la base de datos. Aunque como es nuevo el blog te da igual sobreescribirlo.

    El servidor no ha estado funcionando durante el fin de semana. No se deben hacer pruebas cuando están trabajando en él. No sé si te has dado cuenta de este detalle.

    Un saludo

  • #51268

    jetrel
    Participante

    hola LGrusin, lo del hilo anterior quizás tengas razón tu que tienes más experiencia y conocimientos que yo, pero yo ya estaba empezando a desesperarme y no lo veía tan fácil, en fín, volviendo a este tema, he vuelto hacer por segunda vez (ya que la primera vez que lo hice todo de nuevo fue ayer), lo he eliminado todo, me he vuelto a descargar wordpress, he vuelto a configurar el subdominio, la base de datos y el wp-config.php y me vuelve a dar el error:

    Parse error: syntax error, unexpected T_ENDIF in C:Inetpubvhostsgrupodariza.comsubdomainsbloghttpdocswp-includesfunctions.php on line 2734

    la dirección que escribo en el navegador es:

    http://blog.grupodariza.com/wp-admin/install.php

    por si ves algún error en la dirección.

    En cuanto a lo del servidor no sabía nada, he notado cosas raras pero creía que era mi conexión, como sabes cuando el servidor está y cuando no está funcionando?

    gracias
    un saludo

  • #51269

    LGrusin
    Miembro

    … me he vuelto a descargar wordpress, he vuelto a configurar el subdominio, la base de datos y el wp-config.php y me vuelve a dar el error…

    Yo lo haría de otra forma:
    1 – Descarga la versión en inglés la última la 3.1.1.
    2 – Entra en la carpeta subdomainsbloghttpdocs y elimina todo eso.
    3 – Sube la última versión descargada a la carpeta anterior.

    Para instalar WordPress tecleas blog.grupodariza.com y sigue los pasos.

    Olvida el subdominio, no sé por qué tocas el subdominio. La base de datos es la misma tampoco tienes que tocarla. Igual algo que haces y desconozco no es correcto.

    Si quieres ANTES DE HACER NADA. Crea un archivo php y súbelo para hacer una prueba. Ponle por ejemplo prueba.php El contenido de ese archivo es:

    Ahora teclea “http://blog.grupodariza.com/prueba.php”

    Si se ve la frase [b]Hola mundo[/b] significa que PHP funciona en tu servidor.
    Si sale [b]/* Si se ve este texto PHP no funciona */[/b] significa que PHP no va bien en tu server y sabrás que no es algo que estés haciendo mal. En ese caso le reclamas a ellos.

    Saludos

  • #51270

    jetrel
    Participante

    ok, ya he subido prueba.php y funciona, voy a hacer de nuevo lo que me comentas paso a paso

  • #51278

    jetrel
    Participante

    bueno he eliminado todo el contenido de httpdocs y lo he vuelto a subir de nuevo y si pongo en el navegador http://blog.grupodariza.com/wp-admin/install.php me sale un montón de carecteres parecido al código de algún archivo y si pongo http://blog.grupodariza.com se me va directamente a http://blog.grupodariza.com/Index.php/wp-admin/install.php y me dice
    Not Found
    The requested document was not found on this server.
    Web Server at grupodariza.com

    para desesperarse!!

  • #51283

    LGrusin
    Miembro

    Sigues insistiendo en subir la versión 3.1 en español. Lo siento pero no me fio ni un pelo de esa versión que estás intentando instalar ni tampoco sé si esos archivos están bien. Así es complicado ayudarte.

    Responde a estas preguntas:
    1 – ¿Cómo subes los archivos?
    2 – ¿Usas un programa FTP? ¿Exactamente qué programa FTP usas?
    3 – ¿Está totalmente vacia la carpeta cuando subes los archivos?
    4 – ¿Tienes control total sobre esa carpeta y puedes ver todos los archivos incluídos los ocultos?
    5 – ¿Tiene esa carpeta los sufientes permisos para crear y modificar archivos?
    6 – ¿Desde dónde descargaste esa versión de WordPress?
    7 – ¿Es una copia original o está modificada?
    8 – ¿Cómo lo instalaste la otra vez?
    9 – ¿El servidor lo administras tú?
    10 – En caso contrario, ¿Has preguntado a tu servidor si necesitas alguna configuración especial en los subdominios para instalar WordPress?

    La única forma de saber si esos archivos están dañados es probar con otra versión y la mejor es la última y original en inglés.

    No hace falta ir a /wp-admin/install.php desde que tecleas “http://blog.grupodariza.com” sale la página de configuración de WordPress diciendo que falta el archivo wp-config.php y que se va a crear uno con los datos que pongas.

    ¿Te atreverías a crear una carpeta en el raiz y probar instalar WordPress en ella?

    Ejemplo, creas una carpeta llamada probando y subes los archivos de WordPress en ella. Después accedes tecleando en el navegador “http://grupodariza.com/probando”

    Ya sé que es mucho trabajo pero es la única forma de saber por donde van los tiros.

    Un saludo

  • #51291

    jetrel
    Participante

    Sigues insistiendo en subir la versión 3.1 en español.

    tienes razón, ese detalle es quizás el único que había pasado por alto, como la primera vez me funcionó no le di importancia a bajarme otro diferente.

    1 – ¿Cómo subes los archivos?
    2 – ¿Usas un programa FTP? ¿Exactamente qué programa FTP usas?

    fireftp

    3 – ¿Está totalmente vacia la carpeta cuando subes los archivos?
    4 – ¿Tienes control total sobre esa carpeta y puedes ver todos los archivos incluídos los ocultos?
    5 – ¿Tiene esa carpeta los sufientes permisos para crear y modificar archivos?

    la carpeta está vacía y tiene todos los permisos posibles

    si era una copia sin modificar, bajada desde la página oficial, en fin, ahora me acabo de descargar desde la pagina oficial la version 3.1.1 sin traducir al español y la estoy suviendo al servidor haber que tal

  • #51293

    jetrel
    Participante

    lo acabo de subir todo al subdominio y me vuelve a dar otro error:

    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator to inform of the time the error occurred and of anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Web Server at grupodariza.com

    voy a probar a crear una carpeta en el raiz como dices y a subir wordpress ahí

  • #51294

    jetrel
    Participante

    bueno, lo he creado en el raiz, en una carpeta llamada wordpress y me da exactamente el mismo error

  • #51308

    jetrel
    Participante

    después de muchos experimentos y mucho investigar he conseguido que funcione y al parecer este último problema era del servidor, nose lo que han echo pero 5 minutos ha desaparecido el error y he podido instalar wordpress y ya está funcionando, antes de tocar nada pregunto: debo de tener algo en cuenta para que no me vuelva a pasar lo del principio? es decir, que cuando pulse en “entradas antiguas” me de error, o que cada vez que haga un clic empiecen a acumularse los index.php?
    gracias
    un saludo

  • #51309

    LGrusin
    Miembro

    Yo lo que tengo claro que siempre fue problema del servidor.

    Como no te han dicho lo que es pues te quedas igual.

    También está claro que los errores que te ha dado son diferentes.

    Ahora funciona perfectamente y no tiene problema de index.php. Ahora está perfecto.

    Un saludo

  • #51335

    jetrel
    Participante

    gracias LGrusin por tu tiempo y tu paciencia.

    un saludo

El foro ‘Instalación / Actualización’ está cerrado y no se permiten nuevos debates ni respuestas.

Pin It on Pinterest