Pasar de PHP4 a PHP5 , ¿Riesgos?

Inicio Foros WordPress Programación Pasar de PHP4 a PHP5 , ¿Riesgos?

Este debate contiene 2 respuestas, tiene 3 mensajes y lo actualizó  Hombre Man hace 6 años, 6 meses.

  • Autor
    Publicaciones
  • #61113

    RobVLC
    Participante

    Hola,

    llevo idea de actualizar los temas de mi blog para soporte de HTML5,

    casi todos me dan un error:

    syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or ‘}’

    Buscando por google he dado con que tiene que ver con la versión de PHP que tengo. Si mi blog está en php4, y mediante el .htaccess añado la línea

    CÓDIGO: SELECCIONAR TODO
    SetEnv PHP_VER 5

    para pasar a PHP5.2 para poder instalar los nuevos temas, ¿Corre peligro el resto de información? o sólo por cambiar esto no pasa nada?

    Gracias y un saludo

  • #61114

    LGrusin
    Miembro

    Cuando dices HTML5 imagino que quieres decir PHP5

    ¿Qué versión de WordPress tenías instalada? Ha pasado mucho desde PHP4, han habido algunos cambios en el código. Un theme para PHP4 es posible que haya que modificarlo para PHP5. Las funciones de WordPress también han cambiado con PHP5.

    Quién tiene que cambiar la versión de PHP es tu servidor. Consultales…

    Un saludo

  • #61122

    Hombre Man
    Participante

    El error que mencionas es un error de sintaxis…

    Pero en fin. Tu proveedor de hosting debe instalar primero en el servidor el programa en la versión que necesitas.

    Más aún, en los servidores de muchos proveedores de hosting, coexisten ambas versiones y la empresa te proporciona los medios para cambiar de versión, que en muchos casos se hace con directivas de mime/type… pero supongo que con setenv también es posible.

    Por otro lado, las buenas prácticas de programación recomiendan que te cambies a la versión más reciente, y una de las principales razones es la seguridad. Pero poco a poco verás que los sistemas abandonan poco a poco PHP4, y tu código corre el riesgo de obsolescencia.
    Entonces los riesgos son esos dos: falta de seguridad y obsolescencia. Y ambos riesgos podrían aparecer si no cambias a PHP5.

El foro ‘Programación’ está cerrado y no se permiten nuevos debates ni respuestas.

Pin It on Pinterest