PERDIDA DE FOTOGRAFIAS

Inicio Foros Comunidad Presenta tu Blog PERDIDA DE FOTOGRAFIAS

Este debate contiene 5 respuestas, tiene 3 mensajes y lo actualizó  almendron hace 7 años, 7 meses.

  • Autor
    Publicaciones
  • #20859

    trebla
    Participante

    <p>Hola a todos.<br />
    Tengo un Blog dedicado básicamente a fotografía. Recientemente cambié de hosting y me ha surgido un problema: un buen número de fotos está siendo redireccionadas al antiguo host y no aparecen. Me han dicho que debo modificar la plantilla del tema e indicar la nueva dirección, pero no sé en que lugar debe modificarse.Os ruego ayuda.<br />
    Las fotografías están físicamente en wp-content/uploads, es decir que están todas pero algunas las redirecciona a http://www.estenopo.org/albertblog/uploads/... cuando debería ir a www-acastelarnau.net/wp-content/upload/…</p>
    <p>El blog: La mirada de un ocioso (www.acastellarnau.net)<br />
    el theme utilizado es Piano-black 1.4</p>
    <p>Gracias de antemano.<br />
    Un saludo.
    </p>

  • #51093

    LGrusin
    Miembro

    Pues hiciste mal la migración o no la hiciste, debiste cambiar en la base de datos todas las referencias al antiguo dominio antes de importar los datos.

    Posibles soluciones,
    1 – Si no son muchas imágenes y suponiendo que las imágenes estén en el nuevo servidor con la misma estructura que el viejo dominio. Modifica la URL de las imágenes en cada posts para que apunte al nuevo dominio. En la Galería deben estar las imágenes, seleccionalas y así las tendrás con el nuevo dominio. Si no están en la Galería te sabes el trayecto tampoco cuesta mucho teclear para cambiar el antiguo por el nuevo dominio.

    2 – Entra en phpMyAdmin la utilidad para manejo de bases de datos de tu servidor y cambia todas las referencias al viejo dominio por el nuevo.

    Como creo que tu caso es el primero, y si sólo son las imágenes, hazlo a mano desde cada post.

    Saludos

  • #51108

    trebla
    Participante

    Gracias, LGrusin,

    entiendo el procedimiento, pero mi pregunta es ¿como?, es decir en qué apartado de PhpMyAdmin y en qué lugar de la base de datos.
    Las fotos son muchas, prácticamente todas desde el año 2008. vamos un montón. La solución de cargarlas de nuevo ya la pensé, pero resulta un palo, así que si existe una solución más “global” lo agradeceré.

    Las fotografías están todas en la base de datos, lo he comprobado en el nuevo host, así que entiendo que debe haber un lugar concreto e que se redireccionen los post, pero eso es lo que no sé, dónde está.

    Gracias de nuevo.
    Saludos

  • #51110

    almendron
    Participante

    Tal vez pueda ser útil

    http://wordpress.org/extend/plugins/search-and-replace/

    Eso sí, antes de utilizarlo debes hacer una copia de seguridad porque los cambios no son reversibles. También advierto que no lo he probado en WP 3.1 aunque sí con otras versiones y funcionó perfectamente.

  • #51134

    LGrusin
    Miembro

    Es que son varias tablas las afectadas. Como dice almendron prueba a ver si ese plugin es capaz de solucionarlo. Aunque me temo que si no sabes qué tablas son tendrás que probar una por una.

    En principio para la URL del blog es la tabla wp-options, campos Home y siteurl

    Para los posts y páginas la tabla wp_posts campo guid.

    Para los enlaces en los posts tabla wp_posts campo post_content

    (Siempre y cuando no me haya equivocado y para la versión 3.1)

    Dada la importancia de este tema yo creo que esto deberíamos ponerlo en algún sitio más visible dentro del Foro.

    Un saludo

  • #51155

    almendron
    Participante

    Acabo de mirar ahora mismo y parece funcionar todo bien.

    Si lo has solucionado, interesaría que lo pusieras para saber cómo lo has hecho por si se repite el caso.

El foro ‘Presenta tu Blog’ está cerrado y no se permiten nuevos debates ni respuestas.

Pin It on Pinterest