PHP Warning :cry:: Missing argument 3 for _cat_rows1()

Inicio Foros WordPress General WordPress.org PHP Warning :cry:: Missing argument 3 for _cat_rows1()

Etiquetado: ,

Este debate contiene 4 respuestas, tiene 2 mensajes y lo actualizó  almendron hace 7 años, 1 mes.

  • Autor
    Publicaciones
  • #22943

    lferreyra
    Participante

    <p>Estimados, tengo un problema con mi sitio, ccada vewz que quiero registrarme como usuario me arroja este bendito PHP Warning. Mi duda es si debo modificar el wp-config.php o bien si se debe modificar .htaccess (cosa que no se hacer). Tambien sucede que cuando quiero ver el perfil de un usuario me queda la pagina en blanco.<br />
    Abrí un subdomnio para prbar con otra db esto y cuando quiero registrarme me deja abanzar, pero cuando quiero ver mi dashboard me da error 500!!!</p>
    <p>Espero me puedan ayudar! Ya intenté todo, incluso agregue al wp-confi la linea "error_reporting(0);"</p>
    <p>les paso el erro y el sitio para que lo vean en vivo:</p>
    <p>http://inmo.lucasferreyra.com</p&gt;
    <p>Cuano me quiero loguear me lleva a esta pagina:</p>
    <p>http://inmo.lucasferreyra.com/?page=login&amp;page1=sign_in</p&gt;
    <p> 😥 😥
    </p>

  • #56557

    almendron
    Participante

    Además del error, el blog totalmente descuadrado y tienes problemas con los acentos.

    El error lo tienes localizado en el archivo custom_functions.php del tema que usas (línea 401). ¿Has tocado ese fichero?

    Mi consejo:

    1) haz una copia de seguridad del tema modificado

    2) vuelve a subir el tema original y ve modificando poco a poco. Lo mejor sería que lo hicieras en local. En google te saldrán bastantes páginas de cómo instalar wordpress en local con WampServer o con cualquier otro programa de las mismas características.

  • #56562

    lferreyra
    Participante

    Además del error, el blog totalmente descuadrado y tienes problemas con los acentos.
    El error lo tienes localizado en el archivo custom_functions.php del tema que usas (línea 401). ¿Has tocado ese fichero?

    Gracias por responder Almendron, sé donde esta el error, pero no se que debo poner exactamente en esas líneas.

    Acá las cito:

    function _cat_rows1( $parent = 0, $level = 0, $categories, &$children, $page = 1, $per_page = 20, &$count )
    {
    //global $category_array;
    $start = ($page – 1) * $per_page;
    $end = $start + $per_page;
    ob_start();

    foreach ( $categories as $key => $category )
    {
    if ( $count >= $end )
    break;

    $_GET[‘s’]=”;
    if ( $category->parent != $parent && empty($_GET[‘s’]) )
    continue;

    // If the page starts in a subtree, print the parents.
    if ( $count == $start && $category->parent > 0 ) {
    $my_parents = array();
    $p = $category->parent;
    while ( $p ) {
    $my_parent = get_category( $p );
    $my_parents[] = $my_parent;
    if ( $my_parent->parent == 0 )
    break;
    $p = $my_parent->parent;
    }

    $num_parents = count($my_parents);
    while( $my_parent = array_pop($my_parents) ) {
    $category_array[] = _cat_rows1( $my_parent, $level – $num_parents );
    $num_parents–;
    }

    También he intalado la plantilla sin modificar en http://test.lucasferreyra.com/

    aquí el inconveniente es cuando doy click al nombre del agente, la pantalla se queda en blanco.

    Voy a tomar tus consejos, pero si se te ocurre alguna otra solución te voy agradecer me lo comentes.

    Muchas gracias nuevamente por tu respuesta.

  • #56574

    lferreyra
    Participante

    Alguna otra sugerencia?

  • #56585

    almendron
    Participante

    El código que has puesto no tiene nada que ver con usuarios ni con su registro. No se por qué te da error en esa línea.

    ¿Has modificado algo del archivo custom_functions.php?

    Es evidente que has tocado algo del código del tema bien en ese archivo, bien en otro que hace saltar el error. De hecho, al poner el tema original se ha solucionado.

El foro ‘General WordPress.org’ está cerrado y no se permiten nuevos debates ni respuestas.

Pin It on Pinterest

Ir al contenido