Problema al actualizar de 3.1.4 a 3.2.1

Inicio Foros WordPress Instalación / Actualización Problema al actualizar de 3.1.4 a 3.2.1

Este debate contiene 5 respuestas, tiene 3 mensajes y lo actualizó  CesareMX hace 7 años, 3 meses.

  • Autor
    Publicaciones
  • #22201

    MarceFX
    Participante

    <p>Hola,</p>
    <p>Tengo varios problemas que no me permiten actualizar. Actualmente en http://www.marcefx.com tengo la versión 3.1.4 instalada, y todo va bien, pero cuando actualizo a la 3.2.1 me da error 500 y tengo que volver atrás reinstalando desde una copia de seguridad en el servidor.<br />
    He desactivado los plugins y nada, sigo teniendo el mismo error.</p>
    <p>¿Qué puede ser?</p>
    <p>Además tengo otro problema y es que no funciona bien el Mod-rewrite. Hasta hace poco iba todo bien, pero desde hace un par de días no funcionan los enlaces. Si uso permalink sí que va, así que tiene que ser algo de eso. He probado a crear el .htaccess con este código pero cuando lo subo por FTP la web ya no carga:</p>
    <p>&lt;IfModule mod_rewrite.c&gt;<br />
    RewriteEngine On<br />
    RewriteBase /<br />
    RewriteCond %{REQUEST_FILENAME} !-f<br />
    RewriteCond %{REQUEST_FILENAME} !-d<br />
    RewriteRule . /index.php [L]<br />
    &lt;/IfModule&gt;</p>
    <p>Gracias
    </p>

  • #54744

    LGrusin
    Miembro

    El archivo .htaccess lo crea WordPress cada vez que cambias la estructura de permalink. No hace falta crearlo.

    Pon la que viene por defecto. Incluso podrías dejarla así hasta que logres actualizar. Intenta hacerlo en momentos y horario de poco tráfico.

    Otra cosa no le des al botón atrás del navegador cuando hagas estas cosas.

    Un saludo

  • #54746

    MarceFX
    Participante

    Hola,
    Gracias por la respuesta. Al final conseguí solucionar lo de los permalinks. WP no me creaba el .htaccess, probando influso fon permisos 777 en la carpeta raíz. Al final lo creé manualmente y ya funciona.

    Lo que sigue sin funcionarme es la actualización, que por más que desactivo todos los plugins me sigue dando Error 500 :/ puede que sea algún problema con la versión PHP del servidor?

    Gracias

  • #54939

    MarceFX
    Participante

    Subo el tema a ver si alguien me puede echar una mano. He probado ya decenas de veces y todas resultan en error 500. Actualizando manualmente o automáticamente, con los plugins desactivados siempre da igual resultado.

    La versión de PHP es correcta. No sé qué puede ser :/

    Saludos

  • #54974

    MarceFX
    Participante

    Bueno,
    ¡Solucionado! Al final el problema era de mi tema actual, el Arras Theme. Por lo visto había que instalar una nueva versión que solucionaba este problema de incompatibilidad con la versión nueva de WP.

    Conseguí descubrir que este era el problema gracias a que hice una instalación limpia en local con MAMP y fui instalando poco a poco todo hasta dar con lo que causaba el problema.

    Saludos

  • #54995

    CesareMX
    Participante

    Hola Marce, que bien que encontraste solucion, a mi me sucedio lo mismo con el arras theme, yo fui al foro del theme y encontre la nueva version.

    Saludos

El foro ‘Instalación / Actualización’ está cerrado y no se permiten nuevos debates ni respuestas.

Pin It on Pinterest

Ir al contenido