Problema al migrar blog

Inicio Foros WordPress Dominios – Hosting Problema al migrar blog

Este debate contiene 6 respuestas, tiene 2 mensajes y lo actualizó  lococife hace 4 años, 7 meses.

  • Autor
    Publicaciones
  • #75183

    lococife
    Participante

    Hola,
    Tras una más que nefasta experiencia con el hosting de “Byethost3” (no se lo recomiendo ni a mi peor enemigo), he decidido pasarme a un hosting de pago. A la hora de migrar todo el blog, no he conseguido que se vea todavía. He seguido los siguientes pasos:

    1- Copia de la carpeta íntegra “htp-docs” desde el hosting antiguo a mi Mac.
    2- Exportación de la BBDD original a mi Mac.
    3- En el nuevo hosting, creación de una BBDD con su admin y sus permisos. Importación de la anterior BBDD y cambio en las tablas de “site URL” y “home” por las URL nuevas.
    4- Subida de toda la carpeta “htp-docs” a la nueva “public_html” (así se llama en el nuevo hosting).
    5- Cambio en el “wp-config” de los datos correspondientes a nombre de la BBDD, usuario, pass y host.

    Hasta aquí, no he tenido ningún problema, todo OK y no he obtenido ningún error de nada.
    Pero el problema está en que al intentar acceder a la página, me sale que hay un error en la línea 28 del “wp-config”, que corresponde al DB HOST. He probado a poner “localhost” que es lo que ponía antes pero me sigue dando error. He probado a la dejar la anterior y me sigue dando error. He probado a no poner nada y me sigue dando el mismo error. Tampoco me deja acceder al panel “Desktop” de WP, claro.
    A ver si alguien me puede echar una mano con esto, porque me he visto un montón de tutoriales, he leído un montón de páginas y los pasos que indican son los mismos que he hecho yo, pero no obtengo resultado alguno.

    Si necesitáis alguna información más, os la pondré encantado
    Muchas gracias a todos.
    Un saludo.

  • #75215

    lococife
    Participante

    Hola de nuevo,
    ¿Alguien tiene idea de qué puede ser?
    Me sale este mensaje, concretamente:
    “Parse error: syntax error, unexpected T_STRING in /home/cdxcusaq/public_html/wp-config.php on line 28”
    Gracias.

  • #75222

    LGrusin
    Miembro

    Posiblemente al modificar el wp-config.php hayas cometido algún error, caracteres de más, de menos, en sitios que no deben estar, etc

    Puedes eliminar (o renombrar para que compares después) el archivo wp-config.php, y WordPress te creará un nuevo wp-config.php con los valores que le vayas indicando.

    Un saludo

  • #75233

    lococife
    Participante

    Muchas gracias LGrusin de nuevo, porque me has resuelto el problema.
    Ahora sólo me queda averiguar por qué las imágenes no aparecen enlazadas.

    Muchas gracias.

  • #75239

    lococife
    Participante

    ¿Hola?

  • #75240

    LGrusin
    Miembro

    Quizás este otro hilo te aclare las dudas:
    https://ayudawp.com/foros/hilo/problemas-con-plugin-duplicator/#post-74422

    Un saludo

  • #75256

    lococife
    Participante

    Muchas gracias.
    Doy por cerrado el tema.

El foro ‘Dominios – Hosting’ está cerrado y no se permiten nuevos debates ni respuestas.

Pin It on Pinterest