Problema al migrar de servidor: todo está en Unicode

Inicio Foros WordPress Instalación / Actualización Problema al migrar de servidor: todo está en Unicode

Este debate contiene 8 respuestas, tiene 2 mensajes y lo actualizó  pfd hace 5 años.

  • Autor
    Publicaciones
  • #72599

    pfd
    Participante

    Hola a todos,
    He migrado a un nuevo servidor mediante la función de migración de Plesk y una vez redirigido el site a la nueva IP todo el site me aparece en Unicode (??Y?n?:}N????Ld??Ð?A???h).
    ¿que he hecho mal?
    Ruego que alguien me ayude, me he quedado sin sitio web.
    Gracias por adelantado por vuestra ayuda.

  • #72609

    LGrusin
    Miembro

    Yo creo que es al revés. Una copia en Unicode o UTF-8 te la ha cambiado de formato.

    Intenta mirar en la base de datos, con phpMyAdmin, el formato que tiene. Se puede cambiar… Siempre tiene que estar en UTF-8

    Un saludo

  • #72611

    pfd
    Participante

    Hola,
    He confirmado que la bbdd está en utf8, sinembargo el site continúa en unicode. Se puede ver en http://www.ejerciciodeingles.com. Agradecería alguna otra idea.
    Muchas gracias LGrusin

  • #72612

    pfd
    Participante

    Otro dato que me despista: el backoffice de wordpress se ve perfectamente, lo único que se ve completamente en unicode es el frontoffice. He verificado que que en el header tengo indicado el utf-8 así que me estoy quedando sin ideas.
    Gracias

  • #72614

    pfd
    Participante

    Sigo con mi crónica de la desesperación por si alguien puede ayudarme:
    He añadido AddDefaultCharset UTF-8 al archivo .htaccess
    He añadido Default_charset = “UTF-8” a php.ini
    La bbdd está en UTF-8
    ¿que está fallando? ¿Tan siquiera está relacionado con esto?

    Un alma caritativa que me ilumine, por favor

  • #72657

    LGrusin
    Miembro

    No sólo la base de datos, también las tablas tienen que estar en UTF-8.

    Lo que se me ocurre es que vuelvas a importar una copia una vez cambiadas tablas y base de datos a UTF-8. De todas formas habría que mirar en el backup a ver que formato tiene.

    En estos momentos no veo nada extraño en el blog.

    Un saludo

  • #72695

    pfd
    Participante

    Hola,
    He estado revisando la bbdd tabla por tabla. Había algunos casos en los que el formato no estaba en utf-8 y lo he cambiado, sinembargo el problema persiste. No entiendo la parte de tu comentario donde dices “De todas formas habría que mirar en el backup a ver que formato tiene”. ¿te referieres al backup de la bbdd?¿como lo puedo verificar?

    De momento no se ve el problema online ya que cuando veo que el problema persiste vuelvo a redirigir la IP al servidor antiguo, sinembargo mañana caduca el contrato, con lo que si no lo soluciono me voy a quedar sin web.

    ¿Alguna otra idea?

    Muchas gracias por vuestra ayuda

  • #72717

    LGrusin
    Miembro

    El backup de la base de datos es un archivo de texto. Puedes abrirlo y ver en qué formato ha guardado la base de datos. Esto quiere decir que si está en otro formato lógicamente al importar volverá a poner el que figura en el backup.

    De todas formas antes de ponerte a tocar nada, investiga que secciones del blog salen con otro formato. Títulos, post, fechas, widgets, etc. Igual la solución es más sencilla de lo que parece.

    Un saludo

  • #72908

    pfd
    Participante

    Bueno, tras días y días dándole vueltas al problema y centrándome mucho en la bb.dd. finalmente he localizado el problema. Al final opté por migrar el site pieza a pieza y he descubierto que el problema venía del plugin wp-minify, con lo que no tenía nada que ver con la bb.dd.

    Lo extraño es que no logro que funcione este plugin en el nuevo servidor, pero al menos ahora he podido mover el site y ya lo tengo funcionando.

    Muchas gracias LGrusin por tu apoyo en este tema.

    P.S. – Moraleja para los que lean esto: ¡Es el plugin, estúpido!

El foro ‘Instalación / Actualización’ está cerrado y no se permiten nuevos debates ni respuestas.

Pin It on Pinterest