Problema con Enlaces Permanentes (PermaLinks)

Inicio Foros WordPress General WordPress.org Problema con Enlaces Permanentes (PermaLinks)

Etiquetado: ,

Este debate contiene 3 respuestas, tiene 2 mensajes y lo actualizó  1000ton hace 9 años, 1 mes.

  • Autor
    Publicaciones
  • #14659

    1000ton
    Participante

    <p>Hola. Tengo instalado WP y un blog que funciona bien si no pongo ningún permalink (las entradas quedan con la URL http://1000ton.com.uy/?p=123).</p>
    <p>Si pongo la opción "Mes y nombre" (http://1000ton.com.uy/2009/10/sample-post/) los posts me devuelven el error:<br />
    "Not found. Sorry, but you are looking for something that isn’t here."</p>
    <p>Mi .htaccess es el siguiente:</p>
    <p>&lt;IfModule mod_rewrite.c&gt;<br />
    RewriteEngine On<br />
    RewriteBase /wordpress/<br />
    RewriteCond %{REQUEST_FILENAME} !-f<br />
    RewriteCond %{REQUEST_FILENAME} !-d<br />
    RewriteRule . /wordpress/index.php [L]<br />
    &lt;/IfModule&gt;</p>
    <p>Les agradezco cualquier ayuda, ya que no encuentro cómo solucionar el problema.</p>
    <p>Gracias.-
    </p>

  • #33248

    thinway
    Participante

    Prueba a dejar la línea:

    [quote]RewriteBase /wordpress/[/quote]

    como

    [quote]RewriteBase /[/quote]

    Saludos

  • #33249

    thinway
    Participante

    Por lo que he visto en tu sitio ya lo tienes arreglado. ¿Puedes explicar cómo lo has hecho para cerrar el hilo?

  • #33259

    1000ton
    Participante

    Thinway, gracias por contestar, pero no lo tengo arreglado. De lo contrario hubiera explicado y cerrado el hilo. Te explico más detalles a ver si me podés ayudar.

    Lo que vos ves que funciona es con la URL http://nodo-palola.cdmon.org/wordpress/*. Pero no funciona con el dominio 1000ton.com.uy.

    Tengo el sitio WP en el pc de casa, y como la ADSL me cambia la IP cada 12 horas, tengo el servicio de CDmon con el dominio nodo-palola.cdmon.org apuntando a la IP dinámica.

    Por otro lado tengo el dominio 1000ton.com.uy redireccionando por URL a http://nodo-palola.cdmon.org/wordpress/.

    Me interesa que la URL de mi sitio WP sea http://1000ton.com.uy. Si vos accedés a dicha URL, te muestra mi sitio WP, pero ves que todos los posts apuntan a la dirección http://nodo-palola.cdmon.org/wordpress/CaminoDelPost y no a http://1000ton.com.uy/CaminoDelPost

    Si pongo como URL del sitio http://1000ton.com.uy los caminos de los posts me los pone bien, como http://1000ton.com.uy/CaminoDelPost, pero me da el error en cada entrada y no me muestra ninguna.

    Como que el index.php no funciona bien en ese caso (tengo la última versión de WP instalada).

    Te agradezco cualquier dato que me puedas aportar.

    Saludos desde Uruguay.-

El foro ‘General WordPress.org’ está cerrado y no se permiten nuevos debates ni respuestas.

Pin It on Pinterest