Problema con Explorer al actualizar el diseño

Inicio Foros WordPress Themes y Diseño Problema con Explorer al actualizar el diseño

Este debate contiene 6 respuestas, tiene 3 mensajes y lo actualizó  almendron hace 7 años, 9 meses.

  • Autor
    Publicaciones
  • #20380

    pfd
    Participante

    <p>Hice unas pequeñas modificaciones hace unas semanas (he quitado unas imágenes) y en todos los navegadores se actualizo inmeditamente salvo en Explorer, donde continúan apareciendo. Como es un cambio menor no me preocupa, pero ahora estoy preparando un rediseño completo del blog, con lo que estoy francamente asustado.</p>
    <p>¿Qué pasos debo seguir antes de subir el nuevo diseño para que todos los navegadores recojan las modificaciones?</p>
    <p>nota: tengo wp super caché instalado.</p>
    <p>Gracias
    </p>

  • #49783

    imported_josec
    Participante

    tienes que borrar o setear el cache actual de tu navegador

  • #49784

    pfd
    Participante

    Ya lo he hecho, pero continúa sin cambiar.

    De todos modos, lo que me preocupa no es mi navegador, sino el navegador de los demás. ¿Qué debo hacer para que cuando haga un cambio en el diseño se actualice en los navegadores de todos los usuarios?

  • #49785

    imported_josec
    Participante

    no hay forma de medir eso…

    el wp super caché lo que hace es acelerar la carga del sitio en los usuarios.. y puede que el plugin no deje actualizar inmediatamemte las modificaciones

  • #49801

    almendron
    Participante

    Es muy posible que el error solo se de en la versiones 6 y 7 de Internet Explorer pues leen las etiquetas HTML como les da la gana. No así en la versión 8 que ya respeta bastante las normas.

    Prueba hacer dos hojas estilos, una para IE 6 y otra para IE 7. No es necesario repetir toda la hoja de estilos sino solo aquéllos elementos que sean necesarios para que la visualización sea correcta.

    Después en el header y antes de cerrar “head” le pones un condicional: si detecta una determinada versión de IE, entonces aplica la hoja de estilo correspondiente. Sería algo así como

    Esto valdría para la versión 6 de IE. Para la 7, cambia el número 6 por 7 en la primera línea del código.

    En cuanto al cache, desactivalo cuando hagas las pruebas.

  • #49805

    pfd
    Participante

    Vaya, muchas gracias Almendrón. Voy a mirarme esto que propones.

    Por mi parte he estado jugando un poco con IE8. Aunque quité las llamadas a las imágenes hace ya semanas, estas continuaban apareciendo. Ahora, he borrado también las imágenes del servidor y ya no aparecen. ¿guarda en memoria la llamada a la imagen pero no la imagen? No lo entiendo.

    Cada día me sorprende más el comportamiento de Explorer, parece mentira que dominen el mercado.

  • #49807

    almendron
    Participante

    Si es con IE 8, no debería darte ningún problema. De hecho, con esa versión no es necesario hacer una hoja de estilos aparte.

    Si la página donde se ve mal es la de los ejercicios de inglés, debo decirte que le he echado un vistazo con IE8 y se ve exactamente igual que con Firefox.

    Mira a ver si es que no has vaciado la caché del IE y por eso sigues viendo las imágenes.

    Y otra cosa: mira también en las opciones de super cache y comprueba si hay alguna que desactive el cache para el index. Yo uso Hyper Cache pero tengo marcada la casilla “DO NOT cache the home page so it is always fresh”. De esa forma me aseguro que la página principal siempre muestre los últimos cambios.

El foro ‘Themes y Diseño’ está cerrado y no se permiten nuevos debates ni respuestas.

Pin It on Pinterest

Ir al contenido