Problema con get_header()

Inicio Foros Comunidad Presenta tu Blog Problema con get_header()

Este debate contiene 3 respuestas, tiene 2 mensajes y lo actualizó  23r9i0 hace 7 años, 4 meses.

  • Autor
    Publicaciones
  • #21149

    josejosejose1
    Participante

    <p>Buenos días, llevo unos dias con un problema, Soy un poco inexperto en esto pero aprendiendo, he buscado mucha información y he probado bastantes cosas.. pero nada, a ver si alguien puede ayudarme:<br />
    Mi problema es el siguiente: me han montado una página usando wordpress la cual tengo alojada en un dominio de esa empresa, pero hace poco me dieron acceso ftp a los ficheros para poder modificar cosas. Tengo una copia de seguridad que intento montar en local en una particion ubuntu usando xamp. Hasta ahí todo bien. El caso es que cuando intento acceder al index:<br />
    "http://localhost/pagina/httpdocs/wp-content/themes/themes_juris/index.php"<br />
    Me da un error como este:<br />
    "Fatal error: call to undefined function get_header() in /opt/lampp/htdocs/pagina/httpdocs/wp-content/themes/themes_juris/index.php on line 1"<br />
    Algo a añadir es que, en la carpeta donde tengo el index, tengo tambien el resto de ficheros de get(header.php, foot.php y sidebar.php)</p>
    <p>Utilizo la versión: WordPress 2.9.2.</p>
    <p>He buscado infinidad de cosas por internet, pero no encuentro nada asi..<br />
    Probando he comprobado que probando con el tema que viene por defecto en wordpress(twentyten), me aparece lo mismo.<br />
    Tambien probé inicialmente haciendolo en apache en Windows XP, pero sucedía lo mismo.</p>
    <p>No se si me falta instalar alguna cosa mas, si estoy haciendo algo mal, o que.. agradeceria mucho alguna ayuda. Un saludo y gracias :)
    </p>

  • #52008

    23r9i0
    Participante

    Hola no se puede acceder directamente a el index de un theme, tienes que activar el theme y la direccion seria:
    http://localhost/pagina
    Y se mostrara el theme

  • #52011

    josejosejose1
    Participante

    Sii! Gracias, fallo mio de principiante.

    BUeno, por una parte, cuando ejecuto “http://localhost/pagina” ya consigo que salga algo. El problema es que sale el tema por defecto sin ningún dato de nada. He intentado acceder al “wp-admin” para activar el theme, pero no hay manera de que pueda entrar. Sale siempre que la contraseña es incorrecta.

    He probado a sustituir el contenido del theme default por el contenido de mi theme, pero aun así, sigue apareciendo lo mismo.

    Qué podría hacer? Hay alguna forma de activar el theme mediante algún fichero de configuración o similar?

    Un saludo y gracias por todo de nuevo 🙂

  • #52012

    23r9i0
    Participante

    comprueba que has importado bien la base de datos y que el config.php tiene los mismos datos.

El foro ‘Presenta tu Blog’ está cerrado y no se permiten nuevos debates ni respuestas.

Pin It on Pinterest