Problema con htaccess y la edicion de mis permalinks

Inicio Foros WordPress General WordPress.org Problema con htaccess y la edicion de mis permalinks

Etiquetado: ,

Este debate contiene 8 respuestas, tiene 4 mensajes y lo actualizó  elenanito hace 9 años, 7 meses.

  • Autor
    Publicaciones
  • #11584

    geo
    Participante

    <p>Hola chicos, me ha surgido un inconveniente con mis permalinks…<br />
    Resulta que personalice los permalinks de mi blog, modificando mi archivo htaccess dándole los permisos necesarios.<br />
    El tema es que tengo mi subdominio, donde también quiero tener los mismos permalinks. Pero no me deja editarlos, los quiero modificar y me dice, que ahora tengo que editar mi htaccess agregando unas líneas. Lo mismo que hice con mi dominio principal.<br />
    Pero ya esta hecho eso, lo hice anteriormente. </p>
    <p>Alguien sabe porque pasa esto?<br />
    No puedo tener permalinks que no sean los predeterminados.</p>
    <p>Si por favor, pueden darme el código que debo agregar a mi htaccess para que me deje modificarlo se los agradecería muchisimo.!
    </p>

  • #24256

    imported_Fernando
    Participante

    Tienes que crear un .htaccess en cada sitio donde tengas instalado WP, si tienes un subominio pues ahí también debe haber otro htaccess. Da permisos de escritura a la carpeta del subdominio para que WP pueda escribir en el htaccess o crearlo, o sino crealo en tu ordenador con lo que te dice que hay que poner y lo subes al subdominio.

  • #24266

    geo
    Participante

    Hola Fernando, gracias por tu tiempo y responder. Eso mismo que me explicas fue lo que hize hace un tiempo, antes de consutarles a ustedes.
    Pero no funciono, quizas por que cree/copie el mismo htaccess que el de la raiz de mi host.
    Voy a probar creando uno, solo con el código que me da WP.

    Un abrazo, luego comento como me fue.
    Que tengas un buen día. 🙂

  • #24276

    imported_Fernando
    Participante

    Si claro, de eso se trata, haz un htaccess.txt en tu ordenador. Le pones lo que te dice WP y lo subes al subdirectorio, le cambias el nombre a .htaccess y debería funcionar.

  • #24301

    geo
    Participante

    Gracias Fernando, ya esta el problema solucionado. 🙂

  • #24325

    marcosfv
    Participante

    Tengo el mismo problema en mi sitio y en el localhost. Me pueden pasar las lineas a agragar en el .htacces?

  • #24327

    imported_Fernando
    Participante

    [quote]Tengo el mismo problema en mi sitio y en el localhost. Me pueden pasar las lineas a agragar en el .htacces?[/quote]Las líneas te salen el la página de admin de los permalinks, abajo del todo 😉

  • #24328

    geo
    Participante

    marcos. Esto deberias agregar:

    [code]<IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>[/code]

    Otra solución sería, entrar a tu FTP, hacer “click derecho” sobre el archivo .htaccess y darle “atributos” Marca el siguiente: “777”
    De ese modo, WP lo editara automáticamente.

    Abrazos

  • #28619

    elenanito
    Participante

    hola buenos dias!!

    tengo un problema con los permalinks, que los pongo en modo automatico y funciona, intento cambiarlo a modo personalizado y no me deja… eso por que puede ser, intento personalizarlo con lo siguiente: /%postname%/, pero nada, en algun otro foro he visto que puede ser por el htaccess pero ya no se ni cuantas veces lo he modificado

    SOCORROOOOOOOOOOOOOOO…. S.O.S.

El foro ‘General WordPress.org’ está cerrado y no se permiten nuevos debates ni respuestas.

Pin It on Pinterest

Ir al contenido